DS Linker error - please help

Discussion in 'Other Flashing Hardware & Software' started by Syrus, Sep 9, 2007.

Sep 9, 2007

DS Linker error - please help by Syrus at 9:29 PM (1,436 Views / 0 Likes) 7 replies

  1. Syrus
    OP

    Newcomer Syrus Newbie

    Joined:
    Sep 9, 2007
    Messages:
    2
    Country:
    Brazil
    After reading glowing reviews about the DS Linker, I finally decided to buy one. Unfortunately, after 5 minutes playing with my new toy I was already utterly disappointed. I can't most games to work with this little thing. 99% of the roms I put into the flashcart end up showing only a white screen when they're loaded. I tested like 100 games, but only 6 worked.

    I updated the firmware (1.45), I changed the save types of each rom and it still didn't work. In fact, after my update, 3 of the 6 functional roms ceased to work. Now, only 3 games are working at the moment: 1. Diddy Kong Racing, 2. New Super Mario Bros and 3. Super Mario 64 DS.

    Since a lot of people here can put their DS Linker to work, I resort to your superior wisdom. Please help me on this issue. I know this is a rather common issue with this flashcart, but I can't find a direct and objetive solution to this problem anywhere else.
     
  2. quartercast

    Member quartercast GBAtemp Regular

    Joined:
    Oct 18, 2006
    Messages:
    250
    Country:
    Australia
    You shouldn't have to change the savetypes on 1.45. Just update the firmware, format the cart (using the internal formatter) and copy xmenu.dat over. Also - are you sure you haven't got dud roms?
     
  3. KFM

    Newcomer KFM Member

    Joined:
    Sep 11, 2007
    Messages:
    14
    Country:
    United States
    Yeah, you really shouldn't be having problems playing games with the Auto-DLDI and now auto-save features of the DSLinker.

    You shouldn't really need to format it, the auto-save type feature should kick in, so either change the save type to something you're certain that works, or change it to auto.
     
  4. paul1991

    Banned paul1991 Banned

    Joined:
    May 5, 2007
    Messages:
    680
    Country:
    United States
    The only reason a ROM has never run for me is because I had no save type selected and that has been fixed with the newer FWs.

    Hold A+B+X+Y while booting and it sould inform you of any problems.
     
  5. Syrus
    OP

    Newcomer Syrus Newbie

    Joined:
    Sep 9, 2007
    Messages:
    2
    Country:
    Brazil
    No, the roms are not dud. Specially because some of them worked before the firmware update. As I said, I had 6 roms working and now I've got only around 2 functional roms. 4 of them simply ceased to be playable, giving me the "White Screen of Death" instead.

    I formatted many times and the AUTO save option is not making the roms work either. No saving option (Flash 2/4, EEPROM et al) is working at all.

    Should I try a Full Format (that one that takes 2 hours)?
     
  6. KFM

    Newcomer KFM Member

    Joined:
    Sep 11, 2007
    Messages:
    14
    Country:
    United States
    Did you do a full format before you put your newest firmware version on there?

    If you've never done a full format, do one and then reinstall the firmware. If you did one before, you shouldn't need to do one again.
     
  7. tester72

    Newcomer tester72 Newbie

    Joined:
    Mar 20, 2007
    Messages:
    8
    Country:
    Singapore
    try gettin the clean rom.. i recently encounter issue after usin the new firmware. found dat it doesnt run trimmed rom.. which previus firmware i am able to run.
     
  8. venom75x

    Newcomer venom75x Newbie

    Joined:
    Sep 22, 2007
    Messages:
    4
    Country:
    United States
    help i have a problem too i formated my ds linker now all it says its

    loading menu
    error:not format!
     

Share This Page