[DS(i)/3DS] TWiLight Menu++ - GUI for DS(i) games, and DS(i) Menu replacement

Discussion in 'NDS - Emulation and Homebrew' started by Robz8, May 28, 2017.

Loading...
  1. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    TWL CPU speed is set in TWLMenu++ settings (not the game's settings), correct?
     
  2. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    Luma v10.0 has released!
    If you have Game patching turned on just to fix soft-resetting, you can now turn it off, after updating to v10.0.
     
  3. Wuigi

    Wuigi GBAtemp Advanced Fan

    Member
    6
    Sep 14, 2012
    Germany
    I tried to launch a game from a flashcard after I installed the hello kitty banner acekard update and I use the latest version of twilight menu and there are two cases:
    I select use nds-boostrap instead of kernel: Creates save, stays at whitescreen
    I select to not use nds-bootstrap: I get "Start failed. Error 1"
    Is there some special way to set up the flashcard or are there settings that need to be turned on/off?
    On the wiki there is no section on how to install the flashcard file found in the twilightmenu 7z file.
     
  4. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    There are some games that don't work from flashcard with nds-bootstrap.
    Your best bet for compatibility is with SDK5/TWLSDK games.
     
  5. jengablocks

    jengablocks Newbie

    Newcomer
    1
    May 11, 2019
    United States
    Yes, it is. I did try changing it in game settings as well.
     
  6. Wuigi

    Wuigi GBAtemp Advanced Fan

    Member
    6
    Sep 14, 2012
    Germany
    @Robz8 Are there some games that should work that I can try out to see if my setup is ok?
     
  7. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    Yes.
    I tried these, and they work:

    WarioWare Touched
    Super Mario 64 DS
    Sonic Rush
    Metroid Prime Hunters (slow loading in menus and gameplay)
    Every MegaMan StarForce game
    Pokemon Diamond & Pearl
    Grand Theft Auto: Chinatown Wars
    Kamen Rider: Dragon Knight
    Sonic Classic Collection
    Solatorobo: Red the Hunter
    Pokemon Conquest
    Pokemon Black 2
     
    Tarmfot likes this.
  8. Wuigi

    Wuigi GBAtemp Advanced Fan

    Member
    6
    Sep 14, 2012
    Germany
    @Robz8 Ok then my setup is at fault, I tried diamond and metroid already and those also just showed a whitescreen.
     
  9. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    Are you using Nightly or Release bootstrap?
     
  10. Wuigi

    Wuigi GBAtemp Advanced Fan

    Member
    6
    Sep 14, 2012
    Germany
    @Robz8 I tried nightly first, with release it has the same result.
    I don't know where the files from "akMenu Wood UI root" go though and the BOOT.NDS from the Flashcard users directory boots to Error1 for me.
    Sorry for all the questions.
     
  11. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    You only need nds-bootstrap placed on the SD card.
    Delete the "patchOffsetCache" and "fatTable" folders in "fc:/_nds/nds-bootstrap".
    It's possible the files in those folders got corrupted somehow.
    The current nightly isn't stable, btw.
     
  12. alexander1970

    alexander1970 GBAtemp allows me to be here

    Member
    12
    Nov 8, 2018
    Austria
    Austria
    Hello.:)

    Yesterday i have noticed some strange things in TWiLight v8.5.0 with @JeffRuLz´s Title Manager 0.7.0 for HiyaCFW and @Robz8´s GodMode9 v1.3.4.

    On 1 DSi + 1 DSi XL BOTH Tool works perfect without changing any setting.

    On 1 DSi i get White Screens and after a few seconds then back to TWiLight.JeffRuLz advise was to set "Direct Boot:on" in settings if it not works with TWiLight sadly no change.
    I have deleted the Settings in _nds/TWiLightMenu/gamesettings.After that GodMode9 AND Title Manager no longer make a setting file there.When you start BOTH Tools it says "Now Saving.." and get me back to TWiLight.That means BOTH Tools no longer working.

    - All 3 DSi´s can boot GodMode9 and Title Manager WITH UNLAUNCH.
    - All 3 updated the same way to v8.5.0 (HiyaCFW Helper is broken that means updated manually).
    - All 3 have the same 16 GB SD Card.
    - All 3 have Unlaunch 1.8
    - All 3 have Title Manager in the SAME Folder rom\apps\Title Manager and File is original tmfh.ndsnamed
    - All 3 SD Cards checked of Errors.
    - All 3 SD Cards formatted FAT 32 with Standard Cluster size.

    The ONLY difference: the DSi where GodMode and the Title Manager NOT works has the Memory Pit as Exploit.The other 2 has Flipnote.

    Thank you for reading and any advises and help from you.:)
     
    Last edited by alexander1970, Jun 29, 2019
    Tarmfot likes this.
  13. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    Ah. It appears I made a derp somewhere while adding the DSi homebrew check.
    I will fix this for the next version.
     
    Last edited by Robz8, Jun 29, 2019
    DarkDengar, Tarmfot and alexander1970 like this.
  14. alexander1970

    alexander1970 GBAtemp allows me to be here

    Member
    12
    Nov 8, 2018
    Austria
    Austria
    Thank you my friend.:)
    Good to know what causes this "strange" behavior.:yay:
     
  15. jengablocks

    jengablocks Newbie

    Newcomer
    1
    May 11, 2019
    United States
    Do you think the problem might be my flashcard? The CPU boost works when I launch a game from the SD card, and I'm sure all my settings are correct. I don't know what else could be causing it to not work.
     
  16. Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    Your flashcard is not the issue.
    Try turning off the SCFG setting.
     
  17. jengablocks

    jengablocks Newbie

    Newcomer
    1
    May 11, 2019
    United States
    Turned it off, doesn't seem to be working.
     
  18. Important Posts Updates
    Robz8
    OP

    Robz8 Coolest of TWL

    pip Developer
    19
    Oct 1, 2010
    United States
    I have no clue why it's not working for you.
    It works just fine for me. Try SM64DS, and wake the console from sleep mode. If the screen backlights don't turn back on, then TWL clock speed is working.


    v8.5.1

    Check here on how to update TWiLight Menu++.

    Improvement
    • Homebrew check is now completely devoid of arm7 binary size and TID checks.
      Fixes Super Princess Peach.
    Bug fixes
    • arm9 start signature is now checked after the secure area in modern homebrew (which is just 00s).
      Fixes support for homebrew such as GodMode9i and TMFH (Title Manager for HiyaCFW).
    • Quick Menu: DLP and/or Pictochat will no longer white screen, if the last-launched game is on a flashcard.
    You no longer need to hold L for the following games to work
    • Bee Movie
    • Dragon Quest IV: No longer crashes when talking to vendors in the first chapter.
     
    Last edited by Robz8, Jun 29, 2019
    Tarmfot, ber71, ShadowOne333 and 5 others like this.
  19. alexander1970

    alexander1970 GBAtemp allows me to be here

    Member
    12
    Nov 8, 2018
    Austria
    Austria
    Wow on such QUICK FREE SUPPORT i only can

    :bow::bow::bow::bow:

    From you many companies / support departments should cut off a huge slice.
    Simply a great thing !

    Thank you.:)
     
    Robz8 likes this.
  20. jengablocks

    jengablocks Newbie

    Newcomer
    1
    May 11, 2019
    United States
    Huh. Well, the backlight doesn't turn back on with the SCFG option off. I'm not sure why it still runs slower for me than it does when played from the SD. But thank you for your time!

    Edit: I ran Pokemon Pearl off the DSi's SD card with the CPU boost turned off, and the menus are still extremely fast. The problem might be my flashcard's maximum read speeds for its MicroSD card or something similar. Just leaving this here for anyone who might have the same problem.
     
    Last edited by jengablocks, Jun 29, 2019
Quick Reply
Draft saved Draft deleted
Loading...