Doing something wrong in virtualdub...

Discussion in 'General Off-Topic Chat' started by Harsky, Mar 11, 2007.

Mar 11, 2007
  1. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    After transfering the VHS to a DVD recorder and then transfering it to my HDD to be converted to AVI, I was trying to cut out a 10 minute cartoon from the tape using Virtualdub. Somehow, when I used the Xvid codec as the compression codec, I ended up with a file that was 230mb. Way too much for a VHS quality tape so I tried DIVX and it was 45mb. But when I looked at the video, it was filled with TONS of small blocks on the screen. Is there such a thing as a happy medium where the file size isn't huge but the video quality isn't bad? Or am I configuring DIVX wrong?
     
  2. Dragonlord

    Member Dragonlord Linux-Dragon of quick wit and sharp tongue

    Joined:
    Sep 17, 2003
    Messages:
    3,514
    Location:
    Switzerland
    Country:
    Switzerland
    Xvid is the best if it comes to quality versus file size. What VDub does though is using a default compression setting and this one sux in terms of file size. If you can use MEncoder ( Linux required for this as the command line version for windows, well, it sux ) this would be best. Otherwise you have to look for a separate encoding tool. Then you are mostly required to do a 2-pass encoding for getting the most out of it. So use VDub for the cutting and save it as a plain AVI ( WARNING! requires massive amount of space on a HD and AVI has a fuking 2GB file size limit! ) and then use the other tool ( whatever you choose ). VDub is a superb tool but sux at encoding. If you feel for an adventure you can try fiddling with the parameters in VDub encoding panel. Should be able to do 2-Pass encoding too but I never got it really working. For casual encoding I use MEncoder with quantizer=2 and quality=6. Gives good results.
     
  3. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,705
    Country:
    United Kingdom
    You are experiencing the main issue with video encoding there, basically it comes down to trying different configurations and testing as every video is different.

    Xvid is probably your best bet (some of the new H264 codecs can trounce Xvid and co but that is besides the point and you should not really use them in AVI), hit the video menu and make sure fast recompress or one of the options below is selected (fast recompress sounds to be what you want).
    Same menu and hit compression (or ctrl and P if you prefer), select the codec (I use FFDShow with VDub as it has an mpeg4 option and is pretty much the only VFW codec on my system). Set up as you would:
    Dragonlord is right about 2 pass, it doubles the time but quality is that much better normally. Better yet you could go constant quantisation (it might be called something different but it will have quant in there somewhere or CQ), you have no real control on the resultant filesize but quality is as good as you allow it to be)

    Oh and xvid has a cartoon mode if I recall, I only tried it a few times but for typical western cartoons it worked great (if you have some high detail/colour anime leave it alone).

    @Dragonlord the 2gig limit does not apply to newer revisions of the AVI spec (which vdub can/does use, not sure about the splitters that can handle it though (I believe most can). You might also want to try lossless codecs or a frameserver to dodge the space issues.
     

Share This Page