Does Supercard Dstwo work on the New3ds 9.6.0.24?

Discussion in '3DS - Flashcards & Custom Firmwares' started by ilamini, Mar 27, 2015.

  1. ilamini
    OP

    ilamini Newbie

    Newcomer
    1
    Mar 27, 2015
    Italy
    Hey guys,
    I read on the Supercard forum that someone can't get the Supercard Dstwo to work after updating the New3ds firmware to the latest 9.6.0.24.
    Did anyone of you update and confirm if it works?
    Many thanks
     
  2. GhostLatte

    GhostLatte Yet Another Shitposter

    Member
    13
    Mar 26, 2015
    Antarctica
    I'm pretty sure that nobody will update to the latest firmware. But, it most likely works because the dstwo has always worked on every update in the past even without offical confirmation.
     
  3. ilamini
    OP

    ilamini Newbie

    Newcomer
    1
    Mar 27, 2015
    Italy
    Well I just would like to purchase something from the eshop, that's why I'm asking.
     
  4. Ninoh-FOX

    Ninoh-FOX Otaku Gamer!!

    Member
    2
    Jan 22, 2015
    Spain
    Military base.
    Dstwo works fine in 9.6.0.24 n3ds firmware.
     
  5. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    12
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 23, 2012
    United States
    Octo Canyon
    Yeak, they stopped blocking updates for the DSTWO and other DS-mode flashcarts in the 6.x era, because the DS was officially dead and not making Nintendo money anymore, so they just stopped caring, and went after the bigger threat that is now draining their cash cow: Gateway
     
  6. ilamini
    OP

    ilamini Newbie

    Newcomer
    1
    Mar 27, 2015
    Italy
    Thank you guys. I updated to the 9.6 and the dstwo works still fine.
     
  7. Christian Rosado

    Christian Rosado GBAtemp Regular

    Member
    1
    Mar 26, 2015
    United States
    Can that card play 3DS Roms? Or just ds?
     
  8. sj33

    sj33 GBAtemp Psycho!

    Member
    10
    Oct 22, 2013
    Japan
    ^No, it only plays DS roms. You want a Sky3DS if you want to play 3DS roms on 9.6.
     
  9. Christian Rosado

    Christian Rosado GBAtemp Regular

    Member
    1
    Mar 26, 2015
    United States
    Alright thanks.its just I heard about this other dstwo which apparently works with 3ds up to 9.4 or so. Thought it was this.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice