does R4i with firmware 1.30 work on DSi 1.4E?

Discussion in 'R4 DS' started by DoomKnight, Oct 3, 2009.

  1. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    hey guys

    i am about to buy Gold R4i Revolution SDHC MicroSD and update it to the latest firmware

    does that card can work on the european DSi updated version?

    can i play american roms and japanese roms on it too?
     
  2. Xoo00o0o0o

    Xoo00o0o0o Xoo00o0o0o is in the house

    Member
    818
    54
    Apr 23, 2009
    United States
    Dallas, TX
    Stay away from r4. get a supercard ds one i, acekard 2i, ezflash vi, or a m3i zero
     
  3. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    Acekard 2i AK2i it will work right on my console?
     
  4. Xoo00o0o0o

    Xoo00o0o0o Xoo00o0o0o is in the house

    Member
    818
    54
    Apr 23, 2009
    United States
    Dallas, TX
    Yes it will work on E,U, and J consoles.
     
  5. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    sorry for bothering again, does i can play american games or japanese games with that card on my european dsi ?
     
  6. Xoo00o0o0o

    Xoo00o0o0o Xoo00o0o0o is in the house

    Member
    818
    54
    Apr 23, 2009
    United States
    Dallas, TX
    It will play any rom you put on it, just don't ask for roms.
     
  7. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    no i wont ask =)

    but another question

    upgrading the card can brick my dsi?

    cause i got a real game, pokemon platinium, and i spend a lot of money on my dsi, and i dont want it to be bricked
     
  8. Xoo00o0o0o

    Xoo00o0o0o Xoo00o0o0o is in the house

    Member
    818
    54
    Apr 23, 2009
    United States
    Dallas, TX
    uh what?
     
  9. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    i mean, can a flashcard like acekard and r4 and others can brick a nintendo dsi with 1.4e update?
     
  10. Xoo00o0o0o

    Xoo00o0o0o Xoo00o0o0o is in the house

    Member
    818
    54
    Apr 23, 2009
    United States
    Dallas, TX
    is your dsi already at 1.4
     
  11. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    yes it is, but can nintendo dsi can get briken by using a card?
     
  12. Xoo00o0o0o

    Xoo00o0o0o Xoo00o0o0o is in the house

    Member
    818
    54
    Apr 23, 2009
    United States
    Dallas, TX
    no but you better get a supercard or a m3i zero because they have firmware flashers and the ak2i doesn't. this makes it to where you don't have to have ds phat or ds lite to update the cart.
     
  13. fearofshorts

    fearofshorts GBAtemp Fan

    Member
    479
    1
    Jul 12, 2009
    Melbourne
    Dude, he's talking about the DSi, not the flashcart.
    No, nintendo can't (as far as we can tell) brick DSi's. At all.
     
  14. outgum

    outgum Pokemanz Master

    Member
    1,993
    27
    Sep 22, 2009
    New Zealand
    Hamilton, New Zealand
    jsut make sure to stop updating your DSi in the future, i have heard of things being bricked before from updating, so just dont update XD

    And yeah, dont get a R4, too many clones, Go acekard or M3 as suggested, but M3 is kinda the same as r4, Acekard is most likely the cheapest and bestest XD
     
  15. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    i am about to buy a SuperCard DSONEi

    its the most expensive, but the best
     
  16. rockstar99

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    no the acekard 2i or m3i zero are better options but acekard 2i is the best dsi cart at the moment
     
  17. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    m3i zero can update?
     
  18. rockstar99

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    both m3i and acekard can update but if you want a cart for only games get the acekard 2i a few days ago somebody reported a game not working on acekard and in 10 minutes they fixed it way faster updates
     
  19. DoomKnight
    OP

    DoomKnight Member

    Newcomer
    27
    1
    Oct 3, 2009
    i heard u need have another console to update acekard, is that true?
     
  20. rockstar99

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    yes or you can use your dsi as long as its on 1.3 or less but seeing you dont seem to have another console go for the m3 it is a greatcart too