Does anyone have a clean NAND for a Taiwan/HK Wii?

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
The title basically says it - I've got a RVL-001(HKG) Wii that has a seriously corrupted NAND - luckily, it has Priiloader and BootMii installed and working to the point where I can dump the Nand but it seems messed up enough that most tools just puke when trying to do anything with it.

I concluded that the best way to fix it would be using a tool like Punetwiin to copy over the contents from another working NAND, but I don't have access to one. Although this is an HK Wii, apparently the firmware is identical to the Taiwan version, so either should do. I currently have the console working with a rebuilt 4.3U system menu, so the hardware is obviously fine.

Edit:

OK, I've just been talking to one of my friends in Taiwan, and I'm looking for something that doesn't exist. Both the HK and Taiwan Wiis were shipped with standard Japanese firmware and operated only in Japanese. The unit I have with the Chinese localization is a hack done by the users. That's .. pretty lazy of Nintendo.
 
Last edited by trimesh,

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
won't do you any good. nands are encrypted to that specific wii. you'll brick if you use it.
You can't just flash it - but I was going to use Punetwiin, which takes two NAND images and copies the contents from one to the other while using the key (and bad block map) from the target machine. It doesn't work for E-shop titles because the console ID in the ticket is wrong (since it's the new one), but it can handle system titles with no problem.
 
  • Like
Reactions: cearp

DEMONGreninjaPG

Well-Known Member
Newcomer
Joined
Jun 8, 2022
Messages
75
Trophies
0
Age
13
Location
Arkansas
Website
www.facebook.com
XP
108
Country
United States
You can't just flash it - but I was going to use Punetwiin, which takes two NAND images and copies the contents from one to the other while using the key (and bad block map) from the target machine. It doesn't work for E-shop titles because the console ID in the ticket is wrong (since it's the new one), but it can handle system titles with no problem.
im dealing with the samething me my 2 wiis but my main wii is so corruted to where it only boots to bootmii beyond fixable but my secondary has just a corruted menu on i installed the 1.0u menu on it with my stupidity it is fixable but i have to have a gamecube controllor smash bros melee and mario cart wii which i only have mario cart wii
 

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
im dealing with the samething me my 2 wiis but my main wii is so corruted to where it only boots to bootmii beyond fixable but my secondary has just a corruted menu on i installed the 1.0u menu on it with my stupidity it is fixable but i have to have a gamecube controllor smash bros melee and mario cart wii which i only have mario cart wii

If you can get BootMii to run, then it's 100% fixable, although you might lose all the data on the console.
 

DEMONGreninjaPG

Well-Known Member
Newcomer
Joined
Jun 8, 2022
Messages
75
Trophies
0
Age
13
Location
Arkansas
Website
www.facebook.com
XP
108
Country
United States
lol its not even reading the nand so it beyond fixable

and my second wii is just corruted wtih another menu i installed to to what would happen and corruted but if i can expliot the system with recovery mode i can remove it
 

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
Rather than punetwiin, just use ohneschwanzenegger. U don't need a donor nand

I don't know how - these units show on the system menu as being x.xJ and boot Japanese discs - but the system menu is mostly in traditional Chinese. I've heard some mention of a "T" pseudo region, but ohneschwanzenegger/NUSnandbuilder can't recognize it.
 

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
lol its not even reading the nand so it beyond fixable

and my second wii is just corruted wtih another menu i installed to to what would happen and corruted but if i can expliot the system with recovery mode i can remove it

If it's starting BootMii then it must be able to read the NAND, because that's where the modified boot2 is stored and BootMii won't start without that.

You should still be able to dump the NAND even if it's entirely trashed, because the BootMii NAND dumper just writes physical NAND blocks - and that dump has enough information (factory bad blocks, boot area (first 6 blocks) and the console keys) to build a new NAND from scratch.

And for the second Wii recovery mode is part of the system menu - so it's it not booting at all (say because you didn't install the associated IOS) you won't be able to get into recovery mode.
 

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
12,851
Trophies
2
Age
36
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
7,415
Country
Cyprus
I don't know how - these units show on the system menu as being x.xJ and boot Japanese discs - but the system menu is mostly in traditional Chinese. I've heard some mention of a "T" pseudo region, but ohneschwanzenegger/NUSnandbuilder can't recognize it.
I could be wrong, but as I understand it your wii is JPN region, with language/location settings set to Chinese (which is built into the J system menu)

Like when you first turn on your wii and do the initial set up, it will prompt you to choose a country or language or both, I don't recall exactly. But whatever you set this to will not change the system menu version from #.#J
 

DEMONGreninjaPG

Well-Known Member
Newcomer
Joined
Jun 8, 2022
Messages
75
Trophies
0
Age
13
Location
Arkansas
Website
www.facebook.com
XP
108
Country
United States
If it's starting BootMii then it must be able to read the NAND, because that's where the modified boot2 is stored and BootMii won't start without that.

You should still be able to dump the NAND even if it's entirely trashed, because the BootMii NAND dumper just writes physical NAND blocks - and that dump has enough information (factory bad blocks, boot area (first 6 blocks) and the console keys) to build a new NAND from scratch.

And for the second Wii recovery mode is part of the system menu - so it's it not booting at all (say because you didn't install the associated IOS) you won't be able to get into recovery mode.
its not even reading a nand on the wii nand that is what im trying to say dammit
 

DEMONGreninjaPG

Well-Known Member
Newcomer
Joined
Jun 8, 2022
Messages
75
Trophies
0
Age
13
Location
Arkansas
Website
www.facebook.com
XP
108
Country
United States
my main wii will no boot the menu at all not even priiloader just bootmii which is not reading the nand on the wii and my secondary wii's menu so i should be able to uninstall the wad i installed with the disk exploit
 

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
Unfortunately
I could be wrong, but as I understand it your wii is JPN region, with language/location settings set to Chinese (which is built into the J system menu)

Like when you first turn on your wii and do the initial set up, it will prompt you to choose a country or language or both, I don't recall exactly. But whatever you set this to will not change the system menu version from #.#J

Unfortunately, there is no language select either on the regular Japanese Wii or the HK/TWN version.

Here are some screenshots:

Regular US Wii settings page 3 for reference:

4 menu options including "Language" and "Country"
US_Menu_PG3.jpg


Standard Japanese Wii settings page 1

Version is shown as 4.3J and the text is in Japanese
jpn_menu_pg1.jpg


Japanese Wii settings page 3

Only two options - upper is "Update" and the lower is "Initialize"
JPN_menu_pg3.jpg


HK Wii settings page 1

Still showing 4.3J, but now the options are all in (traditional) Chinese:
HK_Menu_PG1.jpg


Setting menu PG3 on the HK Wii

Same two options as the regular Japanese menu with no language or region select.
HK_Menu_PG3.jpg
 

trimesh

Well-Known Member
OP
Newcomer
Joined
Oct 10, 2012
Messages
59
Trophies
0
Location
Hong Kong
XP
117
Country
Hong Kong
i do not understand japanize and my problem is way worse beyond fixable on my main wii and fixable on my main wii

That post was actually for xFlak and about the problem I'm having.

All I'm saying is that if you can get BootMii to run (presumably as boot2) then I'm really surprised you can't dump the NAND, because I have literally never seen that - even on machines that had sufficiently corrupted filesystems that the system menu instantly crashed. What exactly is BootMii displaying when you try to do a NAND dump?

On your other Wii, I obviously don't know what's wrong with it - but if you just installed a system menu WAD without the correct IOS then it's bricked and recovery mode is not going to help you.
 

DEMONGreninjaPG

Well-Known Member
Newcomer
Joined
Jun 8, 2022
Messages
75
Trophies
0
Age
13
Location
Arkansas
Website
www.facebook.com
XP
108
Country
United States
That post was actually for xFlak and about the problem I'm having.

All I'm saying is that if you can get BootMii to run (presumably as boot2) then I'm really surprised you can't dump the NAND, because I have literally never seen that - even on machines that had sufficiently corrupted filesystems that the system menu instantly crashed. What exactly is BootMii displaying when you try to do a NAND dump?

On your other Wii, I obviously don't know what's wrong with it - but if you just installed a system menu WAD without the correct IOS then it's bricked and recovery mode is not going to help you.
i got it to boot into recovery mode when i first bricked it but i somehow manage to split the gamecube controller mother board in half
 

DEMONGreninjaPG

Well-Known Member
Newcomer
Joined
Jun 8, 2022
Messages
75
Trophies
0
Age
13
Location
Arkansas
Website
www.facebook.com
XP
108
Country
United States
That post was actually for xFlak and about the problem I'm having.

All I'm saying is that if you can get BootMii to run (presumably as boot2) then I'm really surprised you can't dump the NAND, because I have literally never seen that - even on machines that had sufficiently corrupted filesystems that the system menu instantly crashed. What exactly is BootMii displaying when you try to do a NAND dump?

On your other Wii, I obviously don't know what's wrong with it - but if you just installed a system menu WAD without the correct IOS then it's bricked and recovery mode is not going to help you.
its showing that it is but all of it is gray blocks on my main wii and then stop after completed
in simulation mode
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: I don't look like a nerd lol