Do you think I shoud update my vita?

Discussion in 'PS Vita - Hacking & Homebrew' started by Reploid, Dec 4, 2015.

  1. Reploid
    OP

    Reploid GBAtemp Advanced Fan

    Member
    572
    232
    Jan 20, 2010
    Serbia, Republic of
    I have a vita with 3.52 fw, so it could use that e-mail exploit, that's pretty useless to me, since I don't care about PSP emulation stuff. I'm trying not to update without a good reason, waiting for a miracle of a full Vita jailbreak. But now they giving Freedom Wars away in PS+ and I would like to try it. Buuuut, I'll have update fw and to lose acces to e-mail exploit.
    So, what do you think? Is this exploit worth to keep it? Or I should not want anything more than PSP emulation from and move on for now to play a game at least, vita don't have much of those, as anybody can tell.
     
  2. TehCupcakes

    TehCupcakes GBAtemp Regular

    Member
    250
    141
    Apr 5, 2013
    United States
    There isn't really reason to believe a native hack will come any time soon, and much less that it will come through the e-mail exploit. There was very little difference between fw 3.52 and 3.55, so it seems very unlikely that any other exploit existing in 3.52 would not be present in 3.55. Speculation: If a new native hack does show up, it will likely be 3.55+. So in my opinion, you might as well update.

    That being said... If you're interested in hacking at all, I can't think of a good reason to ignore ePSP altogether. You really have zero interest in playing PSP games (that aren't available for purchase on PSN), SNES games, MegaDrive games, or similar on your Vita? If you have any PSP games on your Vita (or a PS3 that can transfer one of the free demos to it), you might as well install ARK on 3.52, then update to 3.55. That way you have it in case you ever want it without the need to buy Mimana Iyar Chronicles.
     
  3. Reploid
    OP

    Reploid GBAtemp Advanced Fan

    Member
    572
    232
    Jan 20, 2010
    Serbia, Republic of
    I have real PSP still, so... I think I'll just update as you suggested. Thanks for your cooperation.
     
  4. TehCupcakes

    TehCupcakes GBAtemp Regular

    Member
    250
    141
    Apr 5, 2013
    United States
    Fair enough. Guess I just missed the obvious. Lol. Still more convenient to have it on one device, imo, but suit yourself. XD
     
  5. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    If you haven't updated yet, keep in mind that the email exploit being patched also breaks the ability to install custom bubbles for content. Which, unless I missed something, includes VHBL stuff and not just ePSP.

    edit: I know the ePSP stuff does still work in 3.55, you just need a $10 game to install it. I assume VHBL can be ported to work with that game as well if it hasn't already.
     
    Last edited by Aroth, Dec 5, 2015
  6. SmellyPirateMonkey

    SmellyPirateMonkey GBAtemp Fan

    Member
    397
    110
    Sep 18, 2015
    United States
    I wouldn't update. Didn't you see the news on Wololo? 3.52 and below. Backups are kinda possible now. You have to have the cartridge in the system at least once every power cycle though. This could lead to something better so I'd wait and see where it goes before updating
     
    Last edited by SmellyPirateMonkey, Dec 5, 2015