Do you HAVE to update wii to paly newer games?

Discussion in 'Wii - Console and Game Discussions' started by MrBananman, Jul 15, 2009.

Jul 15, 2009
  1. MrBananman
    OP

    Newcomer MrBananman Member

    Joined:
    Jul 14, 2009
    Messages:
    49
    Country:
    United States
    So, do you HAVE to update the wii to v 4.0 to play the newest games? I brick blocked some new games like punch out, and they worked fine at the disc screen, but after i hit start, I get the blank black screen and my wiimotes wont connect to the wii. I'm not operating on 4.0, because I am using homebrew channel to install and play wiiware games fine. Anyone have any ideas here.

    If it matters, the games were scrubbed according to the nfo's, which i then brick blocked and burned. Again, the disc screen recognizes it, but when i hit play i get a blank black screen.
     
  2. supermodchips

    Member supermodchips GBAtemp Regular

    Joined:
    May 24, 2009
    Messages:
    291
    Country:
    Australia
    Rather than needing an upadte, most new titles use new IOS that are usually gained from updating. Simply install the correct ones and it should work.
     
  3. MrBananman
    OP

    Newcomer MrBananman Member

    Joined:
    Jul 14, 2009
    Messages:
    49
    Country:
    United States
    So a normal wii update will let my newer games work since it will install the new IOS and use my mod chip to play it, but installing wiiware will be impossible due to homebrew, wad installer, and softmod hacks requiring older IOS's?

    Ok makes sense, but how did brick blocker work in the past? Werent people not updating, and then playing the games then? Did games always need the newest IOS to to play?
     
  4. wchill

    Member wchill Resident chillxpert

    Joined:
    Jun 12, 2008
    Messages:
    1,407
    Country:
    United States
    A normal Wii update will work. WiiWare is still possible.
    You could try using GeckoOS, it should block updates without prepatching, enable region free and also install IOSes without updating.
     
  5. vergilite

    Member vergilite GBATemps Regular Clown

    Joined:
    Apr 14, 2009
    Messages:
    737
    Location:
    Liv-Liv-Liverpool YEAH!
    Country:
    United Kingdom
    don't know about palying games [​IMG](nice title) but i suppose its not needed although you will keep having to install required IOSs for some games
     
  6. MrBananman
    OP

    Newcomer MrBananman Member

    Joined:
    Jul 14, 2009
    Messages:
    49
    Country:
    United States
    Ok well then screw it, I know the games will work If I burn them straight and play them with my modchip. Wiiware is nothing special to me and I have a GC rom disc for the old games. Thanks for your help guys.
     

Share This Page