Do WII titles need BrickBlocker with Backup Loader 0.3?

Discussion in 'Wii - Hacking' started by delage13, Oct 29, 2008.

  1. delage13
    OP

    delage13 Newbie

    Newcomer
    4
    0
    Oct 29, 2008
    Canada
    I haven't been able to find in the forums any definitive answer that ISOs need to be patched to prevent auto updates with non-regional games. I have an NTSC system and want to run PAL games.

    Some have worked so far but I don't want to risk it now that I have the loader working.

    If this has been answered elsewhere please direct me to the link, and I will read it.

    Thanks.
     
  2. vic1337

    vic1337 Member

    Newcomer
    46
    0
    Oct 24, 2008
    United States
    I have the same question, i am playing the soul eater japanese game without any problem but i don't know well if it is the same with all games.
     
  3. UrkeytaY

    UrkeytaY GBAtemp Regular

    Member
    115
    0
    Sep 18, 2008
    United States
    Since it really doesn't take long to brickblock/regionfrii any iso...you might as well run every iso you have if you're paranoid about it.
     
  4. NeoGenesis

    NeoGenesis Member

    Newcomer
    39
    0
    Sep 24, 2008
    Canada
    Canada
    It would still be nice to have a definitive answer [​IMG]
     
  5. kedest

    kedest GBAtemp Psycho!

    Member
    3,287
    110
    Feb 6, 2007
    Netherlands
    I'm curious about something else: does the backup loader take care of the 001 protection?
     
  6. erolz

    erolz GBAtemp Fan

    Member
    459
    12
    Jul 22, 2008
    Belgium
    would like to know too
     
  7. Tichinde925

    Tichinde925 Marth Ditto Money Match?

    Member
    1,096
    0
    Jul 14, 2008
    United States
    Warwick, Rhode Island
    No because the backup loader wont let you install any updates from the discs. So you can play any region games.

    You only need brickblocker if you dont have starfall, have a modchip, and launch games via the disc channel. Because then, it will ask you to update before you can play.
     
  8. NeoGenesis

    NeoGenesis Member

    Newcomer
    39
    0
    Sep 24, 2008
    Canada
    Canada
    Ok, I'm happy with that, saves a bit of time.
    [​IMG]
     
  9. Maikel Steneker

    Maikel Steneker M3 Fanboy

    Member
    3,396
    34
    May 16, 2007
    Netherlands
    As far as I know Backup Launcher 0.3 is still based on Gecko OS. Gecko OS doesn't let you install any updates, even if you're in the same region. I think WiiGator just wrote because he doesn't want mad people whine about their bricked Wii's.
     
  10. wiifan08

    wiifan08 Member

    Newcomer
    32
    0
    Oct 26, 2008
    United States
    That's the true, i already play 3 japanese games in my ntsc wii using backuplauncher 0.3 and no problems at all.
     
  11. hetster

    hetster Advanced Member

    Newcomer
    55
    0
    Oct 17, 2008
    thats different from running a backup via launcher in a non hardware modded wii..i think its not possible as backuploader 0.3 uses geckos..
     
  12. Starfire12

    Starfire12 Member

    Newcomer
    36
    0
    Jun 24, 2008
    Better safe than sorry i think.
    That's why i brickblocked all of mine. Also i might want to get myself a modchip eventually for the convenience and the GameCube games, then it'll be good to have the update removed on my backups.
     
  13. GhostSonic

    GhostSonic GBAtemp Regular

    Member
    188
    0
    Oct 12, 2008
    United States
    The back up loader ignores updates, so no, not at all. There's no point in doing it unless you plan on getting a modchip or something.
     
  14. toastert2003

    toastert2003 GBAtemp Regular

    Member
    119
    0
    Aug 8, 2008
    United States
    Ghost (or anyone), the backup loader just bypasses the update section of the disc, and goes straight to the game... is this 100% verified? At least until the time of this posting?
     
  15. Tichinde925

    Tichinde925 Marth Ditto Money Match?

    Member
    1,096
    0
    Jul 14, 2008
    United States
    Warwick, Rhode Island
    Yes, thats what it does.
     
  16. percu

    percu Newbie

    Newcomer
    4
    0
    Mar 8, 2007
    United States
    So, no need to BrickBlocker if using the launcher, but what about the 001 error?
    I have a 3.2U with modchip (not patched) and want to know if it's possible to bypass this error without updating the modchip.
    Maybe starfall is the solution?
    Thx.