Do I upgrade from 1.4.1 to 1.4.3? Plus a couple of other questions.

Discussion in 'Acekard' started by Toukey, Dec 18, 2011.

  1. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    I have a DSi XL currently running version 1.4.1. I'm not sure if there is any advantage to me upgrading my software to 1.4.3 besides being able to use the online store (however I have done a lot of looking around the web in the last few days and it appears that some of the recent games will only work with this new update).

    If I do decide to update to 1.4.3:

    - can I update from 1.4.1 directly to 1.4.3?
    - do I need to flash my cart in my DSi XL which is currently running 1.4.1 or can I just copy and paste the new files and loaders onto my current SD card.
    - will my current SD card need to be formatted (therefore losing any saved games)? I will look back through old threads to see how to do this (but a link would be great;))
    - I do have a new SD card here, so should I format this first and the load the correct files and loaders and games (would the games be saved if I copied all of the games from the previous card to a folder on my PC)?
    - if I do use the new SD card, would I then be able to use the one I currently have 'as is' or would I need to put the updated files and loaders on it?
    - once this is done, do I then connect the DSi XL to wifi and proceed with the update to 1.4.3?

    I am sorry for all of the questions, but haven't been able to find answers to these questions.

    I have tried to look at the n00b's guide, but I currently on a Mac and it wouldn't open. Can this only be opened on a PC?

    Thanks in advance :)
     
  2. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    You do not need to update your DSi firmware to run the latest games (that is only relevant to the 3DS firmware and 3DS games).

    If you decide to update your DSi then download the bootloader patch from here and run it before you update your DSi.

    No you do not need to format your SDHC card.

    The firmware updater on the DSi will automatically update you to the latest DSi firmware if you choose to update.
     
  3. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    Thanks so much for your quick reply Buleste.

    So to upgrade it is as simple as flashing my cart with the bootloader patch on the SDHC card and then loading on the latest files and loaders (after remove the old files and loaders) and then the games, then update the DSi XL via WiFi?

    Sorry if this is a stupid question, but it's OK for the SDHC to have other stuff (games etc) on it while flashing the cart?
     
  4. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    If you're already on the latest version of AKAIO then there's no need to update anything else on the cart other than the bootloader.

    Having Games etc on the SDHC card will not affect the updating of the bootloader in any way.
     
  5. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    Thanks for your patience Buleste :yay:. I don't think I have the latest version of AKAIO as the last time I set up my Acekard was in November 2010.

    I really haven't played my DSi much, so I have decided to give it to my son, but want to really make sure I don't muck up updating it as he is going to get it for Christmas.
     
  6. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    Update to the latest version of AKAIO first and make sure that is running fine first and then run the bootloader update is probably the best way to go IMO.
     
  7. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    Thanks to your guidance I bit the bullet and decided upgrade to the latest AKAIO, I have also run the bootloader too and know have the Chronicles of Narnia icon! So now it is safe to update the DSi XL via WiFi? I can also remove the bootloader from the root menu of my SDHC card?
     
  8. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    Remover the bootloader update and you can update your DSi.
     
  9. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    Thanks so much :D

    I did spend quite a lot of time looking for the latest version of ak2i moonshell, but couldn't find any links anywhere (I could only see a ak2 version). I did have a version on my SD card, but took it off to update the AKAIO, would this be OK to load back on or would a newer version be better?
     
  10. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    Moonshell hasn't been updated for a long time so all you need is the 2.10 stable version (just google) and the softreset to get you back to AKAIO (Google "softreset_for_Moonshell2.rar" and extract the AKFS.nds into the resetmse folder in moonshell).
     
  11. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    Now I finally have a second micro SD I can write my sons's games to I have put Moonshell on it too, this is what I have on the card.

    Folders - _aio, 2010002161705_moonshell210stable, DustBox, Games, moonshl2
    nds files - akmenun4.nds, moonshl2.nds, moonshl2_AltLoader_DKPr27.nds, moonshl2_DirectBoot.nds

    at lot of this stuff was extracted automatically when I followed the set up prompt. Am I good to go now? I have downloaded the softrest and will put the AKRF.nds into the restmefolder when I have a bit more time on my hands.
     
  12. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    You do not need the 2010002161705_moonshell210stable folder as this just contains the install files and you will not need moonshl2_AltLoader_DKPr27.nds, moonshl2_DirectBoot.nds either as they are there only if moonshell fails to work.
     
  13. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    I finally got around to installing moonshell and it appears to be working OK, I just need to download some stuff to go in the folder, however when I push the start button and tap exit to firmware I get the message 'cannot locate RPGS.nds'.

    Any clues for a fix?
     
  14. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    For the softreset to get you back to AKAIO (Google "softreset_for_Moonshell2.rar" and extract the RPGS.nds into the resetmse folder in moonshell).
     
  15. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
  16. Toukey
    OP

    Newcomer Toukey Newbie

    Joined:
    Dec 18, 2011
    Messages:
    8
    Country:
    Australia
    Thanks so much for your help! I have heaps of games and a working movie now and I'm sure there will be a really happy boy on Christmas Day :D
     
  17. iTStorm

    Newcomer iTStorm Member

    Joined:
    Dec 11, 2011
    Messages:
    38
    Country:
    India
    - can I update from 1.4.1 directly to 1.4.3?
    Yep.
    - do I need to flash my cart in my DSi XL which is currently running 1.4.1 or can I just copy and paste the new files and loaders onto my current SD card.
    You need to flash it with the firmware update on acekard.com
    - will my current SD card need to be formatted (therefore losing any saved games)? I will look back through old threads to see how to do this (but a link would be great;))
    Nope
    - I do have a new SD card here, so should I format this first and the load the correct files and loaders and games (would the games be saved if I copied all of the games from the previous card to a folder on my PC)?
    If the save files are there too, yeah the games would be saved
    - if I do use the new SD card, would I then be able to use the one I currently have 'as is' or would I need to put the updated files and loaders on it?
    You can use it as is, but you should have the latest updated version of AKAIO (which is currently 1.8.9) so, yep, you need to put AKAIO on it.
    - once this is done, do I then connect the DSi XL to wifi and proceed with the update to 1.4.3?
    Yeah.

    EDIT: Sorry, didn't see the reply above, I'll leave this here though, incase if someone else needs it.
     

Share This Page