Question Do I have to update in order to play online?

Discussion in 'Switch - Hacking & Homebrew' started by Paiuand, Jun 15, 2017.

  1. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Hey,
    I dont own a switch currently but im probably gonna get one once Spla2n comes out, and my question here is:
    If i bought it and it was version 2.0, do i have to update to the latest version in order to play Spla2n?
    Or Online Services in general?
    Thanks in advance! :D
     
  2. lembi2001

    lembi2001 GBAtemp Regular

    Member
    214
    169
    Dec 29, 2015
    When you buy it it will probably be on 1.0 so you will more than likely have no choice but to update,
     
  3. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Ok, thanks
     
  4. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Well i still have my question, will i need to be on the latest software to play online or not?
     
  5. Omegadrien

    Omegadrien GBAtemp Advanced Maniac

    Member
    1,713
    530
    Nov 4, 2015
    France
    Pokéland
    Yes, obviously, you have to be on the latest firmware to play online.
     
    Last edited by Omegadrien, Jun 17, 2017
    Paiuand likes this.
  6. thedetire

    thedetire Member

    Newcomer
    18
    14
    Apr 20, 2012
    Netherlands
    No, you don't have to be on the latest one. If you can boot the game you can play online (for now).
    The only exception is that some games will include an update, but that's not always the latest firmware.

    Take Arms for example, it requires you to update to 2.1 to BOOT UP the game but not to 2.3, the latest one.
    You'll play online just fine with 2.1.
     
    Omegadrien likes this.
  7. Omegadrien

    Omegadrien GBAtemp Advanced Maniac

    Member
    1,713
    530
    Nov 4, 2015
    France
    Pokéland
    OK, good to know, thanks for the precision. :P

    I hope Nintendo will not force the switch to be on the latest fw to use online features.
     
  8. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Yeah me too, thanks!
     
  9. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,899
    5,048
    Mar 17, 2010
    Norway
    Alola
    I suggest updating it to 2.3 when you get it. Pegaswitch is confirmed working on 2.3, but later updates may block it.
     
    peteruk likes this.
  10. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Sure, i will get it when the Spla2n pack comes out so i bet i will have to update.
     
  11. peteruk

    peteruk GBAtemp Maniac

    Member
    1,403
    648
    Jun 26, 2015

    See this is what confuses me, others on the site have suggested best to stay on 2.0 but you have suggested to move up to 2.3

    I have always found your advice really helpful and feel I should be following it again but it contradicts others

    What to do
     
  12. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Well, there is no way to update to 2.0, only 2.1 via Arms or other games and between version 2.1 and 2.3 i think its best to be on 2.3, i think he means this....

    — Posts automatically merged - Please don't double post! —

    And if you want to play online then you must be above 1.0
     
  13. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,899
    5,048
    Mar 17, 2010
    Norway
    Alola
    2.0 is the best firmware right now, but it's not really an option if you want to play Splatoon. ARMS is confirmed to require 2.1 and there's no reason to think Splatoon will be any different. It might even require 2.2/2.3.

    Edit: Anyway, there's nothing useful you can do with the browser exploit right now so there's no benefit in staying on 2.0. It may be useful in the future but by then the 2.3 exploit should be released anyway.
     
    Last edited by The Real Jdbye, Jun 18, 2017
    peteruk likes this.
  14. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    The problem is that everything stays private for a while. Ok, pegaswitch works on 2.3, but who says there aren't private deeper exploits that were patched since 2.0?
    So yeah, when it comes to public stuff, you can update to 2.3, but it doesn't mean it's a good idea... except that it's necessary to play some games.
    Your choice in the end :P
     
    peteruk likes this.
  15. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    Well, since 3.0 is out what should i do now if i get it?
    If Spla2n updates the console to like 2.3, should i stay on that or just go 3.0?
    And is it still possible to play online games on a lower version?
     
  16. MSco

    MSco GBAtemp Regular

    Member
    147
    25
    Nov 2, 2016
    Gambia, The
    Did anyone manage to play online or access eshop with a lower firmware than 3.0, since 3.0 is out?
     
  17. Paiuand
    OP

    Paiuand GBAtemp Fan

    Member
    311
    18
    Aug 24, 2015
    Iraq
    No idea
     
  18. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,899
    5,048
    Mar 17, 2010
    Norway
    Alola
    Update to 3.0, there's nothing useful for end users that was patched and tons of improvements were added.