Do any games need to be patched with the newest firmware?

Discussion in 'CycloDS' started by abrack08, Mar 3, 2010.

  1. abrack08
    OP

    Newcomer abrack08 Advanced Member

    Joined:
    Feb 25, 2009
    Messages:
    58
    Country:
    United States
    Does LoZ Spirit Tracks work on Cyclo with the newest firmware without needing to be patched?

    Are there any fairly new, popular games that need to be patched, even if you have 1.57?
     
  2. EyeZ

    Member EyeZ GBAtemp Addict

    Joined:
    Dec 4, 2009
    Messages:
    2,336
    Country:
    United Kingdom
    Spirit Tracks plays clean (no patching), also i don't have any new game on my Cyclo that needs to be patched.
     
  3. DeMoN

    Member DeMoN GBAtemp Guru

    Joined:
    May 12, 2004
    Messages:
    7,647
    Country:
    United States
    Here's a compatibility list: http://cyclods.ject.pro/main:start
    As of now with firmware 1.57 final, no game needs to patched to be played, although some have minor problems (listed in the website I gave you).
    In the future, you can expect that games will have new anti-piracy measures placed in them, so you can either wait for a patch from an unofficial source, or wait for Team Cyclops to release a beta firmware that fixes the game.
     
  4. Tanas

    Member Tanas GBAtemp Addict

    Joined:
    Aug 19, 2006
    Messages:
    2,258
    Country:
    United Kingdom
    Even Alice in Wonderland works when when all others card fail at the anti protection, apart from the Edge and the mighty SCDS1.
     
  5. abrack08
    OP

    Newcomer abrack08 Advanced Member

    Joined:
    Feb 25, 2009
    Messages:
    58
    Country:
    United States
    Thanks for the quick replies, and thanks for the link DeMoN
     
  6. sfg

    Member sfg GBAtemp Regular

    Joined:
    Oct 26, 2009
    Messages:
    299
    Country:
    United States
    I think most of the problems in the list DeMoN linked to are fixed, the list is just not updated.
     

Share This Page