Disc Err (1938)

Discussion in 'Wii - Hacking' started by wseyller, Jun 10, 2011.

Jun 10, 2011

Disc Err (1938) by wseyller at 12:54 PM (2,267 Views / 0 Likes) 8 replies

  1. wseyller
    OP

    Newcomer wseyller Newbie

    Joined:
    Jun 10, 2011
    Messages:
    4
    Country:
    United States
    I just recently got a wii.

    At first I would download several games in ISO format. I would burn to dvd, and I have no problems. Burned about 15 games this way and all work.

    Afterwards I used the Wii Backup Manager and converted to WBFS to make the file size smaller and got rid of the ISO.

    Lately I have downloaded more games and converted to WBFS format right away before burning (Imgburn). Then later i would use Wii backup manager to convert back to ISO and then I have burned 3 games so far and I get this same error. Games: Bolt, Fantasy Aquarium World, and Kawasaki Quad Bikes.

    I used this guide a couple weeks ago to mod my wii. http://gbatemp.net/t171901-modify-any-wii-4-3-below
    It looks like neogamma is trying to load it but is just halts and shows "Disc Err(1938)".

    I convert to WBFS because of the small file size of some games and also because I intend on using a usb hard drive later down the road.

    Question: Going from ISO to WBFS to ISO, then burning causing my problem???

    Question: If so, do I have to redownload the games or anyway around it? Am I doing something wrong"

    I wanted to ask before I waste anymore dvd-r.

    Update: I have tried another game...Mario kart and it works converting from WBFS to ISO then burning. I looked up Err 1938 and I can find a single reference to it on the internet.
     
  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Use the latest NeoGamma beta, it shows "proper" dvd error codes, but these won't help you much. The chance that you get the standard error is very high, because you get it on:
    DVD+R without bitsetting
    bad burns
    DL + drive can't read DL
    Laser is dying
     
  3. wseyller
    OP

    Newcomer wseyller Newbie

    Joined:
    Jun 10, 2011
    Messages:
    4
    Country:
    United States
    I am going to try out the NeoGamma R9 beta 49 fixed later on. The games I tried were Bolt, Aquarium Fantasy World, Kawasaki Quad bike, New super mario bros wii.

    I doubt my laser is dying. The first 20 games I burned work great. Just the last 4 don't.

    I don't use DL or DVD+R

    Bad burn, maybe but that would be too many coincidences. I could see a bad download more likely if that is a possible cause of this particular error.

    I don't believe is has anything to do with my use of WBFS files that I described in my first post. I went back and burned Mario Kart again after converting it back to ISO and it worked fine. Then tried to burn the Kawasaki game again with same error. Gonna try the Neogamma upgrade and if needed some other suggestions provide to me in another forum. I will post back. I may just need to try another download.
     
  4. wseyller
    OP

    Newcomer wseyller Newbie

    Joined:
    Jun 10, 2011
    Messages:
    4
    Country:
    United States
    Well here is what I have done so far.

    I first updated to Neogamma R9 b49. I let my cios version alone for now.

    I tried all four games and got this error: DVD Err (00031100) Apploader loop, then it quickly changes to "Recovered read error". These are the four original games I used Wii backup manager to convert WBFS to ISO and then burn with imgburn.

    Last night I also burned Kawasaki quad bikes again except I used Wii backup manager to burn it which failed last night. Well now I got it loaded to the game's main menu. I tried to load this same disk anytime after that I get the error I just mentioned. So I tried the extra Mario Kart I burned last night using Wii backup manager (the one I bragged about working). It fails now too.

    I tried a different cios cIOS249[56]v21d2x6

    I tried to burn 6 more new games. All the same error. Then I tried all 20 games that I originally burned before converting to WBFS and everyone works.

    It seems Mario Kart tricked me into believing that using WBFS had no involvement to my issue. Now I almost gotta feel certain it has something to do with it as I have spent 3 hours burning and testing game disc.
     
  5. scooby74029

    Member scooby74029 "fake coder"

    Joined:
    May 7, 2010
    Messages:
    1,174
    Location:
    oklahoma, USA
    Country:
    United States
    hey you might try just a regular 249[57] r19 for a cios and see if it works then

    i dont know if it will work but just something to try
     
  6. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    0x00031100 is the correct error code, in happens in the apploader loop of NeoGamma. That's where the main.dol, fst and b2.bin of the game are loaded. "Recovered read error" is what Yagcd says about that error.

    Hmm, i wonder if this means that the read acutally worked, and the loading process could continue. Anyways, since it worked once with the same disc and the other time it didn't, the .iso should be fine. Could be a problem with the disc/laser, NeoGamma or the cIOS. Which cIOS are you using? Can you try d2x56? (see 1st post of the NeoGamma R9 beta thread)
     
  7. ryukoken

    ryukoken Newbie

    your games have not all partition?
    i cant confirm this but
    when i burn a game from wbfs file without all partition (update+game)
    my drive have some problem to read it
    but when i burn this same game with full partition, the game work fine
    with channel disc, try burn with a full iso
     
  8. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Hmm, i have to check if NeoGamma checks if the game has a partition at all, thanks.
     
  9. wseyller
    OP

    Newcomer wseyller Newbie

    Joined:
    Jun 10, 2011
    Messages:
    4
    Country:
    United States
    I have solved my issue finally.

    Basically I had two batches of Memorex dvd-r and forgot about it. I bought them during different times well before I started messing with the Wii. I had used some while at my office and I had some for use at home. Eventually came a time when I had combined them into one stack. So what happen is the first 20 disc on the stack worked but the next 10 or so did not. Both types of disc were actually the same brand and looked nearly identical. I finally remembered that they were bought separately so I started to look at physical differences in these disc. After a couple of minutes starring at them I found a couple minor differences in the center of the disc. It then became perfectly clear to me that the working game disc were different from the non-working disc. I have since burned the games I was having trouble with on proper disc and they work fine. I am disappointed in myself that I did not catch this earlier as I have experience in similiar issues while modding other devices for many years.

    Thanks for all of the help and effort to solve my problem.
     

Share This Page