Disadvantages of 4.0 compared to 3.2?

Discussion in 'Wii - Hacking' started by SpaceJump, May 5, 2009.

May 5, 2009
  1. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    System Menu 4.0 is out for some time now and I'm still on 3.2E, but now thinking of updating to 4.0. All you GBAtempers who updated to 4.0, did you regret it or not? Are there any disadvantages compared to 3.2?

    I also read that for updating to 4.0, we can use the newly released Firmware Downgrader 1.11. Does that install IOS60 trucha-signed, or do we have to install that before?

    Thanks for your answers [​IMG]
     


  2. TheWiiNinja

    Member TheWiiNinja GBAtemp Regular

    Joined:
    Mar 14, 2009
    Messages:
    112
    Location:
    Texas
    Country:
    United States
    There really isn't any disadvantage to 4.0 that I can think of besides the fact that there is no exploit.
     
  3. hdhacker

    Member hdhacker GBAtemp Fan

    Joined:
    Apr 6, 2009
    Messages:
    432
    Country:
    United States
    I have a modchip, so I have no experience with many of the hacks people normally install to blay backup DVDs. However, it's been nothing but positive for me.
     
  4. daxtsu

    Member daxtsu -

    Joined:
    Jun 9, 2007
    Messages:
    5,289
    Country:
    Antarctica
    None, as long as you upgrade properly[make sure you have a CIOS], and are not starting with a new/virgin Wii on 4.0, as like said previously, there's no Twilight Hack or substitute yet.
     
  5. ganons

    Member ganons GBAtemp Advanced Maniac

    Joined:
    Jun 12, 2005
    Messages:
    1,944
    Country:
    United Kingdom
    what about the trucha bug, does stay on 4.0?
     
  6. daxtsu

    Member daxtsu -

    Joined:
    Jun 9, 2007
    Messages:
    5,289
    Country:
    Antarctica
    As long as you have a CIOS installed beforehand.
     
  7. Apekop

    Member Apekop GBAtemp Regular

    Joined:
    Apr 9, 2009
    Messages:
    223
    Location:
    Location, location, location.
    Country:
    Netherlands
    if you install ciosrev9 or higher BEFORE updating, you will have that. (ios36 with truncha)
     
  8. wiiman123

    Member wiiman123 GBAtemp Advanced Fan

    Joined:
    Apr 5, 2009
    Messages:
    938
    Country:
    New Zealand
    ..........................
     
  9. Hells Guardian

    Member Hells Guardian GBAtemp Maniac

    Joined:
    Dec 25, 2008
    Messages:
    1,113
    Country:
    United States
    So long as you are sure to update the system menu using the homebrew updaters and not the wii opdate option in the settings menu 4.0 is a great version to use.
     
  10. ekolimits

    Member ekolimits GBAtemp Regular

    Joined:
    Apr 28, 2007
    Messages:
    298
    Location:
    N.J.
    Country:
    United States
    umm... none,
    you can do everything on 4.0 that you did on 3.2

    go ahead, upgrade... but be careful to follow the steps correctly!!!!
    if not, you will regret it!
     
  11. Patryc

    Member Patryc GBAtemp Fan

    Joined:
    Jul 30, 2007
    Messages:
    452
    Country:
    United Kingdom
    Region free disc loading seems to disappear with 4.0. (on PAL)(CiosCorp) Works almost 100% with 3.2. Upgraded then downgraded again as I didn't seem to find much advantage with it.
     
  12. imapterodactyl

    Member imapterodactyl GBAtemp Fan

    Joined:
    Jan 20, 2009
    Messages:
    424
    Country:
    United States
    No disadvantages. Make sure you've got a cIOS and HBC installed, and use Waninkoko's updater, not the Nintendo Update (it won't mess with your old IOSes like Nintendo's does). Also, remember to patch IOS60 in order to play WADS not purchased through the Shop Channel via SD card.

    This is a good guide (it's what I used... worked like a charm):

    http://www.yafaze.com/wii/4.0updateguide.html

    Use "Method 2". I'm assuming you've been keeping up with the latest IOSes for newer games, since you've managed to stay on 3.2 thus far. If not, you'll need to grab 'em somewhere.... unfortunately, I can't tell you which ones right off the top of my head. Shouldn't be hard for you to find though.

    Alternately, this guide is very good too:

    http://gbatemp.net/index.php?showtopic=144835

    The only real difference is that the first guide uses a different method for IOS60.... same result (has you d/l it instead of patching it).
     
  13. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    What about using the new Firmware Downgrader 1.11 to update to 4.0? Does this work? Does it patch IOS60 in the process (this isn't mentioned anywhere)?
     
  14. Prince Valmont

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Speaking of compatibility, I installed the CIOSCORP on my 4.0 using one of the guides, and for the most part, it works, but games like Guitar Hero III & Endless Ocean will not load properly. They all give me errors upon hitting the Start button from the Wii Menu.

    Is there something that I can install, whether an IOS or cIOS that can fix my compatibility for CIOSCORP? How about something to allow me to load/play PAL games on my NTSC console? Those are the two main things I miss from my 3.2.

    Does anyone have any solutions?
     
  15. daxtsu

    Member daxtsu -

    Joined:
    Jun 9, 2007
    Messages:
    5,289
    Country:
    Antarctica
    I upgraded through Nintendo just fine: I installed CIOS 36 v9 and then ran IOS downgrader to get all the trucha bugged IOSes back[after updating]. Worked fine for me.
     
  16. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    Anyone?
     
  17. jservs7

    Member jservs7 GBAtemp Advanced Fan

    Joined:
    May 14, 2008
    Messages:
    891
    Country:
    Puerto Rico
    I still haven't taken the 4.0 plunge, but I am about to since I want to have more space for my game saves. [​IMG]

    I used WIISCU 0.2 to update IOS51, IOS60 and IOS61 with Trucha signing included. I also used it to update my News, Weather, Mii, Photo and Wii Shop channels.

    Since I did all that and have the latest cIOS36 rev, would I just have to run either Waninkoko's Firmware 4.0 Updater or his latest Firmware Downgrader? (Yes I know downgrading should update something, but people keep saying you can use it to upgrade from 3.2)
     
  18. Slimmmmmm

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    Yeah, I thought there were other problems, but not anymore.




    *EDIT*
    Other problems were nothing to do with this.
     
  19. Tetram

    Member Tetram GBAtemp Regular

    Joined:
    Mar 11, 2008
    Messages:
    129
    Country:
    France
    As there are no exploit anymore, I won't upgrade. It happen only once on my wii when I was on 3.3v1, but the Homebrew channel stopped working properly. it started, but I wasn't able to launch anything : the loading bar filled, but nothing happened, whatever the homebrew.
    I had to install it again using ZeldaTP hack, and everything was OK again.
    If this happen to me while in 4.0, there wouldn't be any solution...
     
  20. raptir

    Member raptir GBAtemp Regular

    Joined:
    Mar 13, 2009
    Messages:
    189
    Country:
    United States
    The preloader hack still seems to work, at least for every game that I've tried.

    Does anyone know if the Firmware Downgrader keeps the Trucha bug in tact like the Firmware 4.0 Upgrader that Waninkoko wrote?
     

Share This Page