Disable Auto-Dim on Ps Vita with registry editor and Henkaku

Discussion in 'PS Vita - Hacking & Homebrew' started by sigma.nl, Sep 15, 2016.

  1. sigma.nl
    OP

    sigma.nl Member

    Newcomer
    46
    9
    Apr 26, 2008
    Netherlands
    netherlands
    I'm wanted to use my Psvita and DS4 controller for remote play on my PS4 but there is an annoying
    auto-dim from the screen.
    Now with Henkaku and the release of a registry editor for the vita (thanks "some1psv" for the editor)
    I thought that the could be a way to disable the auto-dim and....

    After some testing I found a way to disable the Auto-Dim :)

    Just do the following:
    - Make sure your have a Vita 3.60 with Henkaku installed
    - Install RegistryEditor.vpk https://github.com/some1psv/RegistryEditor/releases
    - start the Registryeditor
    - goto the following registry entry:
    /CONFIG/POWER_SAVING/", "suspend_interval"
    - change the value to 0 (zero)

    - goto the following registry entry:
    /CONFIG/DISPLAY/", "dimming_interval"
    - change the value to 0 (zero)

    reboot the vita and your done!!!
    Experience you Vita game play without the Auto-Dim :D

    A reminder, There is no Auto-Dim but there is also no PowerSaving anymore so your battery will drain if you don't push the powerbutton yourself
    !!! also be aware of your screen Burning (don't know if it could burnin but I don't want to try it out ;) )


    cheers
    Gr.
    Sigma
     
    Last edited by sigma.nl, Sep 15, 2016
  2. SuperDan

    SuperDan Im Aware ... Im Unaware

    Member
    754
    201
    Aug 17, 2016
    United States
    Londoner , Living In Louisiana ...
    cool i like that thanks
    ive been trying to figure out how to...
    stop certain games dropping to 80% brightness
    when they start....
    some stay at 100% brightness others instantly drop to 80%...
     
  3. ShinichiKudo

    ShinichiKudo Advanced Member

    Newcomer
    66
    10
    Jul 23, 2012
    Doesnt work
     
  4. yifan_lu

    yifan_lu @yifanlu

    Member
    654
    1,368
    Apr 28, 2007
    United States
    As someone who's left a vita on for weeks without dim. Burnin is real. It's shitty. And it's irreversible. Just be aware.
     
    SuperDan, Silverthorn, EmuAGR and 2 others like this.
  5. ShinichiKudo

    ShinichiKudo Advanced Member

    Newcomer
    66
    10
    Jul 23, 2012
    hi does this really work? i just tried it and it doesnt work on my vita.
     
  6. sigma.nl
    OP

    sigma.nl Member

    Newcomer
    46
    9
    Apr 26, 2008
    Netherlands
    netherlands
    OK thank for your response, it does work with my vita, I have a vita 1000 (EUR)

    I just found a funny thing.
    When you turn your vita on and do not touch a button or screen it will boot and goes to standby but... when you touch a button and go to the
    homescreen with all the bubbles the vita stays on.

    Can you check the following:
    when you go to the settings menu and to the powersaving options, then to the auto standby setting
    can you see if there is a time selected 1,3,5,10,30 minutes
    In my setting menu there isn't one selected see the attached picture link

    http://imgur.com/0YZ0A0T

    Can anyone confirm this does work with your vita.
    I Cannot image that I'm the only one in the world were this works :)
    [​IMG]

    — Posts automatically merged - Please don't double post! —

    thanks I'll be carefull with this but am happy to finally use remote play with a DS4 controller without touching my screen every minute :D
     
    Last edited by sigma.nl, Sep 16, 2016
  7. reprep

    reprep GBAtemp Advanced Fan

    Member
    935
    301
    Jul 5, 2012
    Does changing dimming interval to 0 but leaving suspend interval as is work?


    Sent from my iPhone using Tapatalk
     
  8. SuperDan

    SuperDan Im Aware ... Im Unaware

    Member
    754
    201
    Aug 17, 2016
    United States
    Londoner , Living In Louisiana ...
    it worked on mine ..100% ... & i always hit the power button to turn it off when im done ... but yepp it works for me
     
  9. sigma.nl
    OP

    sigma.nl Member

    Newcomer
    46
    9
    Apr 26, 2008
    Netherlands
    netherlands
    I had to changed both parameters to disable the auto dim
    Don't know why, it would be logical that only the dimming interval set to 0 would solve the problem but sony/vita thinks different about it ^_^

    — Posts automatically merged - Please don't double post! —

    Thanks for checking Superdan
     
    reprep and SuperDan like this.
  10. ShinichiKudo

    ShinichiKudo Advanced Member

    Newcomer
    66
    10
    Jul 23, 2012
    Sorry for the delayed response it was confirmed working on my vita now thanks :)
     
    reprep likes this.
  11. AK_Twilight

    AK_Twilight Newbie

    Newcomer
    1
    1
    Sep 19, 2016
    Serbia, Republic of
    Working perfect. Vita slim. Thank you!
     
    reprep likes this.
  12. sparlock666

    sparlock666 Member

    Newcomer
    18
    0
    Dec 29, 2015
    United States
    Thanks, this works great. Since I changed it though, i don't remember the default value for "suspend_interval". The dimming_interval I remember was at 900, but do you happen to remember that one just in case I want to switch back?
     
  13. asdfqwer426

    asdfqwer426 Member

    Newcomer
    10
    0
    Dec 8, 2010
    United States
    just found this, trying it out now. that auto dim on metal gear cut scenes is KILLING me.

    the default values I had were -
    Dimming interval - 900
    suspend interval - 600

    I haven't checked to see if the suspend interval value changes based on the setting in the settings app, but it might?
     
  14. SuperDan

    SuperDan Im Aware ... Im Unaware

    Member
    754
    201
    Aug 17, 2016
    United States
    Londoner , Living In Louisiana ...
    whoops i saw i replied to this ages ago hahaha .. my bad for having a quick look at gbatemp at work
     
    Last edited by SuperDan, Jun 29, 2017