DIOS MIOS, USB Loader GX, black screen? (help for a noob)

Discussion in 'Wii - Emulation and Homebrew' started by Ambidextroid, Dec 12, 2015.

  1. Ambidextroid
    OP

    Ambidextroid Newbie

    Newcomer
    1
    0
    Dec 12, 2015
    OK, so I am a total noob at this.
    At first I only wanted to HB my Wii for Mario Kart Wii online, and I've done that using the Letterbomb method and dragging a few files onto an SD card etc., easy peasy.

    But now I want to be able to load Gamecube games off of a USB stick without the original disk.


    This is currently what I have:

    - 2GB SD card, formatted as FAT32, with a bunch of folders on called 'apps' (which contains 'dios-mios-booter', 'dios-mios-booter-F', 'IOS236' which I used to install DIOS MIOS, 'usbloader_gx', 'WADManager' and 'wiimmfipatcher' which was used for MKWii online), 'bootmii', 'bslug', 'dm_booter', 'private', 'wad', a file called 'boot.elf' and a file called 'installer.log'.

    - 15GB USB stick, formatted as FAT32 (nothing about cluster size, apparently that's important?) with a folder called 'games' on, with a folder called 'GALP01' on, with 'game.iso' on (Smash Bros. Melee).


    When I open DIOS MIOS and choose Smash Bros., a message pops up saying 'fatal error apploader size is zero'.
    When I open USB Loader GX and choose Smash Bros, the DIOS MIOS logo shows up and then cuts to black, and nothing happens.

    Please someone help! I don't really know much about this whole thing at all.

    Thanks!
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,744
    Oct 27, 2002
    France
    Engine room, learning
    I will assume that you correctly installed DIOS MIOS (and not Lite version, which is for games on SD card).

    The error you see at the DM boot logo means that the game ISO can't be found.
    it could be different issues :
    - wrong partition. (be sure your 15GB stick has only one partition, not a hidden one first)
    - wrong DM (DM with game on SD, DML with game on usb)
    - bad iso (it happens)

    what's strange is that you didn't mention an error when using USBGX, only the logo (no message there?) and then black screen.
    Which version of USBLoaderGX are you using? you can see it in the credit page, or on the boot sequence.
    I added HDD and partition checks after 3.0, so if you are still using 3.0 (revision 1180) you should update the loader.
    Latest version can be found in my signature (though, 1259 has a network bug when downloading custom animated banners, I'll fix it in 1260)

    if you already have r1256 or r1259, and USBLoaderGX doesn't warn you about your drive then it means the partition and hdd format are correct.
    the black screen after the boot logo means it's a video mode issue.
    Go to the game settings and set the default mode to Auto or to Disc default, to match the region of the game and not of your console.

    DIOS MIOS is good but now it's old and has devices compatibility issue. not all USB are working.
    it's nice to try and test all homebrew, and I'm all for helping users with it if they really want to use it, but there are other loaders you can use for gamecube backups, like nintendont.

    Nintendont doesn't need an installation in the console, and will not interfer with your currently installed MIOS.
    just go to Settings>features>update nintendont. it will download latest nintendont version to SD:/apps/nintendont/ folder (this option will be removed in r1260)
    then tell the loader you want to use nintendont instead of MIOS :

    Globaly (for all games) go to settings>loader settings>Game cube mode : nintendont
    or
    individually (for one game) Select Smash bros > option > game option > gamecube mode : nintendont
     
  3. Retro_Mod_Gamer

    Retro_Mod_Gamer Member

    Newcomer
    27
    6
    Nov 3, 2015
    Canada


    Hello Cyan, thank you for all of your hard work and activity in the forums! I love USB Loader GX and it works great on my Wii U with Nintendont. I have modded a Wii for my office and can't get Nintendont to consistently load from usb loader gx. I will update my cios (any cios) and nintendont will appear under loader settings, but after the first time I launch a game, which works great, from usb loader, and then return to usb loader, Nintendont has disappeared from the loader settings until I update a cios and get another one-time usage out of nintendont via usb loader gx. I haven't seen this covered in any previous threads, any suggestions? It's driving me crazy and the same thing has happened on two other Wiis I've helped friends with, but not one other one for some reason.
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,744
    Oct 27, 2002
    France
    Engine room, learning
    You have an old channel installed on the console, and a recent version on your SD card.
    When you launch from HBC, it's the good version with nintendont settings, when you exit a game it reloads the channel and as it's an old version without the nintendont compatibility you lose them all for your next launch from HBC, etc.

    the fix for this is :
    1. delete the channel (download the full channel wad UNLR, use a wad manager to uninstall the channel with that wad)
    2. install the forwarder channel (which will load the main.dol version on SD card instead of loading the internal version inside an old channel)

    https://sourceforge.net/projects/usbloadergx/files/Releases/Forwarders/

    don't install the Wii forwarder on vWii
    and don't install the vWii forwarder on Wii
     
    Retro_Mod_Gamer likes this.
  5. Retro_Mod_Gamer

    Retro_Mod_Gamer Member

    Newcomer
    27
    6
    Nov 3, 2015
    Canada
    Voila! That worked perfectly, thank you so much, I apologize if I missed something in my searching through the forums. Once again Sir, I thank you. :yaywii: