Dear GbaTemp, Remember when I bricked my Wii? I need to recover it..

Discussion in 'Wii - Hacking' started by alex.ap.pacman, Feb 4, 2012.

  1. DeadlyFoez

    DeadlyFoez XFlak Fanboy

    Member
    11
    GBAtemp Patron
    DeadlyFoez is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 12, 2009
    United States
    Your other option to get a quick answer to a simple question is to log in to some IRC channels. GBAtemp's IRC channel is always extremely active, and Joostin likes to hang out in there and he loves to help people.

    Oh gawd.... Did you have to add an avatar? I liked you better when I thought of you as just a blank nothing. Can you like at least change it to like your favorite DragonBall Z character?
    (^^ if you can't tell, I'm now just picking on you)
     
    1 person likes this.
  2. icw35

    icw35 GBAtemp Advanced Fan

    Member
    5
    Sep 22, 2010
    As for the video, don't give up your day job :)
     
  3. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    SEE! now you're speaking my language - I didnt know we had an IRC!
    Hey now, I was making the video because I was wanting to show people that I got it to work...now the only problem is how do I re-install the 4.3 System menu...?
     
  4. DeadlyFoez

    DeadlyFoez XFlak Fanboy

    Member
    11
    GBAtemp Patron
    DeadlyFoez is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 12, 2009
    United States
    I watched the first 5 minutes and it brought me back to the days of being a 13 yr old virgin. :P

    ok. ModMii can build the bootmii.ini file for you and then you just go and put it in the right location.
     
  5. tueidj

    tueidj I R Expert

    Member
    7
    Jan 8, 2009
    The whole thing about bootmii.ini was a waste of time. As per the description in the .ini file, AUTOBOOT only recognizes two settings:
    - HBC: autoboot straight to HBC
    - SYSMENU: autoboot straight to the system menu
    Anything else (OFF, ON, DOTHEHOKEYPOKEY) will make it load bootmii like normal. If it doesn't then you're either missing some files, your SD card is incompatible or you've changed the video setting in bootmii.ini to a mode that your tv doesn't support.
     
  6. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    I still can't access my internet settings despite being able to load all the latest IOS's, is there a way to reinstall the 4.3 system menu?

    Any help is appreciated,

    btw, I've tried to go on the IRC but they didn't do anything.
     
  7. damysteryman

    damysteryman I am too busy IRL these days...

    Member
    6
    Oct 4, 2007
    OK... here I am, only just got back... and I did not really expect to see a video explaining my help and praising me for it lol ... it is a tad embarrassing to be honest, but anyway...........

    And also make sure to embarrass and praise tueidj too! :lol: After all, as I said in the PM, he was the one who pointed out the DVD slot telling us that you had bootmii by flashing twice. The first time I watched that video, I missed that, and therefore assumed that you did not have it, but then tueidj saw it and told us, which made me go back and watch the video again. If he did not post that, I would have never rechecked the video or sent you that PM.

    And the main reason I made that PM... was because that .zip file I made for you contained files that are not actually allowed to be redistributed (the Bootmii armboot.bin, and The Hackmii Installer bootmini.elf file renamed to ppcboot.elf, which replaced the regular Bootmii ppcboot.elf) as the authors (Team Twiizers) forbid it... I just thought it would have been quicker and easier to send you the files to throw on the SD to get the Wii loading The Hackmii Installer, rather than describing how to get the files the normal way, that is all.

    And tueidj is also right about the Autoboot setting too. Just like everything else he posts. He is far more knowledgeable than us regular folk when it comes to Wiis and Wii Hacking.

    And I will also nicely ask a mod to merge your other thread and this one, seeing as they are about the same topic.
    And as for where to ask things you are not sure about without the need to make another thread... perhaps try the Noob Paradise thread. That is what that thread was made for :) Or maybe the IRC channel as DeadlyFoez pointed out.



    Anyways, now that you have your bricked Wii booting The Hackmii Installer, just follow the instructions I posted earlier (install Bootmii as boot2 and IOS (that way your Bootmii is up to date), then install HBC, then make a NAND backup with Bootmii in case you need it in the future, then load up ARC, then show us your Wii's region settings that ARC displays). After doing that report back here with the settings, and we can use them to determine what we need to do next (what settings you must change, what you must leave as is etc.). There is a small chance that your System Menu will need reinstalling, just fixing these settings should do (unless you somehow managed to install EUR/JPN/KOR System Menu over the top of your USA one).
     
    1 person likes this.
  8. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    So MMM tells me its a USA system Menu, and Modifymymenu tells me its a KOR sys menu.... how do I fix this altogether?


    And I apologize for the praise embarrassment.

     
  9. damysteryman

    damysteryman I am too busy IRL these days...

    Member
    6
    Oct 4, 2007
    That is OK :lol:

    Now that is interesting... we now know which 2 regions your Wii is mixing up... Could you please run AnyRegion Changer as per the instructions I posted, and tell us all the settings it shows you? (Do not change any settings just yet though)
     
  10. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    Here's the results, had to select IOS 222 to get it to work. [​IMG]

    Also I was using ARC offline for 4.1 on my 4.3 to verify country
     
  11. damysteryman

    damysteryman I am too busy IRL these days...

    Member
    6
    Oct 4, 2007
    OK! I know what the problem is now. Your Wii's settings are correct for a USA system, but... you have a Korean System Menu installed (ver 4.3K)! This complicates things a bit more.

    We now need to overwrite the 4.3K System Menu with the 4.3U one. But that is not all... we also have to check that the other system channels have not been turned into Korean aswell - Shop, News, Weather channels, along with 2 hidden, but important channels, The Region Select and EULA channels... they need to be the same region as the System Menu just to make sure (for example, to prevent a brick if you ever format the Wii or need to reread and reaccept the EULA).

    Now I do not have a usable SD card to test this next bit ATM, but it should work: extract the contents of Title Lister 222 Mod to the root of your SD card, and then run it via the HBC. It should reload to your IOS222 that you have installed, and check what titles (channels) you have installed, and then output the list of titles to SD:\TITLES.TXT. Once that is done, post that file here, so I can check if these system channels also need changing or not.
     
  12. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    @[member='damysteryman']


    Here you go:

    Warning: Spoilers inside!
     
  13. damysteryman

    damysteryman I am too busy IRL these days...

    Member
    6
    Oct 4, 2007
    OK! Looks good!

    Looks like the only problem is the System Menu itself; there is no need to change anything else. I also see that you have updated a few IOS with ModMii too, and have the latest version of d2x cIOS installed. Nice.

    Now for the fun part.
    1. if you have not done so already, use BootMii to make a NAND Backup to your SD card. Messing with the System Menu is risky if you do not have a backup!
    2. Load up ModMii on PC, and go to ModMii's Download Page 1. Select IOS80-Patched ("80") and System menu 4.3U ("4.3U"), and then Download.
    3. Copy the 2 resulting wads from ModMii's target directory (it is COPY_TO_SD by default) over to your SD card.
    4. Install the 2 wads with MMM.

    Then it should all be working properly again for you.
     
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    I merged the two topics.
    Hopefully, there was only one replies made in the first topic after the creation of the second one, so nothing looks weird.


    About bumping old topics, it's a matter of self judgment.
    For example, if it's 2 years old, don't!
    If it's one or two month old, and it's your topic where you asked for help and finally got it fixed, you can post and bump it, as it's the continuation of your problem.


    When it's an update of the topic, it's better to bump.
    If you only want to ask a question or reply to a user in an old and from someone else topic, don't. There's a chance that user already had his answer, or that there are new method of doing it.
    It works for old tutorials too, don't follow old ones, there are certainly new updates and new methods to do the thing you want.
     
  15. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    @Cyan thank you for the helpful information. Appreciated very much.



     
  16. damysteryman

    damysteryman I am too busy IRL these days...

    Member
    6
    Oct 4, 2007
    Thank you again for merging the threads Cyan :)
     
  17. alex.ap.pacman
    OP

    alex.ap.pacman GBAtemp Regular

    Member
    1
    Sep 5, 2010
    United States
    Seattle, Washington
    [member="damysteryman"] - well, good news, it all works, Thank you again for helping me, I need to send tueidj a thank you as well.
     
  18. damysteryman

    damysteryman I am too busy IRL these days...

    Member
    6
    Oct 4, 2007
    Win! :yaywii:

    And no problem :)
    Good to know that everything is fixed.

    And now, there are 2 more things you may want to consider doing...
    1. Now that your Wii is fully functional, make a another NAND backup of it in its fully functional state, and store this backup somewhere safe in case you need it in the future
    2. (optional) ...clean off all that "Bricked" stuff that was scribbled onto the side of the Wii haha :P
     
  19. LWares87

    LWares87 GBAtemp Advanced Maniac

    Member
    4
    Oct 19, 2008
    United Kingdom
    Colchester, England
    Get a copy of the latest system menu for your region (through either Modmii or NUS Downloader) and install it (using either WiiMod, Multi-Mod Manager or Wad Manager).

    If you had it installed previously, you'll have to re-install Priiloader.

    If that doesn't work... then I don't know what else you can do, apart from that.

    Edit: Custom Colour Removed for a "certain someone's" benefit. :)
     
  20. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    You have a region brick, installing 4.3 isn't going to fix anything (unless you installed the wrong region SM). Post a SysCheck with the guide in my signature so we know what you have installed. Alternatively you could edit your settings using Settings Editor GUI (also in my signature).
     
Quick Reply
Draft saved Draft deleted
Loading...