custom firmware on PSP Mystic Silver?

Discussion in 'PSP - Games & Content' started by FencingFoxFTW, Sep 9, 2009.

Sep 9, 2009
  1. FencingFoxFTW
    OP

    Member FencingFoxFTW GBAtemp Fan

    Joined:
    Apr 27, 2008
    Messages:
    404
    Country:
    Puerto Rico
    I just got a Final Fantasy PSP and I was wondering: is it possible to load custom firmware in it?

    can anyone point me in the right direction?

    sorry if I'm being too n00b

    btw, I havent updated the firmware to play Dissidia
     
  2. Rock Raiyu

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States
    It most likely can't have CFW installed. Aren't those PSP 3000s? If so, then I know you can use ChickHen or whatever its called.
     
  3. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    What firmware is it currently on? That's the determining factor. 5.03 and below you can run a temporary one, above that and no there's nothing for you in the way of an alternative firmware, at least for the time being.
     
  4. FencingFoxFTW
    OP

    Member FencingFoxFTW GBAtemp Fan

    Joined:
    Apr 27, 2008
    Messages:
    404
    Country:
    Puerto Rico
  5. themuddaload

    Member themuddaload Creepin' hardcore.

    Joined:
    May 4, 2008
    Messages:
    1,099
    Location:
    West of the equator Sex: sure
    Country:
    United States
    umm... isnt dissidia sposed to require 5.5? i would assume that sony would preload their psp bundles with the firmware required to run the game...
     
  6. iceache

    Member iceache GBAtemp Regular

    Joined:
    Jul 6, 2007
    Messages:
    155
    Country:
    Canada

    Dissidia does not require 5.5.. I run it just fine on 5.00m33-6
     
  7. Rock Raiyu

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States
    Yeah, Dissidia doesn't have firmware 5.55. It is playable.
     
  8. themuddaload

    Member themuddaload Creepin' hardcore.

    Joined:
    May 4, 2008
    Messages:
    1,099
    Location:
    West of the equator Sex: sure
    Country:
    United States
    i know it doesnt require it... ive played it on my m33, but at my sources it said you had to edit something to get it to work, although i never did it, i obviously cant give linky though...


    ah i found the nfo, that should be safe to post
    Warning: Spoilers inside!
     
  9. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    Dissidia runs fine and unaltered on 5.00M33-6 so modifying the version txt is unnecessary. Just rip your UMD and use the ISO from that and it'll be fine.
     
  10. FencingFoxFTW
    OP

    Member FencingFoxFTW GBAtemp Fan

    Joined:
    Apr 27, 2008
    Messages:
    404
    Country:
    Puerto Rico
    thanks ppl

    the PSP had 5.01 fw, so I used the installer on the link I posted earlier

    believe it or not, I havent tried playing the original Dissidia after flashing, so I'll try that later and report

    edit: Dissidia works without a problem

    funny how they try to trick you into updating to 5.50 when you load it in the original firmware
     

Share This Page