create new nand with ohneswanzenegger when original nand corrupted

Discussion in 'Wii - Hacking' started by vegeta4ss, Sep 30, 2012.

  1. vegeta4ss
    OP

    Member vegeta4ss GBAtemp Regular

    Joined:
    Nov 16, 2008
    Messages:
    141
    Country:
    United States
    I have a friend's wii with bootmii v1.0 installed as boot2. It will not restore his backup (restore freezes) and the system menu is corrupt so nothing loads but a black screen. His nand is in bad shape. I can't verify it with nandbincheck. I can't punetwiin it with my good backup because it can't initialize the file. So I am trying to build a new nand to restore for him.

    I am using ohneswanzenegger to build the new nand, or at least trying. I select my keys.bin file (I had to modify this file already because of the v1.0 bootmii bug and consoleid) and then I set the uid to usa and I leave the output file name alone. Since I do not have a boot1/boot2 entry selected I cannot continue with creating a new nand. Why is this? Is there no default selection for the scenario when you don't have this available?

    When I select "existing nand" on this create nand screen and use MY console's nand backup as the source and my friends keys.bin as the key source and set UID to usa then a new nand can be created. I can nandbincheck -all and it comes back fine after I formatted and installed 4.2u to this new nand. When I try to restore this file I get a message that says this console backup does not match the console id so I can't begin the restore.


    -how can I work around the boot1/boot2 missing entry when creating a new nand from scratch
    -how can I work around my mismatch issue? Can I hex edit the nand.bin and force it to match at the end where the key is stored?

    side question: can I launch the hackmii installer from anywhere in bootmii so that I can update my version of bootmii and maybe make a usable nand backup? v1.0 had a lot of bugs but that's what is in there unless I can run hbc installer.

    Thanks for reading my post.
     
  2. vegeta4ss
    OP

    Member vegeta4ss GBAtemp Regular

    Joined:
    Nov 16, 2008
    Messages:
    141
    Country:
    United States
    I made a backup with bootmii of the current wii state and used that as the "existing nand" in ohneswanzenegger and when I hit the ok button it says "the keys or boot1/boot2 is not correct". This appears to work for others who have had a corrupted nand so I'm not sure why it wont work for me.

    when I try to check this nand backup with nandbincheck it tells me "error setting path to this nand object". I know my syntax is correct because I can use the same syntax on another nand file made with a different wii and the verify goes through fine.

    So basically I have a wii with boot2 bootmii v1.0 and even though it says it makes good backups I can't seem to use them to fix anything. It would be great if I could get a newer version of bootmii on this wii. I think it would make a better boot1/boot2 backup for me to use as my base for a new nand.

    edit:


    because I felt like I was fighting a buggy install of bootmii I decided to bring in a copy of the bootmii folder from a different wii. This upgraded my bootmii from v1.0 to v1.4. I ran a backup operation. Then I ran that file through nandbincheck. It was able to read it....and it was not happy. Here's what it said:


    nandbincheck nand.bin -all
    ** nandBinCheck : Wii nand info tool **
    from giantpune
    svn r: 104
    built: Jun 5 2011 21:29:38
    checking boot1 & 2...
    Boot1 B (vulnerable)
    found 3 copies of boot2
    "blocks 1 & 2: Marked as bad blocks; Content Sha1 matches TMD; TMD officially si
    gned; Ticket officially signed; Version 2"
    "blocks 3 & 4: Used for booting; Content Sha1 matches TMD; TMD is fakesigned; Ti
    cket officially signed; BootMii (Unk)"
    "blocks 7 & 6: Backup copy; Content Sha1 matches TMD; TMD officially signed; Tic
    ket officially signed; Version 2"
    checking uid.sys...
    UIDmap::Check() system menu entry is messed up: 0 0
    checking content.map...
    SharedContentMap::Check -> error converting "φ1
    checking "/shared1/φ1.app" ...
    NandBin::ItemFromPath ->item not found "/shared1/φ1.app"
    "One of the shared contents in this nand is missing"

    So now i'll see if I can make a new nand with this newer backup from bootmii 1.4
     
  3. vegeta4ss
    OP

    Member vegeta4ss GBAtemp Regular

    Joined:
    Nov 16, 2008
    Messages:
    141
    Country:
    United States
    ok good to go. The restore was a success and i've now booted to the system menu. Off to rehack this wii.
     

Share This Page