Could someone post PrePatched homebrew for us

Discussion in 'R4 DS' started by Malleus, Jan 28, 2007.

  1. Malleus
    OP

    Malleus Member

    Newcomer
    12
    0
    Dec 29, 2006
    as topic said =)

    though to be frank I dont even know about that many homebrew utils/games for the NDS, but I guess there is bound to be some good ones?
     
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    22,908
    8,569
    Nov 21, 2005
    I could patch some apps but I favour teaching a person to catch their own donkey.

    The homebrew that will work with the R4 and most other DS slot cards will either have to be built for it or use DLDI.

    Regarding special builds the only one that springs to mind is the DS slot build of lemmings:
    http://forums.ds-xtreme.com/showthread.php?p=24047
    My mirror:
    http://www.4shared.com/file/9023246/588e32...s_dsx_v3_2.html

    DLDI is simple enough
    visit this site:
    http://chishm.drunkencoders.com/DLDI/
    download the r4 dldi file
    download the patcher (I will detail the command line one as I find it simple enough
    The syntax is:
    CODEdlditool
    That is to say if I were to patch a file called a.nds for the R4 I would first make sure a.nds was in the same directory as r4tf.dldi and the patcher called dlditool.exe, then type

    Code:
    dlditool r4tf.dldi a.nds
    Hit enter and a few seconds later a patched app would appear, copy this to your card and do whatever else is needed for the app (copy films, roms, isos, music, pictures....)

    Here is a thread with a bunch of old apps that have now had dldi support added, most apps compiled recently have dldi support added (check their forums for betas and gbatemp does a good line in posting news):
    http://forum.gbadev.org/viewtopic.php?t=12146
     
  3. adgloride

    adgloride Its A Wii Wario

    Member
    2,261
    2
    Apr 2, 2003
    Theirs a GUI version of the patcher that makes life a lot easier. I think its on GBATemp. Theirs no need for pre patched versions of anything as the GUI is so easy to use. Just select the DLDI file (If its in the GUI patchers directory its selected automatically) then select the file and patch.