Corrupted saves on M3 Perfect Lite?

Discussion in 'M3 Adapter' started by link459, Jan 22, 2008.

  1. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    My game's saves have been corrupting whenever I load them up...

    Does anyone know what causes this/a fix?
     


  2. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Bump.....

    Cmon please help, it just erased my Advance Wars save. [​IMG]
     
  3. protomanexe88

    protomanexe88 Newbie

    Newcomer
    4
    0
    Jul 7, 2006
    United States
    Sounds like you need a new battery.

    HAI 459
     
  4. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    HAI PROOT

    Explain.
     
  5. Lifesnoozer

    Lifesnoozer Advanced Member

    Newcomer
    61
    0
    Jan 31, 2007
    My AW: DoR-save got erased as well. However, it's ok now. And I've never had this kind of problem with any other game. Probably something with the rom combined with perfect.
     
  6. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    It's been happening with my Phantom Hourglass save too, it's really starting to get to me now that I actually started playing my DS more often...
     
  7. crazyshiza

    crazyshiza GBAtemp Regular

    Member
    108
    0
    Oct 18, 2006
    I think you might have to arm7 patch those games.
     
  8. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    B-B-B-B-BUMP

    Sorry for the bump, but didn't want to make a new thread.

    Ok so now it's corrupting things left and right... Just corrupted my Metal Slug 7 save for the 3rd time. (RAAAAAAAAAAAAAGE)

    So, help me out... thanks.
     
  9. superdude

    superdude GBAtemp Regular

    Member
    274
    0
    Jul 9, 2008
    Canada
    Canada
  10. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Just patched it, going to see if that helps but, it's been corrupting games in GBA mode as well.. so the arm7 patch won't work for everything. [​IMG]
     
  11. Rayder

    Rayder Mostly lurking lately....

    Former Staff
    6,613
    130
    Jan 14, 2007
    United States
    USA
    How much free space is on your memory card? Not having enough free space can cause the corruptions.

    Possibly it's a fragmentation problem. Copy the entire contents of the card to your PC, format the card, copy everything back.

    Those are things to try anyway.
     
  12. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Tried the arm7 patch last night, now the game won't even load, says it cannot find the save.

    I have a 2GB card and there's around 1.1GB free, but I'll give that a try.
     
  13. Toni Plutonij

    Toni Plutonij *has TrolleyDave & tiny p1ngy on moderating shelf!

    Former Staff
    8,153
    314
    Dec 22, 2007
    Croatia
    Depths of Nuclear powerplant
    Well, be sure to format the card first, and try playing again..
    If it happens again, your battery is dieing..You have to replace it with the new one..
     
  14. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Yeah, it didn't help.

    What kind of battery is it and does anyone know where I can get one for cheap?
     
  15. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Re-Soldered the pins to the points in an attempt to somehow get it working again, but still no help. Randomly erasing saves.

    Can anyone tell me the specific battery that the M3 Lite uses? I can't find a direct answer anywhere online...
     
  16. Toni Plutonij

    Toni Plutonij *has TrolleyDave & tiny p1ngy on moderating shelf!

    Former Staff
    8,153
    314
    Dec 22, 2007
    Croatia
    Depths of Nuclear powerplant
    I was trying to find the correct type of battery, but can't find answer anywhere..I remember seeing it somewhere though, but I didn't bother to memorize it..

    Will get back to you if I find it again!
     
  17. Ridlaw

    Ridlaw Newbie

    Newcomer
    3
    0
    Aug 24, 2008
    Brazil
    Hi...
    I'm having the same problem for months, but since it was only with GBA games, and partly because I wasn't playing very often, I did't care.
    But now, after 10+ hours of Final Fantasy IV gameplay I got a corrupted save, and everything was erased.
    I noticed that this happens when I play the game, turn off and try to play after a day or more without having initialized the system. The backup thing somewhat fail and I lost the data.
    Did anyone find a solution?

    Sorry if I didn't make myself clear. English is not my first language, so don't blame me.
     
  18. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Ridlaw, I understood you better than most people who speak English as their native language. [​IMG]

    And I still have not found the answer. I haven't been able to use my M3 in forever, and I ordered a Real from Dealextreme which is taking forever.
     
  19. link459
    OP

    link459 GBAtemp Fan

    Member
    354
    0
    Oct 17, 2006
    United States
    Finally just took the pads off, took the yellow wrapping off, and cleaned the battery.

    Here's what it says on it:

    Thing is, I looked up LIR 1220, and no such battery exists. :/

    I also looked up CR-1220, but they're only 3V. Just going to buy one and hope it works...
     
  20. Ridlaw

    Ridlaw Newbie

    Newcomer
    3
    0
    Aug 24, 2008
    Brazil
    I think it may help. Thanks.

    I was wondering how long did it take until your files start to get corrupted. I mean, is there an estimated/expected lifespan for these batteries? (If that's in fact the problem - and I do think it is).
    My first save loss was FFVI for GBA, something like one year after I bought M3. Shortly after, I had one or two other GBA saves "mysteriously" erased.
    Now, it's been half a year since the sad GBA facts, and any save backup seems to be "unstable".
    Maybe the fact that I wasn't playing regularly contributed, but it's just a hypothesis. All I know is that now I'm afraid of starting any "new game". LoL