Corrupted save data of rental cartridge while using RxTools 2.6

Discussion in '3DS - Flashcards & Custom Firmwares' started by emersonjr, Jan 10, 2016.

  1. emersonjr
    OP

    emersonjr Member

    Newcomer
    31
    0
    Jan 4, 2016
    Brazil
    I have a Pokemon Omega Ruby cartridge, also i have done the downgrade of my Old 3ds XL now it's on 4.2.0 using RxTools 2.6 with Sysnand and Emunand separated.

    Basically, i had inserted my cartridge into the 3ds and booted the rxmode in emunand. After that, i saw that Pokemon was needing to be updated, so i downloaded the .cia updates, sent it to the SD card and used Title Manager to install it. The installation was succesfull and, finally, i touched the pokemon's icon to start the game. Then the terrible message came... The save data was corrupted.

    I didn't get it at all.

    So, i can't use my rental games with RxTools? Have i really lost my save data of Pokemon?
    I'm heavily confused. I need help :(
     
  2. DaftMink

    DaftMink GBAtemp Regular

    Member
    121
    24
    Mar 19, 2015
    United States
    As long as you didn't delete the data the save is still fine.
    All you need to do is upgrade to firmware 9.2 then downgrade MSET for RxTools if you want that entry point.
    Saves made on a higher firmware don't read on lower due to new security protocols.
     
    Last edited by DaftMink, Jan 10, 2016
  3. emersonjr
    OP

    emersonjr Member

    Newcomer
    31
    0
    Jan 4, 2016
    Brazil
    My sysnand is in 4.2 and emunand in 10.3. You mean i should upgrade sysnand to 9.2 ?
     
  4. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    540
    186
    Nov 21, 2013
    United States
    Illinois
    Yes. You no longer need 4.1-4.5 to run CFW. It works on 9.0-9.2 now also. If you update, it should fix your save issue. Even though your Emunand is updated, it still uses your sysnands keys to determine save decryption which is why you get the error.
     
  5. DaftMink

    DaftMink GBAtemp Regular

    Member
    121
    24
    Mar 19, 2015
    United States
    ^ Yep, no harm in updating to 9.2 all the entry points are still their.
     
  6. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    540
    186
    Nov 21, 2013
    United States
    Illinois
    Well except MSET (ds profile - unless you can downgrade this. haven't looked into it). Have to use browserhax, ironhax, oothax, etc.
     
  7. emersonjr
    OP

    emersonjr Member

    Newcomer
    31
    0
    Jan 4, 2016
    Brazil
    You guys are making me have a breath of life again.

    How do i upgrade from 4.2 to 9.2? I think if i just update by the settings it will update to 10.3, doesn't it?
     
  8. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    540
    186
    Nov 21, 2013
    United States
    Illinois
  9. emersonjr
    OP

    emersonjr Member

    Newcomer
    31
    0
    Jan 4, 2016
    Brazil
  10. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    540
    186
    Nov 21, 2013
    United States
    Illinois
    I updated my old 3ds to 9.2 from 4.5 with the exact same method about a week ago and it went fine. Downgrading is what is more risky. Still, it would be a good idea to have a nand backup just in case and always check the hash of the zip you downloaded to make sure the file is intact! ALWAYS TRIPLE CHECK WHEN YOU DOWNLOAD FIRMWARE CIA'S THAT IT'S THE RIGHT REGION AND VERSION!! It seems bricking with sysupdater is user error 99% of the time. Using Teracopy is also a good idea if you wanna be extra careful.
     
  11. emersonjr
    OP

    emersonjr Member

    Newcomer
    31
    0
    Jan 4, 2016
    Brazil
    But which method did you use to install sysupdater on the sysnand?
     
  12. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    540
    186
    Nov 21, 2013
    United States
    Illinois
    Well I have a Gateway so I used that method but rxtool tools method basically does the same thing just using a different method.
     
  13. emersonjr
    OP

    emersonjr Member

    Newcomer
    31
    0
    Jan 4, 2016
    Brazil
    The rxtool installed on my 3ds is 2.6. Why i can't use that version to install the sysupdater?

    The following sentence comes from the tutorial:

    "If you have a cartdridge updated, rxtools nightlies won't work on it, so you need to use rxtools 2.5.2 (and not 2.6). Instructions here : http://rxtools.net/#!howto"
     
  14. Ryft

    Ryft GBAtemp Advanced Fan

    Member
    540
    186
    Nov 21, 2013
    United States
    Illinois
    Beats me. I've only used rxtools once so I'm not familiar with it, sorry.
     
  15. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,630
    438
    Jan 8, 2009
    China
    SysNAND < 6.0 caused the cartridge save corruption.