"Copy to SD Card" option only for gamecube games on USBLoaderGX

Discussion in 'Wii - Hacking' started by jpmcruiser, Oct 30, 2018.

  1. jpmcruiser
    OP

    jpmcruiser Member

    Newcomer
    2
    Oct 7, 2012
    United States
    It doesn't load the games it just asks me if I want to copy or copy to SD, even though all my settings say to load from my external harddrive.

    I have v3.0 IOS 249 Rev 21010

    All the links I've found online are like 5 years old and say to update to the newest version but I have the most recent one if I'm not mistaken.

    This is a basic question but can anyone help me?
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    soooo, you are saying you already have the solution (you need to update to newest) but thought the given solution is wrong?
    5 years old ... is old. last release version is from 2017, and a beta from 2018.

    you are mistaking, you don't have the most recent.

    Are you sure you have v3.0 and not 3.0c ?

    v3.0 and 3.0c is revision r1180
    latest revision is v3.0 r1268


    here is what you need to do : https://gbatemp.net/posts/6478222

    follow this guide and it will tell you how to :
    - replace your full (OLD) channel to forwarder channel
    - install the really most recent version, from the official site (not a random link found on a random guide)
     
    Last edited by Cyan, Oct 30, 2018
  3. jpmcruiser
    OP

    jpmcruiser Member

    Newcomer
    2
    Oct 7, 2012
    United States
    Okay, I got my version thinking it was the most recent vWii version.
    And the credits page says 3.0 with no "c".

    And I'm kind of confused by the differences between forwarder and channel, can you clarify?
    This is the current version right? I had thought I had gotten it from here: https://sourceforge.net/projects/usbloadergx/
    (this link is just for the app itself right? Could you link me to the most recent forwarder/channel)

    In the link you posted, do I want to use any of the links for download since it is 2 years old?
    And in the link, if I'm not mistaken, you're saying to uninstall a full channel and to install a forwarder? I thought I already had a forwarder not a channel.

    I'm sorry this is kind of confusing.
     
  4. jpmcruiser
    OP

    jpmcruiser Member

    Newcomer
    2
    Oct 7, 2012
    United States
    Bump?
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    latest release is revision 1268 (the green button on sourceforge).
    don't use the installer (I think it gets latest "release" not latest revision), just get the zip and extract to your SD.
    latest release is 3.0 revision 1180
    latest revision is 3.0 revision 1268

    full channel = contains the USBLoaderGX program. you need to reinstall a new channel for each new release of the program (and a new release of the full channel to update the program which is inside). There's no new release of the full channel since revision 1180 3.0c.
    forwarder channel : contains a small program to load the "boot.dol" on SD card. it "forwards" to the dol on SD. the advantage is that you never need to update the channel or reinstall it. It will always loads the "boot.dol" on SD card, whatever the version. it's easier to update : replace the dol on SD.


    the forwarder channel is here :
    https://sourceforge.net/projects/us...er GX-UNEO_Forwarder_5_1_AHBPROT.wad/download
    install it using a WAD manager.
    you won't need to update or replace it (unless I release a new forwarder one day, but then I'll tell it to everyone, or I'll update the version to 6.0).

    if you are sure you already have the forwarder, then you don't need to reinstall it.
    if you launch the loader from the channel, and you don't have "3.0c" in the credit page, then you don't have the forwarder, and it should tell you "3.0 r1268".


    to update the loader :
    download the latest revision (green button) on sourceforge, or try the internal option "update the loader".
    but I sometime forget to trigger the update using the internal option, so you better check the site, or my signature to get latest beta.
     
    Last edited by Cyan, Nov 3, 2018
Loading...