Confusion regarding Wii firmware and Wiikey

Discussion in 'Wii - Hacking' started by Fish on a Stick, Sep 29, 2007.

  1. Fish on a Stick
    OP

    Fish on a Stick Member

    Newcomer
    33
    0
    Aug 27, 2006
    I realize this has been asked countless times, and I apologize if any annoyance results from this thread. I've used the search tool and found many other insightful threads but I'm very new to this, and some things are still confusing me.

    I'm getting my wii chipped tomorrow, and it's been recommended that I at least update my firmware to 2.2E, and from the other threads I found, the 3.0 firmware update seems to screw the wiikey up. I have no idea what version firmware my wii has, but I'm pretty sure it's neither of those. (I can't even remember if I've updated at all since launch)

    My question is, should I update the firmware at all? I know there are solutions to the 3.0 update, but I'm not sure if I should update the firmware before or after the wiikey has been installed. And if there's a possible way to update exactly to 2.2? (I hear that playing Metroid Corruption will update it to 2.2, but it's not out in Australia)

    Thanks in advance.
     
  2. manias

    manias GBAtemp Maniac

    Member
    1,258
    0
    Aug 7, 2007
    Netherlands
    3.0 "problems" have nothing to do with the wiikey. the only thing that happens @ 3.0 is non-wii and non-gamecube-marked discs are not bootable.. that's it.
    Just upgrade to 3.0, you will need it for newer games anyway.
    Don't for a minute believe that 3.0 screws with modchips (nintendo put a warning when u try to update post 3.0, which is just that, a warning, nothing happens)
     
  3. Fish on a Stick
    OP

    Fish on a Stick Member

    Newcomer
    33
    0
    Aug 27, 2006
    Alright, thanks Manias.