Confused about whole Firmware thing

Discussion in 'Acekard' started by cphil19, Dec 7, 2009.

  1. cphil19
    OP

    cphil19 Newbie

    Newcomer
    9
    0
    Dec 6, 2009
    United States
    Okay, so I JUST purchased a DSI as well as a Acekard 2i but I want to be ready to set it up when I receive it. First off, I heard if the DSi has 1.4 firmware on it, I need a ds lite or a dsi will lower firmware to be able to update the flash cart to work with my Dsi. If thats the case, do all new dsi's shipping right now have 1.4 already installed? And if thats the case, are there any Acekard 2i's being solid that are 1.4 ready? (meaning, I dont need a seperate dsi with lower firmware or a ds lite to get it to work). As you can see, I'm pretty confused and a little clarification would be great. Thanks
     


  2. Uncle FEFL

    Uncle FEFL OBJECTION!

    Member
    1,175
    24
    Sep 7, 2009
    United States
    PM me for Social Security information
    No. As far as I know, there aren't any preloaded cards updated. There was a competition on Youtube, but that is now over with.

    Do you have a DSLite? I think you should check your DSi's firmware anyway, in case you might be lucky.
     
  3. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Most dsi afaik come with 1.4x firmware. Acekards are not preflashed so only 1.3x or lower. Acekard's can be bought preflashed at gamebygame by adding $5. (which I find a rip off) There might be other places that you can buy it preflashed for no charge but I don't know any.
     
  4. cphil19
    OP

    cphil19 Newbie

    Newcomer
    9
    0
    Dec 6, 2009
    United States
    I don't have a DS lite, and I really don't know anyone who does have one (I kinda live in the middle of nowhere). I just ordered the DSi today from amazon. Chances are, will it be preloaded with 1.4? What are my options if it is?
     
  5. cphil19
    OP

    cphil19 Newbie

    Newcomer
    9
    0
    Dec 6, 2009
    United States
    Okay, so if I buy one thats 1.4 ready from gamebygame, the flashcart will work fine right out of the box with the dsi?
     
  6. rikuumi

    rikuumi GBAtemp Advanced Fan

    Member
    586
    1
    Oct 2, 2008
    United States
    WA
    yeah thats right
     
  7. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Yeah remember to click yes to the DSi 1.4 Ready update before you add it into the cart. Oh and sorry actually the update is $2. [​IMG]
     
  8. cphil19
    OP

    cphil19 Newbie

    Newcomer
    9
    0
    Dec 6, 2009
    United States
    Thanks guys!
     
  9. Lakerfanalways

    Lakerfanalways GBAtemp Advanced Fan

    Member
    882
    10
    Feb 20, 2009
    United States
    The AceKard 2i that I purchased from reelhotstuff.com says that it already updated to 1.4 so does that mean I have to do anything in order to make it work or has the job already been done for me..I just have to pop in my MicroSD card that already has the AKAIO on it and Im good to go?
     
  10. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Oh RHS sells them preflashed? [​IMG] Well at least I know I have a cheaper somewhat option. Yeah just pop it in if it is already updated.
     
  11. Schizoanalysis

    Schizoanalysis From somewhere inside the rabbit hole...

    Member
    2,785
    368
    Jun 23, 2009
    ...
    Which is the file that is used to flash the AK2i (for 1.4 compliance) -- I had a look on th website but I am confused -- it is different to the firmware? yes?
     
  12. Lakerfanalways

    Lakerfanalways GBAtemp Advanced Fan

    Member
    882
    10
    Feb 20, 2009
    United States
    So I just have to put in the MIcroSD Card(Already with AKAIO 1.5 and a bunch of games) put it into the AceKard and Im good to go?
     
  13. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
  14. Schizoanalysis

    Schizoanalysis From somewhere inside the rabbit hole...

    Member
    2,785
    368
    Jun 23, 2009
    ...
    Thanks BoxShout!

    I've been doing some further reading up on this -- and I am wondering -- it appears that the 1.4 AK2i fix is only needed if you are using a US/EUR DSi consoles -- and not a Japanese DSi -- is this correct? Does anyone know?

    I am getting my new Japanese DSi LL in a week or so -- and am wondering if I can get away with not updating my AK2i -- Danny Phantom kinda sucks -- I'll know in 1 week when I get a hold of my DSi LL, but I just thought I'd ask in case anyone knows --

    Thanks!
     
  15. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Nope its required for every 1.4x firmware. You might be thinking about the language fix instead actually. The language fix fixed the fact you could only run the ak2i on the us/eu dsi on the english language option.

    [​IMG]
     
  16. Schizoanalysis

    Schizoanalysis From somewhere inside the rabbit hole...

    Member
    2,785
    368
    Jun 23, 2009
    ...
    Ah! Thanks BoxShot -- now it's making more sense --

    sorry for my noobishness...
     
  17. geonjay

    geonjay Member

    Newcomer
    13
    0
    Nov 29, 2008
    United States
    I just ordered from RHS too - I always order from them, fast and cheap (like my mom)..anyway. Their site does imply that the AK2i card they sell is already "1.4 compatible", but they don't get in to specifics. I'm sending their support an email tonight - maybe they'll speak plainly. Oh, the AK2i + 2GB was $30/USD..not bad

    j
     
  18. Lakerfanalways

    Lakerfanalways GBAtemp Advanced Fan

    Member
    882
    10
    Feb 20, 2009
    United States

    I received my AK 2i today but I have not tried it since I Dont have a DSi and I am thinking about waiting til the new NDSI comes out..but from what others have told me, when it says 1.4 compatible, it means that its already preloaded with the update that makes it work with 1.4 firmware. I did email the RHS a few days ago asking the same question but never got a response, if you do please let me know
     
  19. geonjay

    geonjay Member

    Newcomer
    13
    0
    Nov 29, 2008
    United States
    They replied in record time! They DO flash the chips for you - and they do NOT charge extra for it!


    from RHS Sales
    to geonjay
    date Mon, Dec 7, 2009 at 11:19 PM
    subject Re: General Inquiry Enquiry from Real Hot Stuff

    We upgrade it before we ship it out.
     
  20. Lakerfanalways

    Lakerfanalways GBAtemp Advanced Fan

    Member
    882
    10
    Feb 20, 2009
    United States

    AWESOME news..now I just pop in my MicroSD card which already has AKAIO 1.5 and I am good to go..now the question is, should I get the DSi or wait for the NDSI