CONFIRMED: No roadblocks for 7.0.1 Support on SXOS

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by tinkle, Mar 9, 2019.

Thread Status:
Not open for further replies.
  1. radicalwookie

    radicalwookie GBAtemp Fan

    Member
    5
    Sep 15, 2018
    United States
    Yeah..They have major issues getting it to work lol.
    It’s obvious
     
  2. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Many, if not most, games were incompatible, and some of the games that we're unplayable were AAA games like Mario Odyssey.
     
  3. thaikhoa

    thaikhoa GBAtemp Addict

    Member
    9
    Sep 16, 2008
    Australia
    Custom XCI will do the job. Non of pirates install things without "bypassing". Until the core games need 7.0, there is no need for the hype of it.
     
  4. DayVeeBoi

    DayVeeBoi GBAtemp Advanced Fan

    Member
    5
    GBAtemp Patron
    DayVeeBoi is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Aug 17, 2015
    Canada
    Canada
    This number is so ridiculous that I can't believe people keep quoting it. I remember reading it and laughing when it was originally claimed. I will almost guarantee this was the total number of downloads (at the time) which is a nonsense metric.

    If you look at the reliable (ie; non-industry) piracy studies that have been done (by researchers) the number of people who actually pirate on a platform is so ridiculously low that it makes this laughable (we're talking in the sub 1% range). For this number to be accurate we would have to believe that likely every single person who pirates on the switch bought one SX license, and some of them bought an extra one just to show support.

    Also, thanks for fighting the good fight @Lacius , I gave up a long time ago but I do appreciate that people (against all odds) continue trying to educate. I have no issue with folks that want to use SX for the meagre features that it has over top of the free solutions (to date), I do have a problem with the almost total ignorance some users seem to have of the scene.

    Also, if TX had no roadblocks, they wouldn't have to create a post saying that there are no roadblocks.
     
    Last edited by DayVeeBoi, Mar 10, 2019
  5. NFates

    NFates Wants to understand™

    Member
    7
    Mar 13, 2016
    Dominican Republic
    Probably home.
    Friendly reminder Yoshi's Crafted World comes out in less than three weeks
     
    hippy dave likes this.
  6. thaikhoa

    thaikhoa GBAtemp Addict

    Member
    9
    Sep 16, 2008
    Australia
    Just skip that game if it will need 7.0 keys or so, the demo shows terrible graphics on handheld mode.
     
  7. ZachyCatGames

    ZachyCatGames GBAtemp Addict

    Member
    9
    Jun 19, 2018
    United States
    Hell
    I'd be surprised if Yoshi required 7.x

    And why does that matter?
     
    Lacius likes this.
  8. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    The demo only required the 5.0.0-5.1.0 master key, so it's probably nothing to worry about.
     
  9. Absintu

    Absintu GBAtemp Regular

    Member
    5
    Feb 2, 2018
    Portugal
    Ppl just need a xci loader to get out of bans. Until now, only sxos can do that
     
  10. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Using XCI files is not safe against being banned.
     
    wicksand420 likes this.
  11. NFates

    NFates Wants to understand™

    Member
    7
    Mar 13, 2016
    Dominican Republic
    Probably home.
    Even if the Yoshi game doesn't require 7.0 (my bad), April has a decent lineup.

    BoxBoy + BoxGirl, FFX, Dragon's Dogma, MK11. Smash's Joker DLC likely releases in April, too.
     
    hippy dave likes this.
  12. Absintu

    Absintu GBAtemp Regular

    Member
    5
    Feb 2, 2018
    Portugal
    I've heard that before and the opposite also. thing is: from the ppl I talked that use xci offline, noone got banned
     
  13. sj33

    sj33 GBAtemp Psycho!

    Member
    13
    Oct 22, 2013
    Japan
    It would actually be relatively trivial for them to add support for 7.x by simply integrating sept. The fact that they're clearly so hesitant to do this due to the splashscreen is quite amusing.
     
    g4jek8j54 and Absintu like this.
  14. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
    I used xci backups from day 1 of SX OS. I used one nsp just to try it and learn. Banned right after.
     
    Absintu likes this.
  15. natkoden

    natkoden GBAtemp Maniac

    Member
    6
    Jul 25, 2006
    Argentina
    That might be the reason, LOL
     
  16. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    There are three things that influence game compatibility:
    1. System version requirement flag -> easily bypassed using Tinfoil's bypass option
    2. Master key encryption -> with the correct master key, a title can be not-as-easily decrypted and re-encrypted using a lesser key. Anyone can do this, but it's not fun for the average user.
    3. Software development kit -> There's no way to bypass this.
    Games and updates are already using the 7.0.x version requirement flag, but that's not a big deal. We will probably see 7.0.x master key encryption very soon with digital titles (some updates allegedly have them already), but cartridges probably won't have them for a few months. A game made with an SDK that requires 7.0.x is probably very far away.

    People have reported being banned using XCI files offline and connecting online with the same Switch later. There's a megathread about it.

    I said it earlier in another thread, but the fact that they haven't implemented 7.0.x support using sept yet says a lot about their mindset right now. I see two possibilities as to why they haven't used sept yet:
    1. Their business model necessarily requires that their users are largely ignorant of free alternatives like Atmosphere, and they'd rather wait a long time or never support 7.0.x than show the Atmosphere logo.
    2. Sales are flat enough that they aren't making enough money to warrant even the reduced effort it would take to implement a sept-based solution to 7.0.x.
     
  17. Absintu

    Absintu GBAtemp Regular

    Member
    5
    Feb 2, 2018
    Portugal
    You know just as well as I do how those megathreads go. Ppl tend to "ignore" or "forget" that one time they went online on CFW, that one nsp they installed or that save game they altered...
     
    Romain80200 and huma_dawii like this.
  18. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    In principle, Nintendo should be able to log the use of an XCI, unless its certificate is unique and legitimate for that title. It's plausible that people are using XCI files offline and being banned later.
     
  19. huma_dawii

    huma_dawii GBAtemp Psycho!

    Member
    10
    Apr 3, 2014
    United States
    Planet Earth
    Me included, the first time I got baned was when I forgot I have installed an NSP. Went ahead and updated it and boom, two days later... Banned. Never installed a NSP ever again. So far XCI has kept my new Switch from being banned!
     
    thaikhoa and Absintu like this.
  20. TheZander

    TheZander King of the Level 7's

    Member
    10
    Feb 1, 2008
    United States
    Level 7
    Does no roadblocks mean that there were roadblocks and they got passed them. Or that there were never any roadblocks to begin with?

    I would have been more at ease if they had mentioned it being "clear sailing" however i realize that this particular saying in conjunction with the roadblock one may seem to convolute the metaphorical travel.

    Perhaps i should ask on their forum about this to clear it up, I'll mention the mods hopefully they won't make have to get belligerent with them.
     
Loading...
Thread Status:
Not open for further replies.