CONFIRMED: No roadblocks for 7.0.1 Support on SXOS

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by tinkle, Mar 9, 2019.

Thread Status:
Not open for further replies.
  1. tinkle
    OP

    tinkle taciturn shill girl

    Member
    6
    Jun 9, 2015
    United States
    upload_2019-3-9_16-3-36.
    Just to keep y'all updated, there's no "silently dropping support."
     
  2. iriez

    iriez GBAtemp Fan

    Member
    6
    Oct 27, 2016
    United States
    rookies.
     
    chaoskagami, werta, swabbo and 7 others like this.
  3. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    Is there anymore reason to believe this than there was to believe they had a solution for ipatched Switch units? I'm not saying they're lying here, but it's possible they are. It would be in their financial best interest to do so, even if SX OS had been abandoned.
     
  4. ombus

    ombus GBAtemp Regular

    Member
    4
    Dec 28, 2015
    United States
    Hey man ! great you saw this :D. is there a reason to believe atmosphere will have emunand or silently abandone it ? is still in progress but no news... man... lol
     
    Last edited by ombus, Mar 9, 2019
  5. tinkle
    OP

    tinkle taciturn shill girl

    Member
    6
    Jun 9, 2015
    United States
    It's also entirely possible they have a solution for ipatched units, and haven't yet readied it for release. When a company has a track record of innovation and delivery (EmuNAND three different ways, cheat support first, USB HDD support, the only XCI Loader, et al,) it makes more sense to give them the benefit of the doubt, no?
     
    weatMod, PT333, Vorde and 17 others like this.
  6. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    5
    Jan 31, 2008
    United States
    I dont believe they said they had a solution for ipatched units, other than that they were working on it... much like plenty of others i assume
     
    Tomy Sakazaki, vpd and tpax like this.
  7. JoeBloggs777

    JoeBloggs777 GBAtemp Fan

    Member
    5
    May 30, 2018
    United Kingdom
    oh :unsure: i can see another locked thread coming up:teach:
     
    ZachSZ, tbb043, Nononoki and 5 others like this.
  8. tinkle
    This message by tinkle has been removed from public view by linuxares, Mar 9, 2019, Reason: I'm not even gonna bother comment on this.
    Mar 9, 2019
  9. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    @tinkle
    I've provided reasons (not proof) to believe it might be possible that TX isn't going to update SX OS with 7.0.x support. There's a difference. Please don't be disingenuous.
     
    Last edited by Lacius, Mar 9, 2019
  10. smf

    smf GBAtemp Addict

    Member
    8
    Feb 23, 2009
    It is possible they are lying, it's possible they are telling the truth. I am not arrogant enough to suggest what the odds on each possibility are, it certainly doesn't offer anyone any benefit getting angry either way.

    As for ipatched units, I wouldn't expect anything until mariko is out. I'd certainly be upset if TX released another exploit before then. If you get annoyed with exploit hoarding then you should stay away from the PS4 scene, the switch scene is zero day in comparison.
     
    Last edited by smf, Mar 9, 2019
    PT333, charlieb and DayVeeBoi like this.
  11. linuxares

    linuxares I'm not a generous god!

    Moderator
    15
    Aug 5, 2007
    Sweden
    People have the right to be skeptic, especially since they're paying/paid for a product and a team that said they're able to get hacks running on ipatched switches.
    Especially since Gateway just put their hands up in the air when things started to get hard.
     
    Subtle Demise, Sinon, JeepX87 and 8 others like this.
  12. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    Because of this announcement, I think it's more likely than not that TX is going to come out with something for 7.0.x. However, there's still good reason to be skeptical. People can go back through my posts from earlier today to see why I say that.
     
  13. Essasetic

    Essasetic Your local TX Fanboy

    Member
    8
    Jun 16, 2018
    United Kingdom
    Yep. That's them trying to cover their asses.

    — Posts automatically merged - Please don't double post! —

    You think it's coincidence since Sept dropped SX OS has had the longest drought of updates it has ever had?
     
    Sinon, crissal, clank and 6 others like this.
  14. Dust2dust

    Dust2dust GBAtemp Advanced Fan

    Member
    6
    Jun 17, 2010
    Canada
    I don't get the urgency to get 7.x support. Everything runs fine as is on 6.2. Wanting to update to 7.x just for the sake of being on the latest firmware is kind of pointless. When there will be an AAA title that needs 7.x firmware to work, I'll understand the rush to update.
     
    thaminder, tbb043, PT333 and 13 others like this.
  15. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    I thought I posted a response to this, but apparently I didn't. TX said they had another coldboot exploit that works on ipatched units, but there's good reason to be skeptical of this.

    There's nothing about XCI support, for example, that provides any reason to think there will be 7.0.x support.

    There's not much urgency, but games will eventually require 7.0.x, and people are nervous TX might silently abandon SX OS once it's no longer profitable to support the CFW.
     
    Last edited by Lacius, Mar 9, 2019
    Tomy Sakazaki, CloudLep and Essasetic like this.
  16. linuxares

    linuxares I'm not a generous god!

    Moderator
    15
    Aug 5, 2007
    Sweden
    Latest Tales of Vesperia update for example.
     
  17. tinkle
    OP

    tinkle taciturn shill girl

    Member
    6
    Jun 9, 2015
    United States
    Given the quite transparent fact that Stargate is TX, and Stargate has a monthly revenue stream inherent to it, I think it's foolish to assume they'd murder their cashcow ;)
     
  18. Essasetic

    Essasetic Your local TX Fanboy

    Member
    8
    Jun 16, 2018
    United Kingdom
    Yoshi's Crafted World will likely require 7.0/7.0.1 when that releases.
     
    funnyguywiiu likes this.
  19. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    That all depends on how profitable it is. I don't know the answer to that.
     
    THYPLEX likes this.
  20. Essasetic

    Essasetic Your local TX Fanboy

    Member
    8
    Jun 16, 2018
    United Kingdom
    I mean. Stargate isn't very profitable because they can't keep their damn servers up xD
     
    CloudLep likes this.
  21. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    I don't think it will require the 7.0.x SDK, but it might require the keys. There are inconvenient ways around the latter though.
     
Loading...
Thread Status:
Not open for further replies.