Computer no longer detects removeable usb storage device

Discussion in 'Computer Games and General Discussion' started by dipper145, Jul 17, 2008.

  1. dipper145
    OP

    dipper145 GBAtemp Regular

    Member
    111
    0
    Jun 12, 2008
    Canada
    Well, I used to be able to add and remove stuff from my microsd from my computer, but now all of a sudden it can't. And nothing has changed on my computer, so needless to say I am very confused.

    When inserting and removing the usb transflash thing there is a beep from my computer, and I dont think there was one before.
     
  2. Linkiboy

    Linkiboy GBAtemp Testing Area

    Member
    4,888
    37
    May 14, 2006
    United States
    Does the same thing happen in other USB ports? Do other USB devices work?

    If so, your microsd adapter borked.
     
  3. fischju

    fischju Rehabilitated Jaywalker

    Member
    1,940
    0
    Jan 11, 2008
    United States
    So, you have a microsd with a direct USB adapter? Did that happen to come with a flashcart? Because those adapters die very often. A microsd to USB adapter with a 12-in-1 media reader is a much better solution.

    If you mean a normal flashdrive, I'll assume you have XP and say to try it in other computers. If you have linux, try that, and if it isn't recognized open /var/log/messages after you hook it up to see if there is an error. (I think tail -f /var/log/messages open when hooking it up will tell you right away, but I've only used Linux once)
     
  4. dipper145
    OP

    dipper145 GBAtemp Regular

    Member
    111
    0
    Jun 12, 2008
    Canada
    Okay so i just tried it on my laptop and it works fine there, so it has something to do with my computer. I am using windows XP.

    All my other USB devices work perfectly fine. I even tried putting it in and adding new hardware, but that did nothing. I will continue to search for a solution, but if anyone else cares to help, I would appreciate it.
     
  5. Linkiboy

    Linkiboy GBAtemp Testing Area

    Member
    4,888
    37
    May 14, 2006
    United States
    Have you tried it with other USB ports on the SAME computer?
     
  6. dipper145
    OP

    dipper145 GBAtemp Regular

    Member
    111
    0
    Jun 12, 2008
    Canada
    Yeah I did, and it didn't work.

    But I have it working now.

    I went to device manager and updated all the USB things under that. Somehow some drivers got deleted? Or mysteriously went missing. I don't know how this could have happened, but its windows, strange stuff happens sometimes.

    Its fixed now and working perfectly.

    Thanks.
     
  7. fischju

    fischju Rehabilitated Jaywalker

    Member
    1,940
    0
    Jan 11, 2008
    United States
    Reinstall/update your chipset drivers

    Ah, fixed