cIOSX rev21d2x: Yet Another Hot Fix!!!!

Discussion in 'Wii - Hacking' started by davebaol, Feb 3, 2011.

?

Did d2x work for you?

  1. Yes, I had an issue with the official cios and d2x fixed it

    86 vote(s)
    47.5%
  2. Yes, but everything was already working for me with the official cios

    77 vote(s)
    42.5%
  3. No, and I posted what goes wrong

    9 vote(s)
    5.0%
  4. No, and I won't report what goes wrong because I am a troll

    9 vote(s)
    5.0%
  1. grrkodiak

    grrkodiak Advanced Member

    Newcomer
    72
    0
    Nov 14, 2009
    Canada
    Which base is better for ios 249 to get RB3 instrument not lagging and mic working
     


  2. FIX94

    FIX94 Global Moderator

    Global Moderator
    7,065
    8,824
    Dec 3, 2009
    Germany
    ???
    Use base IOS56 and everything should work fine and fast.
     
  3. grrkodiak

    grrkodiak Advanced Member

    Newcomer
    72
    0
    Nov 14, 2009
    Canada
    is it also possible to play RB3 DLC from USB drive without having to have to use nand emulation
     
  4. Why not use ModMii to create the wads once and install them with a wad manager?
     
  5. jesquinas

    jesquinas GBAtemp Regular

    Member
    124
    0
    Apr 14, 2010
    But if you install the cIOS with MMM isnt necessary remove the stub slots first,simply install the cIOS wads.

    Greetings.
     
  6. jesquinas

    jesquinas GBAtemp Regular

    Member
    124
    0
    Apr 14, 2010
    No,the WD Elements 500 GB (my disk too) doest have any software for disabbling the spinning down feature.

    Greetings.
     
  7. jesquinas

    jesquinas GBAtemp Regular

    Member
    124
    0
    Apr 14, 2010
    Can you tell me where do you observe the spinning down issue in homebrews such as WiiMC?I have the Western Digital Elements 500 GB and I havent observed that behavior,Can you tell me examples because maybe I was confused.

    Greetings.
     
  8. pepxl

    pepxl GFX W!Z4RD

    Member
    3,263
    108
    Jun 19, 2009
    try using Ashampoo HDD Control, it has features to disable AAM and APM for most HDD's, just get the free trial
     
  9. Raul83

    Raul83 Member

    Newcomer
    13
    0
    Sep 14, 2009
    United States
    Just want to add that with this installed as IOS56, Golden Eye menus are fluid in online multiplayer!
    Also online matches seem more fluid (to me at least). Just want to say thanks!! [​IMG]
     
  10. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    ModMii for Windows
    Version 4.4.9 Released!

    by XFlak

    Download ModMii Installer Here


    Not released in French yet, sorry guys, I wanted to add the final changes to the English version before translating v4.4.7, I'll release a v4.4.9 in French as soon as I can



    4.4.8 Changelog
    • Updated d2x cIOSs to v2.
    • Added Return of the JODI exploit for USA and EURO Wii's. Exploit for JAP Wii's
      is included in the download but in it's current form it doesn't work.
    • Updated Wii Backup Manager to v0.3.8 build 60.
    • Other minor changes.
    4.4.9 Changelog
    • Fixed bug causing ModMii to crash when building guides including the Return of the JODI exploit.
     
  11. Monster212

    Monster212 Member

    Newcomer
    26
    0
    Jan 17, 2010
    United States
    great work XFlak thanks a bunch....
     
  12. .44 Magnum

    .44 Magnum GBAtemp Regular

    Member
    104
    28
    Jun 25, 2010
    United States
    Agreed, excellent work XFlak. Very much appreciated.
     
  13. davebaol
    OP

    davebaol GBAtemp Advanced Fan

    Member
    913
    118
    Sep 3, 2010
    Italy
    1st post updated.
    Thanks XFlak. [​IMG]
     
  14. eN-t

    eN-t Member

    Newcomer
    46
    1
    Feb 5, 2011
    Gambia, The
    @.44magnum, @jesquinas:

    OK, I'll try to explain the whole situation as detailed as I can.

    First off, my Wii setup:
    4.3Ev2
    all IOS and cIOS up-to-date (Hermes 5.1, Waninkoko rev21, IOS58 rev6176...)
    boot2v4, BootMii as IOS, PriiLoader installed
    SD Card for Homebrew
    USB-Drive for Games and Media

    My homebrew apps:
    HBC 1.0.8 running IOS58
    USB Loader GX 2.0 rev1067 (on SD Card)
    WiiMC 1.1.2 (on SD Card)
    and other, but that doesn't matter

    My cIOSes:
    202[base60] (Hermes 5.1)
    222[base38] (Hermes 5.1)
    223[base37] (Hermes 5.1)
    224[base57] (Hermes 5.1)
    249[base57] (Waninkoko rev21 OR d2x v2)
    250[base38] (Waninkoko rev21 OR d2x v2)

    My problem in detail:
    When I start games (through any cIOS via any Loader) or homebrew (mostly IOS58, but also others) which make use of the USB drive, I encouter...
    - NO problems in ANY situation with my "WD My Passport 250GB" (formatted WBFS for games and FAT32 for other files [roms, movies...])
    - NO problems in ANY situation with my "32 GB Transcend HighSpeed USB Stick" (formatted WBFS for games and FAT32 for other files [roms, movies...])
    - sth. like LAGS in almost EVERY situation with my "WD Elements 500GB" (formatted WBFS for games and FAT32 for other files [roms, movies...])

    Those LAGS only appear when using the "WD Elements 500GB". For games (started with Hermes and Waninkokos) and for homebrew apps (started with IOS58 and others). These LAGS sometimes do not appear for a while but sometimes it lags really often. These LAGS are best seen in WiiMC and also in Zelda: TP.

    For the ones who try to reproduce the LAGS with a WD Elements drive, try this:
    EITHER
    - format the drive to FAT32 and put some files and folders onto the drive
    - then start WiiMC (1.1.2) through HBC running on IOS58
    - just navigate through the folders and files a little, start some files, end playback, navigate again
    --> you _should_ encouter some "lags": it takes long to open files or folders, sometimes when trying to open a folder there is a timeout ("could not be opened"), but after trying a second or third time it works like a charm - THIS is what I get
    OR
    - format the drive to WBFS (although I think you can also use other formats)
    - install Zelda: TP
    - start the game through any USB Loader (I use USB Loader GX 2.0 rev1067, but the problem already encountered in version 1.x rev938) using any cIOS, I used Waninkokos official IOS249 rev20b and rev21 [base57, but base58 or base56 made no difference for me]
    - run around a little in the game and do some things, e.g.
    --> kill some enemies, pickup blue, yellow, red, purple, orange or silver rupees,
    --> transform to wolf,
    --> teleport, show map,
    --> do some fishing...
    - you SHOULD encounter LAGS when
    --> picking up certain rupees for the first time (it takes several seconds to display the rupees when picked up)
    --> transforming to wolf or human (Link transforms to the wolf and you see the shape, but it takes a while to display the textures or model)
    --> teleporting (it should take a while to display the map, the map menu opens up fast but there is no map for some seconds)
    --> fishing (it takes seconds to display the text string saying "Super!" or sth. like that when you catch a fish).

    I think that's because the HDD spins down because I tried everything (other format, other cIOS versions, other base IOS, other sector size/cluster size for HDD, other partitioning for HDD...) and nothing helped. But with my new HDD or USB stick, there are no problems, no matter what.





    I will try cIOSX rev21 249[57]d2x v2 wednesday in Zelda: TP with the laggy HDD and tell you, if the problem's gone. For instance, I can't say if there is a difference in homebrew using IOS58 (I think there is no difference, why should there be one?!). Would be cool if that Ashampoo works or if the WD Software works now. The first time, it did not.

    Thanks!
     
  15. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    @davebaol, no prob! btw, u may want to update your instructions, you can replace the following steps

    Code:
    6. Enter "D" to download selected files
    7. Enter "Y" to start downloading
    8. Check all the wad files are "valid" then enter "M" to go back at the main menu.
    9. Enter "2" standing for Download Page 2
    10. Enter "MMM" to add to the download queue Multi-Mod Manager
    11. Enter "D" to download it
    12. Enter "Y" to start downloading
    with the following steps instead

    Code:
    6. Enter "2" to navigate to Download Page 2
    7. Enter "MMM" to add Multi-Mod Manager to the download queue
    8. Enter "D" to download your chosen files
    9. Enter "Y" to start downloading
    10. Check that all the files are "valid" then enter "E" to exit ModMii.
     
  16. davebaol
    OP

    davebaol GBAtemp Advanced Fan

    Member
    913
    118
    Sep 3, 2010
    Italy
    Of course.
    Thanks once again.
     
  17. jservs7

    jservs7 GBAtemp Advanced Fan

    Member
    891
    6
    May 14, 2008
    Just wanted to know: Does this new v2 rev give the same scrolling freeze error in Wiiflow (I'm using the latest public build) as it did in v1?
     
  18. sock99

    sock99 Member

    Newcomer
    45
    0
    Feb 3, 2010
    France
    What programming language are cIOS written in? - Might be fun to learn a bit.
     
  19. davebaol
    OP

    davebaol GBAtemp Advanced Fan

    Member
    913
    118
    Sep 3, 2010
    Italy
    C and Assembly
     
  20. Etheboss

    Etheboss Official LULWUT supporter

    Member
    2,444
    667
    Feb 24, 2009
    Netherlands
    Around somewhere
    Fingers crossed, i didn't have the freezes up to now (and still don't while i am testing it at the moment)...but i still can't exclude it totally, random freezing when scrolling through games is still under investigation by the wiiflow dev team.

    Edit: forgot to say, i was also being plagued by these random freezes.