CIA installed, no icon in rxMode emuNAND

Discussion in '3DS - Flashcards & Custom Firmwares' started by chango, Jul 23, 2015.

  1. chango
    OP

    chango GBAtemp Regular

    Member
    116
    22
    Dec 5, 2005
    Syria
    Hello,

    I recently installed 30 or so CIAs via BigBlueBox on an O3DS running RxTools Pasta Edition 2.6

    Upon closing BigBlueBox, all of the unwrapped present icons appeared, but there were blank spaces between them, almost as if it were still waiting for the icons to load, but no icon ever appeared. I further tested this by moving other icons to where the blank icons were, and it did not swap the blank space with the icons I moved, therefore I assumed that it was some weird glitch.

    However, I noticed that only about 20 of the 30 CIAs I installed actually were present. All of those games load just fine, so I went to go re-install the CIAs that didn't install the first time around. But when I tried to do that, it said it was skipping all the CIAs, because "Program already exists", and indeed the title data is present on the left tab in BigBlueBox. But the game icons don't show up anywhere!

    I have no idea where to go from here, all assistance is appreciated.

    Thanks in advance for all the help.
     
    Last edited by chango, Jul 23, 2015
  2. MarcusCarter

    MarcusCarter Goodra the Great

    Member
    435
    102
    Jan 7, 2012
    United States
    Indianapolis, IN
    Try installing FBI with BBM, delete the not working titles through it, reinstall them with it, then tell me if they work or not. BBM can be iffy with some .cia files. Also if you are using the official release of rxTools, unsigned .cia files will not work whatsoever, although SOME might work. You're better off with Gateway for the time being if you want to play any game you want, although I've heard rumors about a modded version of rxTools that, like the latest official release, has the signature checks patched out, but it also allows unsigned .cia's to run. Someone correct me if I'm wrong.
     
  3. chango
    OP

    chango GBAtemp Regular

    Member
    116
    22
    Dec 5, 2005
    Syria
    You're right, its not the official version, its rxPasta edition, it definitely was made so that unsigned CIAs boot. But you say the latest edition of the official rxTools supports unsigned CIAs? Should I switch to that version rather than rxPasta?

    I'll try reinstalling with FBI as you have recommended. These are .CIAs that I have absolutely installed before with BBM and had no problems with whatsoever, albeit with a Gateway.
     
  4. chango
    OP

    chango GBAtemp Regular

    Member
    116
    22
    Dec 5, 2005
    Syria
    I installed Roxas 3.0 Alpha 0 and these previously installed games magically appeared. Odd.
     
  5. StriderVM

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    Here's my theory.

    - The Nintendo 3DS is Region Locked. This means if you buy for example a US 3DS, and you insert a Japanese cart, the game will not load/appear on the home menu.

    - This also applies to Eshop stuff (And CIA files) , unless the CIA has been labeled/modified as "region free", if the game's and consoles region do not match, they will not show up in the home menu. But you can load them direct thru BBM/DevMenu if you know what you are doing.

    - rxTools 3.0 also has removed these region checks so now you can play games that are locked to a specific region.
     
  6. MarcusCarter

    MarcusCarter Goodra the Great

    Member
    435
    102
    Jan 7, 2012
    United States
    Indianapolis, IN
    I was saying that SOME unsigned .cia files MIGHT run, examples including some Custom VC games, and was saying that this applied to roxas75's last release, which was rxTools 2.6. The public mods done by the Pasta team are excluded by my statement due to the latest release by them being in early beta testing phases.


    Ah, okay. Yeah, I wasn't thinking about region locked games. Your theory makes perfect sense, assuming that @chango tried installing region locked games. Thanks for clearing that up @StriderVM.
     
  7. chango
    OP

    chango GBAtemp Regular

    Member
    116
    22
    Dec 5, 2005
    Syria
    Definitely not true in regards to imported games that have not been region-free patched. Many of them launch and play just fine. It wasn't a matter of not being able to play the installed games, the games were installed but simply not showing up. Anyhow, updating to 3.0 alpha 0 fixed the issue and the games appeared.
     
  8. hunter010709

    hunter010709 Advanced Member

    Newcomer
    90
    23
    Jun 27, 2015
    Yes, this is a region issue, nothing else......

    — Posts automatically merged - Please don't double post! —

    Outside your region games will not show.

    It's not that they won't play when launched.

    You will never see the icon to even try to launch it.

    Until recently, cia creation has been a so called 'dirty'.

    Did you dump the said games from your region and do the conversion/patching yourself.

    No you did not......
     
  9. jernk

    jernk GBAtemp Regular

    Member
    106
    65
    Feb 28, 2015
    United States
    If an out of region CIA doesn't appear I just press the power button (without turning it off) and then go back to home screen. After that it should appear as a present (it disappears almost every time so I always do it)
     
  10. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    What a load of shit, official rxtools has supported unsigned cias for months

    OP the issue was fixed because region free support was added in the latest rxtools for cias
     
  11. MarcusCarter

    MarcusCarter Goodra the Great

    Member
    435
    102
    Jan 7, 2012
    United States
    Indianapolis, IN
    I just reread the rxTools homepage, and you're right. Since rxTools 2.5, unsigned .cia files WERE supported. I mixed up the fact that roxas75 PLANNED to disable only SOME signature checks to enable homebrew with the fact that he ended up not doing homebrew support alone, and just enabled all games/homebrew instead like with Gateway. My apologies for the error.
     
  12. proflayton123

    proflayton123 悲しみ

    Member
    5,604
    2,051
    Jan 11, 2016
    Japan
    日本
    I'm having the same problems :(
     
  13. Dylan the Tactician

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    Same issue with a Japanese FE:IF.
    The odd thing is that since this is my second emunand (I bricked my first one, lol), and in the first emunand, it appeared on the home menu. I'm using the exact same .cia file I used the first time as well.

    on rxtools 2.5, going to update it asap.
    The interesting thing, however, is that previously, I was also running rxtools 2.5. I found that... odd that it worked the first time, but not the second.

    [Edit]
    Moved up to 3.0, and it worked, just like everyone else has been saying.
     
    Last edited by Dylan the Tactician, Feb 6, 2016
  14. proflayton123

    proflayton123 悲しみ

    Member
    5,604
    2,051
    Jan 11, 2016
    Japan
    日本
    Having the same problem ><
     
  15. Dylan the Tactician

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    You on rxtools 3.0? Or 2.5?
     
  16. proflayton123

    proflayton123 悲しみ

    Member
    5,604
    2,051
    Jan 11, 2016
    Japan
    日本
    I got it working eventually, thank you though