RELEASE ChoiDujourNX - a system firmware installer homebrew for the Nintendo Switch

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by rajkosto, Aug 1, 2018.

  1. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    10
    Dec 26, 2015
    United States
    7.0.1 emunand work fine.

    — Posts automatically merged - Please don't double post! —

    If you are on exfat that is your issue.
     
    skinnyBIGGS likes this.
  2. enderer

    enderer GBAtemp Regular

    Member
    3
    Jul 19, 2015
    United States
    i am not on exfat. i was on 64gb fat32 and just switched to 128gb fat32 and both sd cards give the same message. i tried updating atmosphere and still get the same message.
     
  3. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    10
    Dec 26, 2015
    United States
    You try the latest kosmos file pack?
     
  4. enderer

    enderer GBAtemp Regular

    Member
    3
    Jul 19, 2015
    United States
    i updated to kosmos 12.0.1 and now i can run goldleaf (and probably other apps) but when i try to run a game, i get the same message about corrupted data or 'unable to start software'. could it be sigpatches or something stupid like that?
     
  5. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    10
    Dec 26, 2015
    United States
    Sig Patches
     
  6. enderer

    enderer GBAtemp Regular

    Member
    3
    Jul 19, 2015
    United States
    it works now! whew! i was freaking out for a second. thank you for your help and your prompt replies. :)

    EDIT: update, all but 2 games work. i guess i'll have to reinstall super mario bros u deluxe and super smash bros ultimate.
     
    Last edited by enderer, Apr 15, 2019
    Hayato213 likes this.
  7. Philliyxx

    Philliyxx GBAtemp Regular

    Member
    3
    Sep 21, 2018
    United States
    Install the sig/acid patches
     
  8. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Did...did you just ignore all of the posts after the one you just quoted including the one right before your post where OP had already solved his problem???
     
    XaneTenshi likes this.
  9. Philliyxx

    Philliyxx GBAtemp Regular

    Member
    3
    Sep 21, 2018
    United States
    Looks like I did whoops sorry, was on the previous page and didn't see there was a whole next page :unsure:
     
    Last edited by Philliyxx, Apr 15, 2019
    Draxzelex likes this.
  10. huma_dawii

    huma_dawii GBAtemp Psycho!

    Member
    10
    Apr 3, 2014
    United States
    Planet Earth
    Can I downgrade to 7.0.1 without a NAND backup from 8.0 with regular Choidujour without autoRCM?
     
  11. Philliyxx

    Philliyxx GBAtemp Regular

    Member
    3
    Sep 21, 2018
    United States
    If you can enter RCM and have your prodinfo and Biskeys you can downgrade/rebuild with choidujour to 6.1. then use choidujournx to go back up to whatever higher fw you want

    https://guide.sdsetup.com/usingcfw/manualchoiupgrade
     
  12. Neath

    Neath Advanced Member

    Newcomer
    3
    May 1, 2013
    Canada
    Canada
    Hey guys. A little bit out of the scene but I went from 5.1 to 7.0.1, my switch completed the installation successfully, but now when I go to launch my switch, the payload is successful but doesn't get past the Nintendo screen. Just black from there. I've updated my sdfiles (I think?) through sdsetup.com and am running atmosphere 0.8.7. Can someone help?

    edit: nevermind. figured it out. ok if you run into this problem, you have an exfat sd card and you selected the non-exfat installation in choi. so you need to either grab another microsd card and put on the necessary files, or backup and clear off ur current one (and format it to fat32) and reinstall the 7.0.1 WITH exfat. once your done you can set your card back up or just use your other one if you had two. enjoy!
     
    Last edited by Neath, Apr 19, 2019
    MrNiceDonovan likes this.
  13. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    7
    Aug 23, 2013
    im confused i want to update but im worried cos of reading this "quote You cannot upgrade or downgrade directly to 6.2.0, 7.0.0, 7.0.1 or 8.0.0 as the ChoiDujour PC application does not support these firmware versions" so if i cant update directly to 7.01 then how am i ment to do it?
     
  14. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    That comment is only meant for ChoiDujour. This is the thread for ChoiDujourNX.
     
  15. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    7
    Aug 23, 2013
    okay thanks for pointing that out. sorry to be a dumbass but whats the difference?
     
  16. Taorn

    Taorn GBAtemp Regular

    Member
    4
    May 27, 2017
    United States
    Choidujour and ChoiDujourNX are two separate applications. ChoiDujourNX will work fine for upgrading to 7.0.1.
     
  17. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    ChoiDujour is a Windows exe. ChoiDujourNX is a homebrew application for the Switch.
     
    jammybudga777 likes this.
  18. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    7
    Aug 23, 2013
    so which version is prefered these days? can i go straight from 6.2 to 7.1 using ChoiDujourNX without problems?
     
  19. jammybudga777
    This message by jammybudga777 has been removed from public view by Joe88, Apr 19, 2019.
    Apr 19, 2019
  20. jammybudga777
    This message by jammybudga777 has been removed from public view by Joe88, Apr 19, 2019.
    Apr 19, 2019
  21. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Depends. ChoiDujourNX works across all firmware versions but requires CFW and homebrew so for people who updated to a firmware CFW does not support, such as the newly released 8.0, ChoiDujourNX is useless for them while they are still on 8.0. ChoiDujour doesn't require CFW but can only downgrade to firmwares 6.1 and below (at the moment which is subject to change) so it is useful for those situations where people cannot boot CFW but wish to downgrade in order to use CFW rather than wait for CFW support on their current firmware.

    As for your other question, you can use ChoiDujourNX to install any firmware you give it. Well maybe not 8.0 since its not supported by CFW just yet.
     
  22. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    7
    Aug 23, 2013
    so if i jump from 6.2 to 7.1 its not going to cause issues as long as i do it properly? thanks for your replys and help btw
     
  23. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    I don't know of any issues outside of booting a CFW that doesn't support 7.1
     
  24. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    7
    Aug 23, 2013
    Don't all cfw support 7.1 now?
     
Loading...