Changed PSV SD Card and now SD2VITA wont work (on 3.60)

Discussion in 'PS Vita - Hacking & Homebrew' started by xXxSwagnemitexXx, Aug 13, 2018.

  1. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    My dad has a PSVita on 3.65 (Title says 3.80 because I got the version number wrong) and he had an SD2Vita. He would use H-Encore to run the exploit each time he rebooted, but he usually kept it in sleep mode. Anyway, without talking to me, he sold his 16GB PSVita SD Card and got a 4GB one for some money and I didn't get the chance to transfer the content. I got h-encore back onto his SD Card and installed the driver for the SD2Vita again. But none of his games he installed through PKGJ are there including PKGJ. The only thing thats there is the SD2Vita switcher app and VitaShell (On system storage). Vitashell is recognizing it but in PKGI (idk why PKGI is still there(he used PKGI before PKGJ)) it still says its the 4GB one in the bottom right corner. I have no idea how to get his SD2Vita working again.
     
    Last edited by xXxSwagnemitexXx, Aug 15, 2018
  2. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    There is no firmware 3.80
     
  3. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    the vita is on the latest firmware, i forgot what the latest version number is

    — Posts automatically merged - Please don't double post! —

    its on 3.65
     
    Last edited by xXxSwagnemitexXx, Aug 15, 2018
  4. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    4GB, is too small, you can barely even install one game. If the 4GB isn't mounted as ux0 you can't install vita games on to it.
     
  5. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    i have the 4gb mounted as UX0 until i run h-encore, which mounts the SD2Vita as UX0. All the games are installed to the SD2Vita
     
  6. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    Back to your problem, it is because SD2Vita require a restart for it to work.
     
  7. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    I restarted after installing the driver with Switch SDVita and it still doesn't work
     
  8. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    Gamesd.skprx is a kernel level plugin that require restart, you can try Celeste Blue StorageMgr if you want, it can do everything Gamesd.skprx can do.
     
  9. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    I'll try it, and do you think I should install Enso after installing StorageMgr incase that helps?

    Edit: The PSVita is on 3.65, sorry for all the version mistakes
     
  10. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    If you are on 3.65, then you can install Enso, don't install Enso if you are on 3.67 and 3.68, the vita has no nand restore method.
     
  11. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    Thanks, I'll do it while installing the StorageMgr
     
  12. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    You can set up one of them first, then do the other, maybe do enso first.
     
  13. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    Okay, will do, thanks
     
  14. DinohScene

    DinohScene Feed Dino to the Sharks

    Moderator
    22
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Oct 11, 2011
    Antarctica
    Восторг
    Changed your thread title to correctly reflect your FW version.
     
  15. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    thanks
     
  16. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    I set up the StorageMgr thing and in Vitashell it says the SD2Vita is mounted as UX0, in PKGI it says the Sony SD Card is mounted as UX0 and none of the games on the SD2Vita are showing on the home screen
     
  17. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    did you removed Gamesd.skprx and restart ?
     
  18. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    yes
     
  19. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    9
    Dec 26, 2015
    United States
    MCD=uma0
    INT=imc0
    GCD=ux0
    UMA=grw0

    That is the mounting points in the Storage_config.txt
     
  20. xXxSwagnemitexXx
    OP

    xXxSwagnemitexXx meme machine

    Member
    5
    Dec 7, 2016
    United Kingdom
    New Donk City
    I left storage_config.txt as the default

    — Posts automatically merged - Please don't double post! —

    I left it as default because it does what I want (SD2Vita as UX0) except it doesn't work
     
Loading...