Change: from a JP Wii to an US Wii

Discussion in 'Wii - Hacking' started by Kenshin Br, Dec 18, 2008.

  1. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    Hello,

    I have a japanese Wii (yeah, that's bad, I know).

    My console runs fine the most part of the ISOs from any regions, but for official US games I think that it just don't work.

    But I want to have a little collection of official games. So I'm thinking about to sell it and buy an US Wii. But this is a bad way for me. It's too difficult and here in Brazil videogames are soo expensive. Wii here costs something about 600 US dollars.

    So, while I was searching about Homebrews I found a application called "AnyRegion Changer" ( http://wiibrew.org/wiki/AnyRegion_Changer/ ) and one of it's features is to change the Wii "game settings", determining "which region of Discs and channels the System Menu will boot".

    I would like to know if this application can really change the region of my Wii. In simple words, if my japanese Wii can be changed into a US Wii and if I will be allowed to play official US games on it whithout problems - I don't care about other channel or Wii shop.

    So, if you can help me, please, post here. [​IMG]

    I'm really in trouble because if I sell this japanese Wii I don't know if I'm going to have money to buy another one next year.

    Thanks.
     
  2. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    Yea that program works great, but you could try using the program Geckos to run your US games or install starfall, But if you really want to use any region changer just change your Game region setting to US you really should not have to completely change your system over to US cause both US and JAP are NSTC
     
  3. Rock Raiyu

    Rock Raiyu Clock Up

    Member
    5,065
    38
    Jul 14, 2007
    United States
    Walking the path of heaven
    AnyRegionChanger can change the region of the Wii to US and you can play official US games.
     
  4. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    Thanks for the answers. I don't know nothing about homebrews but I will try to know about it and do this.

    Thanks. [​IMG]
     
  5. Vidboy10

    Vidboy10 Tsardom

    Member
    2,617
    7
    Dec 15, 2008
    Canada
    Vancouver, B.C
    im curious witch frimware are you on?
     
  6. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    3.3J.

    Why? Are there some problem in it?
     
  7. Vidboy10

    Vidboy10 Tsardom

    Member
    2,617
    7
    Dec 15, 2008
    Canada
    Vancouver, B.C
    Nope not at all!
    just saying if you downgrade to 3.2J and install Starfall than you can play region free games. [​IMG]
     
  8. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    Ok. [​IMG]
     
  9. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    One more question.

    My Wii is a japanese Wii with 2DCkey.

    Can I use the Twilight Hack without problems right?
     
  10. Vidboy10

    Vidboy10 Tsardom

    Member
    2,617
    7
    Dec 15, 2008
    Canada
    Vancouver, B.C
    Nope Shouldn't even hurt your wii at all!
     
  11. wanders

    wanders Advanced Member

    Newcomer
    63
    0
    Dec 14, 2008
    United States
    If you change your 'Console Area Region' region (something you have no reason to do really) with AnyRegionChanger, make sure you switch to the appropriate firmware... If you're just changing the console's GAME region, then don't worry about it.

    Could always try Gecko OS too, as WiiBlaster suggested.
     
  12. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    So, I just don't have to touch the 'Console Area Region', right?

    But to allow my Wii show the menus in English... What I need to do? Just to put 'language setting' in English? Can I install a 3.2U system menu on the console?

    [​IMG]
     
  13. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    just game region setting to NSTC\US ,and Lang to US\Eng but really man i recommend Geckos or Starfall, so you can play both your region games
     
  14. Vidboy10

    Vidboy10 Tsardom

    Member
    2,617
    7
    Dec 15, 2008
    Canada
    Vancouver, B.C
    Get frimware downgrader and select on 3.2U and it will install and it will ask for for a region menu patch and say yes
     
  15. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    Ok. [​IMG]
     
  16. Unholy360

    Unholy360 Member

    Newcomer
    21
    0
    Dec 5, 2008
    Hang on a sec, I thought starfall will not work if you have a Japanese Wii.

    Well at least that's what the Wiibrew site says.
     
  17. djsika

    djsika Advanced Member

    Newcomer
    70
    0
    Mar 5, 2008
    United Kingdom
    I had a jap wii on 3.3j i used anyregion changer to go to 3.2j and then i went to 3.2U, now my machine is fully english and i can play usa originals (dunno why i did it i'm in the uk haha) but yeah i also have starfall installed and have all options installed, hope this helps
     
  18. Kenshin Br
    OP

    Kenshin Br GBAtemp Regular

    Member
    146
    0
    Mar 6, 2008
    Brazil
    Yeah. This is exactly what I want to do.

    I'm still downloading Zelda TP JPN to install the but I think it will works great.

    Thanks to all helpers.
     
  19. kindaichi

    kindaichi Member

    Newcomer
    21
    0
    Aug 2, 2006
    Hi,
    I´m from Brazil too... right now i have a Wii 3.2J and i can play any game using GeckOS.(and SoftMod for Rock Band)
    My Wii has a D2Ckey chip, and i didn´t change to 3.2U because oI don´t want to open again my Wii.

    If u use a Wiikey 1.9g u can change your Region only using your DVD Boot... for the wiishop and wiiweather there is a wakinko program thant change that.(don´t remember the name)

    And i have the same doubt... Unholy 360, in Wiibrew they say that only 3.2E and 3.2U can use Starfall... that´s why i didn´t tried.
    So all my games i pass WBB, and sometimes WiiFrii 3.2b