CFW detects phantom controller keypresses

super_copy

New Member
OP
Newbie
Joined
Nov 24, 2013
Messages
3
Trophies
0
Age
121
XP
40
Country
Hello. I just did a jailbreak and installed EvilNat 4.88.2 CFW on my PS3 slim. It boots and works fine, but a few applications are exhibiting a very strange problem: as soon as I launch them, they seem to detect keypresses from a non-existent (phantom) controller, cursor moves erratically to the left or to the right, and the apps are unusable. This happens on two apps so far:

1. multiMAN v04.85.01
Its XMB-style screen, and its file manager screen, appears and disappears while I move around the menus, and flickers and shows a few dots, as if screen is trying to repeatedly refresh the menu items.

2. YouTube NoPSN version 3.03
As soon as I launch it, it prompts me to speak into a microphone. I do NOT have a microphone (headset or whatever). Prompt disappears on its own.
When I try to watch ANY video, the video progression slider moves to the right and back to the left at random, so the app keeps seeking and rebuffering without being able to play any video content.

And it does NOT happen with anything else;
XMB: all menu items work fine, no phantom key presses or undesired scrolling
Amazon Prime Video NoPSN (v4.2 I think): menus work, I can watch movies without a hitch
Movian 5.0.723: all menus work, but when I play videos from a SAMBA folder, keeps rebufferingk, so I'm not sure whether I have a network problem, or the phantom controller is causing trouble here as well.

At first I thought it might be controller, some bad contact or stuck key. I tried a different controller and got the exact same behavior as above.
Also I think if the controller were malfunctioning, I would see problems navigating the up,down,left,right menus of ALL apps, but problem only affects the two apps above.

It feels as if some apps have a different way of taking inputs from controllers, and they keep detecting that some phantom controller has the "right" or "left" button always held down.

I checked my list of BlueTooth devices, nothing paired.

Also should mention, to do the jailbreak, I had to update OFW from 4.46 to 4.80, then use PS3Xploit dot com BG Toolset. When it backed up and flashed the 16 MB NOR, I did not see any CFW at v4.80, so I decided to install "CFW 4.88.2 Evilnat Cobra 8.3 [CEX]". Is it OK for NOR to contain hacked firmware from 4.80, while the rest of CFW is 4.88.2?
 

thominho

Active Member
Newcomer
Joined
Feb 9, 2014
Messages
36
Trophies
0
Age
27
XP
676
Country
Greece
I will play the stupid card of the prank from someone but probably you would have known it until now. But in a realistic case, first disconnect everything and watch how the PS3 behave when you connect each controller one by one with some button smashing and a 10 minutes gap between each new connection.

Case example: Controller 1 connected => Press X,Δ,Χ,Δ,LEFT,RIGHT,START,SELECT,RESTART PS3,START PS3,STOP PS3,Play a game 10 minutes, run some other homebrews, restart PS3 etc
Controller 2 Connected ....
Controller 3 Connected ...

It will take you some time like 2-3 hours but at least you will found the culpirt
 

Dave_Chad

Well-Known Member
Member
Joined
Jun 29, 2016
Messages
722
Trophies
0
Age
35
XP
2,094
Country
I'm pretty sure some of those have sixaxis controls on for some reason. It should stop if you hold the controller perfectly level then you can browse for the setting and disable it.
 

super_copy

New Member
OP
Newbie
Joined
Nov 24, 2013
Messages
3
Trophies
0
Age
121
XP
40
Country
Thorminho:
I was trying my two controllers one at a time, i.e. while testing one, I kept the other one completely off, all 4 LED lights off, and out of range.

Dave_Chat:
I tried that, does not make a difference. The phantom button presses seem to kick in at random times, while controller is level and untouched on a table.

Again the really baffling aspect is that the problem does NOT follow either of the controllers. Does NOT happen to XMB and most apps. It ONLY happens to MultiMAN and YouTube.

I just tried poking that tiny reset button on the bottom of the controllers and reconnect them. Did not help.

Thank you both for replying.
 

thominho

Active Member
Newcomer
Joined
Feb 9, 2014
Messages
36
Trophies
0
Age
27
XP
676
Country
Greece
Thorminho:
I was trying my two controllers one at a time, i.e. while testing one, I kept the other one completely off, all 4 LED lights off, and out of range.

Dave_Chat:
I tried that, does not make a difference. The phantom button presses seem to kick in at random times, while controller is level and untouched on a table.

Again the really baffling aspect is that the problem does NOT follow either of the controllers. Does NOT happen to XMB and most apps. It ONLY happens to MultiMAN and YouTube.

I just tried poking that tiny reset button on the bottom of the controllers and reconnect them. Did not help.

Thank you both for replying.
Can you please check from Bluetooth Devices that any other Bluetooth device is not connected? They may interfere

EDIT: if youtube prompt you that a headset is on then maybe you have forgotten a headset connected. Even if you haven't it near you please disconnect them all and try again. To give you an example, I had a PC Controller with a USB receiver, and some months later I started "drifting". It wasn't the controller but when the signal was bad for a reason it started drifting.
 
Last edited by thominho,
General chit-chat
Help Users
  • No one is chatting at the moment.
    DEMONGreninjaPG @ DEMONGreninjaPG: oooh pizzza can i get a all meat pizza with pineapple