CFW 10.3.0-28 U and cheat engine or the like?

Discussion in '3DS - Homebrew Development and Emulators' started by MisterDragon2012, Jan 26, 2016.

  1. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    Hey folks,

    I have Ninjhax 2.5 installed and functional on my N3DS XL with 10.3.0-28 U running.

    Is there any possibility to have a value editor such as a cheat engine or similar for the games running as .3ds on sky3ds+(plus)?

    Please advise?


    Additionally,

    Is there a possibility of an editor for save game files as Powersaves does not work with sky3ds+(plus).



    Thanks,

    MD2012
     


  2. A_Random_Guy

    A_Random_Guy Officially That Dev

    Member
    862
    459
    May 22, 2015
    Malaysia
    Smea's closet
    For ram cheats, you would need to use NTR CFW which is for 9.2 and below sysnand 3DS and 9.3+ emunand.
     
  3. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    So if I read this correctly:
    I need to get emunand, as I am running 10.3.0-28 U?
    Or do I need sysnand 3DS?
     
  4. Wolfy

    Wolfy Person That Never Was

    Member
    545
    203
    Aug 18, 2015
    United States
    Somewhere In The Aether...
    As @A_Random_Guy said, you need to downgrade to 9.2 and then create an EmuNAND which you would then need to update.
    But currently downgrading comes with a huge risk, if you screw up, there's a chance to brick your 3DS, even more than that, if its only a softbrick, then you would have to update to the latest firmware, aka. 10.5
     
  5. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    He didn't say that, but that's okay.

    So I'm looking to see if there is any way for the version I am running 10.3.0-28 U?
     
  6. einhuman197

    einhuman197 GBAtemp Advanced Fan

    Member
    942
    356
    Aug 17, 2015
    Germany
    Inside your bootloader (´◉◞౪◟◉)
    There's no other way then downgrading or waiting.
     
    MisterDragon2012 likes this.
  7. Favna

    Favna #PCMasterRace

    Member
    807
    390
    Sep 12, 2009
    Netherlands
    The risks where pretty much ironed out already since it now installs NATIVE_FIRM first instead of last tho
     
    PokeAcer likes this.
  8. Wolfy

    Wolfy Person That Never Was

    Member
    545
    203
    Aug 18, 2015
    United States
    Somewhere In The Aether...
    I know that he didn't say that exactly, but it implied it since that is what is required to load EmuNAND

    Good to know, I have a 10.3U N3DS and was hoping that I would eventually get the chance to, I'm probably at least going to wait until Smea releases *hax 3.0
     
    MisterDragon2012 likes this.
  9. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    Implying doesn't help here lol. (Being as clear as possible will benefit all involved, especially someone like me who is not 100% immersed in this yet) thank you a ton though for helping me understand what he meant [noob here sorry]

    Good to know though, does anyone know of save editors then or is it a waiting game again?
     
  10. Wolfy

    Wolfy Person That Never Was

    Member
    545
    203
    Aug 18, 2015
    United States
    Somewhere In The Aether...
    Sorry for not making it clear to those who are not aware of such requirements, but happy to help for the other points :)

    And there are save editors, but not as numerous as you may want, the more popular games will usually have editors for them though.

    Go here if you want to check them out... https://gbatemp.net/forums/3ds-rom-hacking-translations-and-utilities.276/
     
    MisterDragon2012 likes this.
  11. Juiss

    Juiss GBAtemp Regular

    Member
    180
    52
    Jan 3, 2016
    France
    You're 4 weeks late with that warning buddy, downgrading has been pretty much "safe" for a while now.
     
    TheKawaiiDesu likes this.
  12. Favna

    Favna #PCMasterRace

    Member
    807
    390
    Sep 12, 2009
    Netherlands
    Yeah so ... aside from downgrading being safe already, smea isn't releasing *hax 3.0 most likely anymore: https://twitter.com/smealum/status/689689112954023936
     
  13. Shadowfied

    Shadowfied GBAtemp Advanced Maniac

    Member
    1,655
    1,450
    Dec 6, 2014
    I don't really see the point in waiting for *hax 3.0. Even when it does come, it has nothing with downgrading and EmuNAND to do, so I'd advice you to downgrade ASAP. Use SafeSysUpdater and you'll be good, then backup your SysNAND, get a CIA installer and create an EmuNAND and you're good to go.
     
    Favna likes this.
  14. Wolfy

    Wolfy Person That Never Was

    Member
    545
    203
    Aug 18, 2015
    United States
    Somewhere In The Aether...
    Wanna send me the link to a guide so I can get started then? And thanks for the info x3
     
  15. Shadowfied

    Shadowfied GBAtemp Advanced Maniac

    Member
    1,655
    1,450
    Dec 6, 2014
    This is the one I used when downgrading my systems. Follow the steps there but use SafeSysUpdater instead. They're essentially the same but SafeSysUpdater will only let you go through if the MD5 hashes of the updates match (= are the right files for your system) the correct ones. With these checks, it's essentially impossible to brick unless you power down your system in the process or do some other absolutely moronic thing ^^ Let me know if you have any questions or need help, post here or PM, whatever you'd like.
     
  16. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    Seems like this is a very easy downgrade process? Less than 10 minutes from start to finish?

    Is it possible to downgrade from 10.3.0-28U to 9.2?
    Has anyone had direct experience with a N3DS XL 10.3.0-28U to 9.2?

    What are the benefits over using just a Sky3DS+(plus) vs downgrading to 9.2 firmware?
     
  17. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,810
    4,992
    Mar 17, 2010
    Norway
    Alola
    There are some claims that softbricks are more likely to happen on lower firmwares and that 10.3 is the best firmware to downgrade from, I don't believe them though. It doesn't really make sense that it would be less likely to brick on a newer firmware. The exploit and all the code is the same regardless of what firmware version you are running.
    As long as you have a working homebrew entry point and 10.3 or lower firmware you can downgrade.
     
  18. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    What are the benefits over using just a Sky3DS+(plus) vs downgrading to 9.2 firmware?
     
  19. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,810
    4,992
    Mar 17, 2010
    Norway
    Alola
    There aren't really any benefits to using a Sky3DS+, only limitations.
    You can still use your Sky3DS+ on emuNAND if you want to run .3DS roms, but additionally you'll be able to use unsigned CIAs such as homebrew, eShop games in CIA format, plugins/cheats in NTR-CFW, custom theme CIAs, DLC CIAs, on 9.2 the system is pretty much blown wide open and the sky is the limit (pun not intended)
     
    MisterDragon2012 likes this.
  20. MisterDragon2012
    OP

    MisterDragon2012 Advanced Member

    Newcomer
    57
    1
    Jan 1, 2016
    United States
    So, once I downgrade to 9.2, what would be my next step in order to use NTR? - Do you recommend any guides? - There seem to be a lot of options out there, but I am way late to the 9.2 party - so how should I start?