can't use sd card, is there a way to update Pios 236 ?

Discussion in 'Wii - Hacking' started by yazeed44, May 10, 2014.

  1. yazeed44
    OP

    yazeed44 Newbie

    Newcomer
    5
    0
    May 10, 2014
    Saudi Arabia
    Hi everyone

    i softmodded my wii before a long time , so i wanted to update the IOS236 and stuffs to make zelda work on my wii

    the problem : the sd card can't be used , in homebrew channel it can't detect any apps , if i pressed on ( internal sd card ) the screen will become black and i got an exception

    i tried usb and it works fine

    is there a way to update through usb ?

    thank you
     
  2. yazeed44
    OP

    yazeed44 Newbie

    Newcomer
    5
    0
    May 10, 2014
    Saudi Arabia
    My wii version is 4.2U
     
  3. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    3,986
    1,123
    Nov 21, 2005
    United States
    what is a "pios"
     
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,290
    5,316
    Mar 17, 2010
    Norway
    Alola
    I have no idea what you are trying to do or what a "pios" is, but if HBC crashes when you try to switch to SD card you should try reformatting it (as FAT32), or try a different card.

    ^ What this guy said.
     
  5. yazeed44
    OP

    yazeed44 Newbie

    Newcomer
    5
    0
    May 10, 2014
    Saudi Arabia

    sorry i meant IOS236​


    actually i formated it to fat 32 and fat , but it didn't work​

    and my sd card is sandisk , it should be work according to http://wiibrew.org/wiki/SD/SDHC_Card_Compatibility_Tests


     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,914
    Oct 27, 2002
    France
    Engine room, learning
    IOS236 doesn't have different version.
    You don't update it.
    It's not needed anymore anyway...

    And it's not used to make a game work, it was used to get access to NAND which is now possible without cIOS.


    I don't know what you think you want to achieve, but don't do things you don't understand fully!
    Don't update, don't install anything, don't follow an old outdated guide, don't follow a youtube guide.


    If you have an issue with a game, explain your issue and we will help you.
    if you want to make zelda work, I suppose you are talking about Zelda Skyward Sword.

    There are two method to get it work:
    Update your d2x cIOS to v7 or newer (install v10!)
    or
    go to your loader settings and choose to boot an alternative dol for that game. You have a video.dol and another .dol, select the second one.
     
  7. yazeed44
    OP

    yazeed44 Newbie

    Newcomer
    5
    0
    May 10, 2014
    Saudi Arabia
  8. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    3,986
    1,123
    Nov 21, 2005
    United States
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,914
    Oct 27, 2002
    France
    Engine room, learning
    Please, don't follow random guides!


    The guide you linked is for WiiU, not for Wii! You will brick your console.

    the Guide you found are not "update" but "install" method.
    If you want to update, don't follow that guide.


    tell us what you want to do, and we will help you.
    You don't need SD card to play Zelda or to update your softmod.
    You need SD card only to install the softmod the first time.
     
  10. yazeed44
    OP

    yazeed44 Newbie

    Newcomer
    5
    0
    May 10, 2014
    Saudi Arabia
    ok , i want to update my softmod so i can play all the games ,

    Thanks for replay ^_^
     
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,914
    Oct 27, 2002
    France
    Engine room, learning
    I thought you wanted only to play Zelda.
    You don't need to update the softmod to play Zelda, but you can do it.


    To update, you can use modmii program on your computer (if you have windows).
    You answer few questions and it will download all needed files, and will generate a guide.
    Follow the guide step by step to update your softmod.
    Instead of putting the files on SD card, you can place them on USB.

    It should update your homebrew channel, and your system files.



    Maybe your homebrew channel is already updated, and you only need to install the system files?
    You can check your Homebrew channel version : Press Home, and look at the top right.
    If it's "Version 1.0 or newer, using IOS58" then you are fine.

    If you want to update only the system file manually let me know.