Can't update HBC

Discussion in 'Wii - Hacking' started by Raylene2K7, Nov 6, 2010.

Nov 6, 2010

Can't update HBC by Raylene2K7 at 5:46 PM (3,571 Views / 1 Likes) 29 replies

  1. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    I haven't done much with my Wii since spring so today I wanted to update my Wii's Homebrew Channel from 1.06 to 1.08 but I received this error:



    "This installer can NOT continue!

    There is no usable or vulnerable IOS installed on this Wii.
    Please not that we will not use fakesigned IOSes due to
    security reasons. Only UNPATCHED versions will be used!

    Read the FAQ at: http://hbc.hackmii.com/faq/
    Look for an updated version at: http://bootmii.org

    If this is already the latest version... well, suck it.

    Exit

    >
    "


    [​IMG]



    What IOS do I need to install to fix it?
    Or do I need to update to Wii firmware 4.3?
    (I'm still on v3.2e at the moment and every game works fine on my WiiKey chipped Wii)

    Do I need to use NUSD, sciifii or something or can I fix it by installing the needed (unpatched) IOS?

    Help, please
     
    1 person likes this.


  2. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    install an unmodified IOS58....
     
  3. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    I've got several IOS58 right here but I don't know if they are modified. I've also heard some people say Wad-Manager modifies the IOS-Wads when installing.

    How/where can I get a 100% unmodified IOS58?
     
  4. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    get it from Modmii....

    wad manager doesn't modify anything while installing....

    if that alone doesn't do the trick, do the same with IOS61....
     
  5. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    Didn't work [​IMG]


    I've installed it...

    [​IMG]
    (I've used IOS249 to run Wad-Manager, as always)


    but I still get the message...

    [​IMG]



    Do I need to un-install my old IOS58 first or do I need to use an other IOS to run Wad-Manager?

    help, please (I feel like an idiot after taking a break from the Wii for over half a year [​IMG] ... [​IMG] )
     
  6. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    did you try the same with IOS61 as well (i added that after you left to get 58 i imagine)?

    did you at any point have cIOSCORP installed on the system?

    never uninstall IOSes, just overwrite....
     
  7. Yuan

    Member Yuan GBAtemp Maniac

    Joined:
    Oct 1, 2007
    Messages:
    1,271
    Country:
    Brazil
  8. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    Ok, so

    after installing IOS61...

    [​IMG]

    there is still no luck [​IMG]



    Here is my current HBC status, if you might need to know

    [​IMG]




    and here is my sysCheck2.0.1 result:



    sysCheck v2.0.1 by Double_A
    ...runs on IOS36 (rev 3351).

    Region: PAL
    System Menu 3.2E (v290)
    Hollywood v0x11
    Console ID: 67552162
    Boot2 v2

    Found 556 titles.
    Found 34 IOS on this console. 0 of them are stub.

    IOS4 (rev 3): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS9 (rev 516): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS11 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS12 (rev 6): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS13 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS14 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS15 (rev 260): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 512): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS20 (rev 12): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS21 (rev 517): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS22 (rev 772): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS28 (rev 1288): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS30 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS31 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS33 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS34 (rev 3348): No Patches
    IOS35 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS36 (rev 3351): No Patches
    IOS37 (rev 3869): No Patches
    IOS38 (rev 3867): No Patches
    IOS51 (rev 4633): Trucha Bug
    IOS53 (rev 5149): Trucha Bug
    IOS55 (rev 4633): No Patches
    IOS56 (rev 5405): No Patches
    IOS57 (rev 5661): No Patches
    IOS58 (rev 6176): No Patches
    IOS60 (rev 6174): No Patches
    IOS61 (rev 5662): No Patches
    IOS202 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS222 (rev 4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223 (rev 4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS249 (rev 19): Trucha Bug, NAND Access, USB 2.0
    IOS250 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 3088): Trucha Bug
    BC v2
    MIOS v5

    Report generated on 2010/11/06.
     
  9. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    puzzling indeed...i'm at a loss....

    just curious, are you using the auto-update feature when you go into the HBC? i ask because there was an issue with a HBC installer awhile back (i don't remember the details).... but if you are attempting to auto-update from within HBC, this cannot be the issue....

    i see you have some outdated IOSes in there....this may take some time, but you could try updating your IOSes...to do so, get the update 4.2 pack from http://gbatemp.net/index.php?showtopic=171901 and install those IOS wads....yo umight want to use Multi Mod Manager from the pack so you can do a batch install.... i don't know if it would help you situation, but it might.....
     
  10. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    Yes, I'm using the auto-update that pops up after 2 seconds after opening HBC but the error message is shown when trying to install not when downloading the data for HBC 1.08
     
  11. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    ...that short lived, buggy installer can't be the issue then....

    you do have what appear to be CORPed IOSes (but don't think they are as the versions are not maxed), but it could also be that they're outdated....using the source to update your IOSes that i cited in my last post will not only get you updated, CIOSCORP-free IOSes, it will also put you on SM4.2 which is good....may fix the problem...may not....

    hey Yuan, if you return, weigh in here; i'm curious to see what you think....
     
  12. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    Very weird indeed, I think/hope its the autoupdate, I've never had problems when installing it via the hackmii installer boot.elf from the sd card.

    if u want u can use use modmii's hackmii solutions feature to just reinstall your HBC (or just download the latest hackmii installer from here and save it to your sd card, then launch it from your current HBC then use that to update).

    or u can use the modmii wizard to rehack your wii entirely
     
  13. Yuan

    Member Yuan GBAtemp Maniac

    Joined:
    Oct 1, 2007
    Messages:
    1,271
    Country:
    Brazil
    It is really odd. But as HBC FAQ says cioscorp can mess with HBC installer. Just update to 4.2 using the guide brausm08 suggested or if you don't want to update use Dop-Mii / NUS Download to update these IOS:

    4,9,11,12,13,14,15,17,20,21,22,28,31,33 and 35 to unpatched versions. You may update all others below 200 too, just don't mess with IOS30 (your system menu IOS).
     
  14. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    @XFlak & Yuan
    Updating to v4.2 or 4.3 would be fine with me BUT what if something happens? If I do get a weird error and I'm stuck I might be screwed
    (wasn't there an error earlier this year because you needed to update to 4.0 first and then continue with 4.1 / 4.2 when updating from 3.2 / 3.3 / 3.4 ?)
     
  15. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    do you have bootmii@boot2 (from your prior install)? if so, for sure nothing can happen that you can't fix...even if you don't though, chances are slim slim slim....
     
  16. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    There was never such an error with ModMii. There have been small bugs, but nothing major, and no one has EVER reporting bricking using ModMii.

    U don't need to update to 4.2 or 4.3, u can update to 4.1 instead using ModMii. I used to support 3.2, but there's no point, it's very safe to update using ModMii, the only real risk is the risk of power failure, and even then, if u have bootmii @ boot2 installed, or a nand backup, u can easily recover, and modmii makes sure to tell u to do those steps before actually updating
     
  17. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    I've never done anything with any bootmii / boot2 stuff.
    Well, I'm gonna install all the ios'es Yuan said (4,9,11,12,13,14,15,17,20,21,22,28,31,33 and 35) and then I'll try again by using the HBC elf installer.


    @XFLak
    how do I get bootmii @ boot2 installed or do a nand backup?
    (If intstalling the current IOSes won't help me I'm gonna do this just to make sure I don't brick my Wii, then I'll use your NUSD/ModMii to update my Wii)
     
  18. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    download and extract modmii, then run the modmii wizard, and tell it your wii is a virgin, answer the rest of the questions truthfully, then follow your custom guide
     
  19. Raylene2K7
    OP

    Member Raylene2K7 GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    978
    Location:
    parts unknown
    Country:
    Jamaica
    Ok, I've put this on my sd-card..

    [​IMG]






    but I get stuck on the very first step [​IMG]
    "Run BannerBomb v1 by going to Settings, Data Management, Channels, SD Card and choosing yes to load boot.dol/elf"..leads to this

    [​IMG]

    .. and from now on I can't continue, pressing "A" or "B" doesn't work (I've tried the Wiimote and also my GC controller)







    I've tried an other sd-card and now I get this again..
    [​IMG]
    ..when starting "Run BannerBomb v1 by going to Settings, Data Management, Channels, SD Card and choosing yes to load boot.dol/elf"






    So what should I do now? Updating by using sciifii or some other tool or updating by using a new game with update 4.x on it?
    (All my games are brickblocked so I guess I need to find a game with 4.1 or 4.2 on it)
     
  20. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    u probably also have a boot.dol for firmware updater 4.1 on the sd card, and its loading that instead of the boot.elf. FYI, that firmware updater can brick u if ur not careful, so don't use it
     

Share This Page