Can't seem to get Boktai 1 to work properly on EZ Flash IV

Discussion in 'GBA - Flashing Hardware and Software' started by Jabodie, Aug 18, 2014.

  1. Jabodie
    OP

    Jabodie Advanced Member

    Newcomer
    56
    5
    Mar 22, 2009
    United States
    I've been playing the US version of Boktai on version 1.72 RESET with a patch that can be found here:

    http://gbaemu.dcemu.co.uk/boktai-solar-sensor-patch-kit-v2-0-0-479156.html

    Now I've been patching, unpatching, repatching using gbata.exe, but I can never seem to get the game to work properly. Either the game says the solar sensor is working, or I can't freely adjust the sun level using the (L+R) left/right button combination. I've tried unchecking the reset patch and applying the SRAM patch via the gbata.exe program rather than the EZ client as well.

    I'm not sure what I'm doing wrong here. The patching process is always the same (as far as I can tell), but I can't get the game to work properly.

    Any help would be appreciated.

    Edit: Also, I could use some help with Sonic Advance. For some reason, it used to save, but now suddenly refuses. I've tried different firmwares (1.72RESET, 1.68, 1.74, and 1.71) and loading it to the NOR, but none of them have solved the issue (originally played on the 1.71 firmware). The odd thing is that it used to save and still has my progress, but won't progress any further.