Can't run NDS games, or a way to get the OTP.bin with a9lh already installed?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Azmort, Jun 27, 2016.

  1. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    Well, I'm helping a friend to get his o3ds updated so I installed the a9lh and everything was good until I tried to load a NDS game (flash cart and original).

    Previously it was able to play NDS games, it was on 4.5 so it was using the mset exploit, I updated it to 9.2 and did the downgrade to 2.1 to install the a9lh, however it was an automated installer so I didn't get the OTP.bin
    then I installed his previous emuNAND onto sysNAND.

    I tried to use the luma cfw downloaded from it's original github but it doesn't boot, neither saltfw does, I can only run the bin on that pack, I updated it with star updater and it also worked, I can also boot Hourglass9.
    Gateway bin also doesn't work

    Also tried to restore the original sysNAND (the one on 4.5) and still no NDS games.
    So I was wondering if I get the OTP to install another a9lh in order to use the files I got on my own 3ds that works perfectly, maybe that's the solution, however since a9lh is already installed, I can't boot sysNAND on 2.1, so what can I do? Thanks in advance.
     
    Last edited by Azmort, Jun 27, 2016
  2. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    1-remove the link ASAP or mods will happen
    2-https://github.com/Plailect/Guide/wiki
     
    Last edited by Davidosky99, Jun 27, 2016
  3. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    I have read that guide but it doesn't have the answers for my question :/
     
  4. Seriel

    Seriel Worshipper of Skiddos

    Member
    2,746
    5,050
    Aug 18, 2015
    United Kingdom
    UK
    (you might wanna remove the link from the quoted text in your post too)
     
  5. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    yea removed :P
     
    Seriel likes this.
  6. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    Your quote has the link in it :creep:

    Nope, he's using luma. Errr.... sounds like something got corrupted along the way.
     
    Last edited by ishygdaft, Jun 27, 2016
  7. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    removed the link don't kill me please :O
     
    MajinCubyan and Seriel like this.
  8. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    I love you :wub:
     
    Davidosky99 likes this.
  9. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    Oh, I forget to mention that I tried installing the TWL_FIRM and that gave me the error screen where it asks you to hold the power button, before it it just get stuck ona black screen.
    And I'm using Luma, everything else works.
     
  10. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    Luma already has the TWL patched firm. I would look into removing what's left over from mSET.
     
  11. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    Already done.
     
  12. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    This might sound silly but.. are you using the Dev fork of Luma?
    Another odd idea, try a gba game and see if that loads.
    DS loading might be broke or you might not be able to switch between firms without erroring out.

    Just for fun, try some DSiware too.
     
    Last edited by ishygdaft, Jun 27, 2016
  13. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    Nope
     
  14. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    GBA and DSi Ware works o.o
     
  15. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    Welp, with DSi ware working, I offically have no idea what's wrong. You say retail carts don't work ether? Odd.
     
    Last edited by ishygdaft, Jun 27, 2016
  16. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    Exactly they don't work at all :/
     
  17. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    I don't wanna give up but frankly I'm stumped.
     
  18. Azmort
    OP

    Azmort GBAtemp Regular

    Member
    157
    11
    Sep 25, 2015
    Mexico
    Well, thank you, my friend just came and he's taking his 3ds in this state, I'll just wait to find a way to get the otp on a device with a9lh already installed or to uninstall it, because I think the problem is the arm9loaderhax I'm forced to use.
     
  19. uribemaster

    uribemaster GBAtemp Fan

    Member
    305
    83
    Feb 9, 2010
    United States
    Well it could be that your cartridge slot has gone faulty. Does it read retail carts fine?
     
  20. ishygdaft

    ishygdaft A mystery wrapped in an enigma

    Member
    295
    78
    Jun 20, 2016
    United States
    See I was thinking the same thing, but he said it worked before install a9lh so I don't think that's it.
    Something along the way got corrupted in firmware and I unfortunately don't know what.