1. apatinoc4

    OP apatinoc4 Newbie
    Newcomer

    Joined:
    Jul 3, 2020
    Messages:
    7
    Country:
    Colombia
    Hello! I usually browse in this forum for troubleshooting and it usually works until now, things have gotten so bad I had to create an account.

    I'll try to be as specific as possible. my switch (firmware 8.1) had atmosphere custom firmware with hekate 5.2.1 playload, I tried to updrade to firmware 9.2 trough ChoiDujourNX and instead of selecting 9.2(exfat) as I was supposed to I picked 9.2 alone, this corrupted everything and found that the correct fix was to manually downgrade and try upgrading again.

    For downgrading manually I followed step by step what this guide said trying to downgrade to firmware 5.1.0:

    https://switch.homebrew.guide/usingcfw/manualchoiupgrade.html#step-0-before-starting

    I followed every step including backing up my NAND, and the only step where I seemed to find a difference in the tutorial was when transfering boot1 into my switch the size didnt say ''524.29'' but ''524.2'' except from that every step had the expected result until ''Step 13: Launching the First Time After Downgrading'' where the launching didnt work it got stuck in the ATLAX NX logo, after that tried ''Step 14: First Launch Failed'' and didnt work, had the same output , finally tried doing the entire process again and didnt work.

    Any pointers on what I could do to fix this? Thanks for your time!

    Update: I got this error message when I tried to boot emunand after doing the downgrade ''pkg2 decryption failed''

    Then tried restoring my nand to the state prior to the downgrade and get this error when trying to boot emunand '' emummc is forced but not enabled'' , after googling some more people say that I have to get into sysnand and create an emmummc but when I try to launch sysnand I get '' A fatal error occurred when running Atmosphere''

    Im kinda stuck. Any pointers on what I could do would be much appreciated

    Thanks!
     
    Last edited by apatinoc4, Jul 19, 2020
  2. pioneerpeter

    pioneerpeter Newbie
    Newcomer

    Joined:
    Jul 17, 2020
    Messages:
    7
    Country:
    United States
    There is a new nand rebulding guide. Just try it !
     
  3. chippy

    chippy GBAtemp Fan
    Member

    Joined:
    Dec 21, 2017
    Messages:
    319
    Country:
    Australia
    Got a backup before you tried to upgrade?
    Why not restore the band backup you made before the downgrade. Get an sd card in fat32 format. Put the latest 10.# on it and update to 1p with exfat support
    Dont see why you had to downgrade in the first place
     
  4. apatinoc4

    OP apatinoc4 Newbie
    Newcomer

    Joined:
    Jul 3, 2020
    Messages:
    7
    Country:
    Colombia
    Problem is I didnt back up NAND before doing the upgrade, did the back up in a weird point after the upgrade but before the downgrade
     
  5. chippy

    chippy GBAtemp Fan
    Member

    Joined:
    Dec 21, 2017
    Messages:
    319
    Country:
    Australia
    Well the backup you have the system would work just not read the sd card?
    Then just restore it, get a new sd or format your current to fat32. Load up your cfw and upgrade kike you do to 10.# with exfat
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - downgrade, upgrade, hekate