Cant play Red Steel 2 and Wii Sports Resort

Discussion in 'Wii - Hacking' started by The Composer, Feb 6, 2011.

Feb 6, 2011
  1. The Composer
    OP

    Member The Composer GBAtemp Regular

    Joined:
    Sep 13, 2009
    Messages:
    289
    Location:
    Chile
    Country:
    Chile
    I just modded my wii (black) with the modmii guide and everything went fine. After that I tried to play my backups from an external HDD with CFG.

    I can play most of my backups fine, but I have problems with those 2 games. I actually dont want to use the disc games because I want to keep the drive intact.

    Any help?
     
  2. awssk8er

    Member awssk8er GBAtemp Advanced Maniac

    Joined:
    Jun 26, 2007
    Messages:
    1,605
    Location:
    New Jersey
    Country:
    United States
    It's because they use Wii Motion Plus, so you have to do something different.

    I think on your loader if you just turn Alt. Dol on then it should work.

    I had the same problem a while ago, but don't exactly remember how to fix it.

    Since it is a black Wii, I'm assuming it is 4.2 or 4.3, so it should work. If I am not mistaken, one firmware update added something for Wii Motion Plus, so I'm pretty sure they wouldn't work on anything lower than 4.0.
     
  3. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    A bit more info would be nice.

    First the obvious question: you DO have a wiimote+ thingy (or a wiimote with the motionplus inside), right? Those games won't work without it.


    Second...wii sports resort has this sort of antipiracy thing. First, you have to play the game WITH the alternative dol on the disc. This just to watch the introduction movie or something. After that, it will create a savegame. Then quit the game, and reconfigure it to play it without that alternative dol. That should solve it.

    I dunno about red steel 2. Chances are it has the exact same problem (and solution), but I don't know for sure (it has an alternative dol, though).
     
  4. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,895
    Location:
    St. Louis, Missouri
    Country:
    United States
    This is incorrect. Just make sure you are using the latest cIOS. I recommend 249dx56, which can downloaded with ModMii. No alt dol should be required.
     
  5. Fat D

    Member Fat D GBAtemp Maniac

    Joined:
    Nov 18, 2006
    Messages:
    1,117
    Country:
    Germany
    Actually, 4.0 broke something with Wii Motionplus, which 4.1 fixed (the "video has already been played" part, which is probably what is causing your trouble, was reset whenever you entered the SD menu). WM+ by itself works fine on EVERY sysmenu version.

    But I really think that the reason they do not work is that you did not watch tht stupid WM+ video yet. Launch WSR via alt dol once and the situation should be fixed. Then disable the alt dol again.
     
  6. awssk8er

    Member awssk8er GBAtemp Advanced Maniac

    Joined:
    Jun 26, 2007
    Messages:
    1,605
    Location:
    New Jersey
    Country:
    United States
    My bad. It was a while ago, and that's how I thought I got it to work.

    I remember everyone was having trouble with Wii Sports Resort when it was first released, and I remember someone saying you could do that. I think that was only for disc backups though.
     
  7. The Composer
    OP

    Member The Composer GBAtemp Regular

    Joined:
    Sep 13, 2009
    Messages:
    289
    Location:
    Chile
    Country:
    Chile
    Going to try this. Btw I have a Wii Remote Plus (Wiimote+Wiimotion Plus).

    EDIT: Tried and didnt work. I downloaded the files with ModMii and installed them as wads. Tried 249dx 56 and 57.
     
  8. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands
    The alt .dol still applies.

    There is a .dol for the instructial movies and one for the actual game.
    Pick the one for the game if you have trouble.
     
  9. The Composer
    OP

    Member The Composer GBAtemp Regular

    Joined:
    Sep 13, 2009
    Messages:
    289
    Location:
    Chile
    Country:
    Chile
    Tried this instead. It worked!
     
  10. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    I think Lacius is referring to the "It's because they use Wii Motion Plus" part, as that is just coincidental. There are quite a few games without the motion+ that have alt dols, and not all motion+ games have issues.

    The latest cIOS, however, is indeed not the issue. Having the latest cIOS'es is nice and all, but it isn't a silver bullet. You cannot just solve any issue by installing the latest cIOS.
     
  11. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,895
    Location:
    St. Louis, Missouri
    Country:
    United States
    Oops, that's right. My experiences with Wii Sports Resort started with a backup disc, so I never had to use the alt dol method the first time. My mistake.
     
  12. The Composer
    OP

    Member The Composer GBAtemp Regular

    Joined:
    Sep 13, 2009
    Messages:
    289
    Location:
    Chile
    Country:
    Chile
    Thanks to everyone for helping me solve this problem.

    Now we are all certain that alt dol from disc is the solution.
     
  13. tueidj

    Member tueidj I R Expert

    Joined:
    Jan 8, 2009
    Messages:
    2,569
    Country:
    If anyone cares: the instructional video actually writes a new setting in SYSCONF after you've finished watching it for the first time, not a savegame. It's done this way so that any WM+ game can check to see if the video has been played.
     

Share This Page