Can't link Ezflash to a Original Cartridge - Zelda Four Swords

Discussion in 'EZ-Flash' started by AlexandreBarroso, Oct 4, 2014.

  1. AlexandreBarroso
    OP

    AlexandreBarroso Newbie

    Newcomer
    3
    0
    Oct 4, 2014
    Brazil
    Hello everyone,
    it's my first time i ever post on this forum, so please forgive me if i have misplaced this topic.

    The question is, how can i make my ez flash game Zelda Link to the Past/Zelda Four Swords link in to a original cartridge (also a Zelda Link to the Past/Zelda four Swords?

    I have the Zelda Link to the Past/Zelda Four Swords original Cartridge
    Ez flash IV that works just fine
    Original GBA link cable
    and 2 Gameboy Advance SP

    - - -

    I have already tried to patch a .IPS file like indicated on this forum (i have tried to register but it appears to be no more in funcion) by Fast6191, also a member here, as far as i know it:http://ezflash.sosuke.com/viewtopic.php?f=12&t=17714.

    I tried with Lunar or GBA Tool Advance like a hundred times, but it dosen't work.

    I googled it, but i could not find any other .IPS file that i could try to pach in on the rom for the EZ flash.

    - - -

    Again, sorry if i misplaced this topic, and also sorry my poor english, it is really the first time i enter to a forum to look for a help like this. Every other problem i have found on my Ez flash i was able to find a solucion just looking on the Google. But it has been almost a month that i am trying to make this game work and i have no success. Thank you.
     
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,514
    9,330
    Nov 21, 2005
    I assume this is the US version of the game you are patching. It will want to be the stock version so if there is a translation then you will have to skip it.

    Anyway what did you do to patch the game? You should be able to patch the orginal ROM, copy that newly patched file over (no EZ4client just plain old windows explorer) and then make sure it has a save (if you have already used EZ4client on one of them then you should have a save file you can use, otherwise I just copy one of suitable size).

    I did not test the four swords patch between originals and EZ4 but it was made using the same method as the others there, many of which do work/have been used. It could be that the patch does not work for this game (I would not be surprised either way) but we can cross that bridge as and when we need to.
     
  3. AlexandreBarroso
    OP

    AlexandreBarroso Newbie

    Newcomer
    3
    0
    Oct 4, 2014
    Brazil
    Hi Fast, it is really a pleasure to meet you.
    I have looked in a lot of your posts lately searching for help.
    And i guess i alredy know why they call you "Fast", lol.

    I do not use any translations when i play games. It is kind a way that i can train my english.
    Actually i have forgot to say, my original cartrigde it´s my only European game that i own. The game is in spanish, and i really hate it, i would rather if it was in english. Like you said i use US version of the game to patch. I tried lots of European roms, but when i download then, they are in the .SMC or .SFC format and i can't make it work, even on the VisualBoy emulator they wont work.

    When i patch i use the GBA Tool Advance and the .IPS you made available. I change the name of the .IPS file for the same as the rom. After patching i used, like you said again, the EZ client to transfer the rom.

    I just tested simple copping and pasting on the windows folder. But again, the game dosen't work.

    - - - - -

    Also, i would like to make myself available if anyone need linking testing for any games. I have 3 GBAs and a GBA link cable. I would be glad to help. Thank you.
     
  4. Lumstar

    Lumstar Princess

    Member
    3,635
    89
    Mar 6, 2006
    United States
    Darling
    .SMC or .SFC is a SNES game. That won't work for GBA.

    Not all games support multiplayer between the US and European versions. You may have to find a find a rom who matches your cartridge.
     
  5. AlexandreBarroso
    OP

    AlexandreBarroso Newbie

    Newcomer
    3
    0
    Oct 4, 2014
    Brazil
    IT WORKS!!
    Thank you guys!

    Like Lumstar said, i was downloading a SNES european game on the EZ FLASH.

    It was hard to find a GBA european game that worked. The european one i have found on Romhustler.com dosent works, it was repeatly saing that the game could not save.
    Later on i was capable to find one GBA Zelda link to the Past/ Four swords (E) in some not very know web site.

    On patch prosses i have not changed the .IPS file that Fast has made.

    The only side effect that happens is that the game became completely mute (the one in the EZ FLASH). But the original cartridge works just fine.

    Again, thanks a lot you guys. ;]]]
     
  6. Lumstar

    Lumstar Princess

    Member
    3,635
    89
    Mar 6, 2006
    United States
    Darling
  7. N7Kopper

    N7Kopper Proud lover of a three-inch girlfriend

    Member
    397
    140
    Aug 24, 2014
    I'd personally test the ROM in something like VBALink to see if it's a software problem - patching save type from EEPROM to SRAM, or even save location to different memory addresses prevents the Master/Slave relationship of GBA/GCN links, (you'd need to patch the Gamecube game to write to your patched save locations appropriately, except in specific cases like Mario Golf where Toadstool Tour doesn't override Advance Tour so much as talk with it, peer-to-peer style) but shouldn't effect the peer-to-peer nature of GBA/GBA ones.