Can't launch FBI through H&S on emuNAND

Discussion in '3DS - Flashcards & Custom Firmwares' started by ShadowStkr, Jul 21, 2016.

  1. ShadowStkr
    OP

    ShadowStkr Newbie

    Newcomer
    7
    0
    Jul 21, 2016
    Brazil
    I've been following Plailect's guide in order to enable A9HL and switch from rxTools to Luma3DS. I started at part 4 already since I had a GW Emunand, and although I had some problems dumping the Health&Safety App, I fixed it by dumping the CTRNAND partition, mounting it with OSFMount, then defragmenting it, saving it as .bin image and then restoring it to the system.

    However, even though my emuNAND is updated as requested in the guide (11.0.0-33), and even though I followed all the steps involving Universal Inject Generator and the Health and Safety Dump, and even though Decrypt9 says that FBI has been successfully injected into the Health and Safety App, when I try launching the app in emuNAND, it launches the original Health and Safety app instead of FBI. I've already redone this process in a lot of ways, such as restoring the emuNAND to an earlier backup and redoing the whole updating, defragmentation and injection process again, uninstalling the FBI cia I had installed before on emuNAND through BigBlueMenu and trying to dump and inject again, but nothing seems to work.

    I would greatly appreciate if anyone could help me with this problem. If this somehow helps, before I tried doing this entire thing, I had a 4.5 sysNAND which was downgraded through Gateway from 9.2, and was using the DS profile exploit to boot emuNAND through rxTools, although the emuNAND itself was still is the Gateway one.
     
    Last edited by ShadowStkr, Jul 21, 2016
  2. DavidRO99

    DavidRO99 Average Ryzen user.

    Member
    981
    285
    Jun 11, 2016
    Korea, North
    your back-door
    You can also try using DevMenu or BigBlueMenu
     
    ShadowStkr likes this.
  3. tatumanu

    tatumanu GBAtemp Fan

    Member
    468
    131
    Nov 1, 2004
    Portugal
    So your emunand was created after you downgraded from 9.2 to 4.5 through gateway?
     
  4. ShadowStkr
    OP

    ShadowStkr Newbie

    Newcomer
    7
    0
    Jul 21, 2016
    Brazil
    I'll try doing that and posting the results later then.

    Exactly, it was created through Gateway itself as well, although I switched to rxTools eventually and used that to boot it since then.
     
  5. DavidRO99

    DavidRO99 Average Ryzen user.

    Member
    981
    285
    Jun 11, 2016
    Korea, North
    your back-door
    Did it work?
     
  6. ShadowStkr
    OP

    ShadowStkr Newbie

    Newcomer
    7
    0
    Jul 21, 2016
    Brazil
    Tried injecting both and the problem persists.
     
  7. SimplyFedorable

    SimplyFedorable Evangelion Geek

    Member
    568
    231
    Apr 7, 2016
    United States
    melee hell
    get the .3ds format of fbi (in the relases zip) and also get the .cia of fbi. Put the .3ds version of fbi on your gateway, and the .cia on your sd card. Boot into gateway and launch fbi from the gateway select menu. Use that to install the .cia version of fbi, and assuming you are using the same emunand for your gateway and cfw, a new version of fbi should have installed. You can move the old one some where else, like a random folder. Hope I helped!
     
  8. ShadowStkr
    OP

    ShadowStkr Newbie

    Newcomer
    7
    0
    Jul 21, 2016
    Brazil
    Yeah, I solved the problem with this, although I needed to boot through Gateway and reinstall FBI and TinyFormat two more times due to the guide requiring me to format emuNAND twice. Anyway, thank you very much for the help. I'm going to try downgrading to 2.1.0 now.
     
  9. SimplyFedorable

    SimplyFedorable Evangelion Geek

    Member
    568
    231
    Apr 7, 2016
    United States
    melee hell
    awesome. Just follow the guide exactly