Can't install NSP after updating both AMS & switch firmware

katrinasofia

Member
OP
Newcomer
Joined
Nov 15, 2021
Messages
6
Trophies
0
Age
31
XP
9
Country
Spain
Hi!
I'm running version 13.0.0 and AMS 1.2.4|S. I just updated everything so I could play Skyward Sword and Metroid Dread but I can't even install older games, like Mario's Odissey.
A bunch of errors when I do it through Goldleaf 0.9 (2145-0001 (0x291) being the most common. With newer games another error comes up, saying that my version is outdated (wrong) or that I may need sigpatches (I've tried many but nothing works). I have also tried Daybreak to install games but nothing either.
I've read about sigpatches and fusee-primary not being a thing anymore. To be honest, I have basically no idea what I'm doing, just follow steps that someone taught me and instructions online.
If you could help me, that'd me grand! Thanks!

Edit: I use Hekate to boot the thing.
 

Dust2dust

Well-Known Member
Member
Joined
Jun 17, 2010
Messages
1,678
Trophies
1
XP
2,613
Country
Canada
I never used DeepSea, I always update manually. It's not that hard. First, you update Atmosphere, next you install the latest sigpatches, and finally you update the Switch firmware (13.1.0 is latest). Daybreak is used to update the firmware, not to install games. Firmwares can be obtained from Darthsternie. Sigpatches from https://github.com/ITotalJustice/patches/releases

If you're not sure what you're doing, you could check this guide > https://rentry.co/SwitchHackingIsEasy

Almost forgot to mention... You should drop Goldleaf and get yourself a good installer, like DBI > https://github.com/rashevskyv/dbi/releases
 
  • Like
Reactions: katrinasofia

katrinasofia

Member
OP
Newcomer
Joined
Nov 15, 2021
Messages
6
Trophies
0
Age
31
XP
9
Country
Spain

I updated manually as well and installed the sigpatches from the website you mentioned. The switch firmware though is already installed (13.0) so I can't do that step now. I'll drop Goldleaf, thanks for the advice! And thanks for the guide as well!

I'll try to do it again from the beginning, but with the Switch firmware updated to 13.0 already (should I downgrade?).
Regarding sigpatched, both contain the same stuff. I copy the folders on FUSEE or HEKATE and paste them on my SD (combining the files with what was there already after installing ATM). Does that make sense?

Thanks a million!
 

Dust2dust

Well-Known Member
Member
Joined
Jun 17, 2010
Messages
1,678
Trophies
1
XP
2,613
Country
Canada
The safest option (for me anyway) when I upgrade is to delete the old atmosphere folder and start from there. That takes care of any incompatibilities between old and new versions of Atmosphere files and Sigpatches. But yes, in theory, overwriting should work, I just never tried that way. The latest version of the firmware is 13.1.0, not 13.0, so it might be worth upgrading, while you're at it. As a rule of thumb, never downgrade... more trouble than it's worth. And when a new firmware comes out from Nintendo, wait until Atmosphere and sigpatches are updated too before upgrading. Usually, that takes just a couple of days.
 

katrinasofia

Member
OP
Newcomer
Joined
Nov 15, 2021
Messages
6
Trophies
0
Age
31
XP
9
Country
Spain
Still nothing. I really don't know what else to do.
Upgraded firmware, following a clean ATM instalation just in case, following your steps.

I was able to install Skyward Sword through DBI but I can't run it, tells me to open from the HOME menu (again) or something like that (black screen, white Nintendo font.) I'm going to try again tomorrow and take photos so I can show them here, if that's alright.
 
Last edited by katrinasofia,
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: But if my mom yelled at me, it was all over I would cry like a baby lol