Can't install HBC on a DarkCorp'ed wii

Discussion in 'Wii - Hacking' started by matanga, Jun 10, 2010.

Jun 10, 2010
  1. matanga
    OP

    Newcomer matanga Newbie

    Joined:
    Jun 10, 2010
    Messages:
    4
    Country:
    Argentina
    Hi guys,

    I've uninstalled HBC from my wii withous previously uninstalling DarkCorp.

    Now I wan't to reinstall HBC to run an USB Loader but I can't run HackMii because I receive "No vulnerable IOS found".

    I've found that I have to replace 2 IOS thru Bannerbomb to allow HackMii to run again, but I receive the following "exception (dsi) occurred" while trying to run anything from Bannerbomb.

    Any suggestions? Any way to install HBC, uninstall DarkCorp, replace IOS, perform a Nand restore, or do anything to get it resolved? Remember that, at this point, I can't run HackMii because of "No vulnerable IOS found" message.

    Thanks in advance.

    Matanga!
     
  2. kano

    Newcomer kano Advanced Member

    Joined:
    May 19, 2008
    Messages:
    71
    Country:
    Malta
    Hi, Im not a l33t haxor but I can give u some of my experience, first of all are you sure you trying to install the right HBC for your system ? there are 2 versions that are for system menu below 4.0 and above 4.1, if u still cant install try update your wii so you will replace any cios with official ios and then folow a guide to rehack your 4.2 wii, beware that you will loose any hacks on your wii doing this so be sure b4 u try. hope Iv been of any help
     
  3. transam81

    Member transam81 GBAtemp Regular

    Joined:
    Oct 4, 2009
    Messages:
    284
    Location:
    Central California
    Country:
    United States
    here are some clips from the darkcorp thread (lazy).

    All IOS have their version number maxed out to prevent being
    overwritten by an Official Nintendo Wii System Update (although we do
    not recommend performing a Wii System Update anyway).

    How to uninstall it:
    First of all, DON'T DELETE ANY IOS!!! YOU WILL (most likely) KILL
    YOUR WII IF YOU DO!!! Rather, the IOS must be OVERWRITTEN with
    official, unmodified IOS. Just run the “DARKCORP v1.0 Full Installer”
    or the “DARKCORP v1.0 Lite Installer” and select:
    Uninstall DARKCORP (YOUR IOS WILL LOSE ALL PATCHES!)
    This will replace your cIOS with unmodified IOS, meaning no trucha,
    no ES_Identify etc. If you had any patches applied to IOS prior to
    installing DARKCORP v1.0, you have to reapply these patches after
    uninstalling.

    just in case here is the rest of it.

    http://gbatemp.net/t218371-darkcorp-v1-0-release
     
  4. matanga
    OP

    Newcomer matanga Newbie

    Joined:
    Jun 10, 2010
    Messages:
    4
    Country:
    Argentina
    I can't install HBC since Hackmii shows "No vulnerable IOS found", nor I can reinstall or uninstall Darkcorp since HBC is not installed in my Wii anymore...

    Forgot to mention that I have 4.2U installed.

    Any other suggestions?
     
  5. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    Download NUSAD from my signature, run the program, from the main menu, type "H" for Hackmii solutions, follow the prompts, and it will generate a guide for you to follow.

    It doesn't get any easier than this.
     
  6. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    unless you go to his house and do it yourself.
     
  7. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    lol, true very true... if the OP wants to pay for my flight to Argentina, I'll fix his problem personally for free! [​IMG] lol
     
  8. matanga
    OP

    Newcomer matanga Newbie

    Joined:
    Jun 10, 2010
    Messages:
    4
    Country:
    Argentina
    LOL, It will be cheaper to send me a new Wii console... I vote for my option!!


    I'll try your suggestion and will let you know.

    Thanks a lot
     
  9. WitoRIT92

    Member WitoRIT92 GBAtemp Fan

    Joined:
    Jan 24, 2009
    Messages:
    430
    Country:
    United States
  10. addy2k

    Newcomer addy2k Newbie

    Joined:
    Oct 8, 2009
    Messages:
    6
    Country:
    Germany
    In my opinion the best way would be running the Darkcorp Installer via Bannerbomb and use that to get rid of Darkcorp. If this fails, I would try using DOP-IOS (run via Bannerbomb) to get back to unmodified IOSes 36 and 61. After this is done, HBC should install just fine.
     
  11. Riley

    Member Riley GBAtemp Maniac

    Joined:
    Mar 9, 2009
    Messages:
    1,123
    Location:
    BC Canada
    Country:
    Canada
    Just IOS36. Theres no reason to re-install IOS61 as it wasn't modified in the first place.
     
  12. damysteryman

    Member damysteryman I am too busy IRL these days...

    Joined:
    Oct 4, 2007
    Messages:
    1,182
    Country:
    Antarctica
    @Riley
    ...unless he installed cIOSCORP v3.1 and never uninstalled it (it was removed in v3.2 tough).

    @matanga
    You had cIOSCORP v3.5 or older installed at some time, right?

    Try the cIOSCORP v3.5 Uninstaller. (sorry, I cannot provide a direct link due to teh forum rulez...)

    Run it via bannerbomb (copy the "sd:\apps\cIOSCORP_v3.5_Uninstaller\boot.dol" to sd:\boot.dol" in order for it to run from bannerbomb).

    Make sure you have cIOS249 installed, as it is needed by the app.

    And then you can reinstall DARKCORP if you want. (after performing the uninstall method mentioned above, DARKCORP will then be compatible with hackmii installer)


    ...and thanks for bringing this issue up. I've now seen that the DARKCORP v1.0 Uninstaller will only uninstall what it modifies, but it doesn't uninstall any pre-v3.6 remnants...

    ...I'll have to get that fixed.
     
  13. matanga
    OP

    Newcomer matanga Newbie

    Joined:
    Jun 10, 2010
    Messages:
    4
    Country:
    Argentina
    The problem here is that I receive the following "exception (dsi) occurred" while trying to run anything from Bannerbomb.

    Is there any other way to run DarkCorp uninstaller than by ussing Bannerbomb or HBC?
     
  14. muck chucker

    Member muck chucker GBAtemp Regular

    Joined:
    Sep 21, 2008
    Messages:
    161
    Country:
    United States
    Try a diffrent bannerbomb from the hackmii website. Also can you give a run down of eveythimg you do from puttin the files on the sd to what you do on the wii.
     
  15. calthephenom

    Member calthephenom GBAtemp Regular

    Joined:
    Sep 28, 2009
    Messages:
    123
    Country:
    United States
    also, while we're on a DarkCorp and HBC thread, how come my HBC didn't go upside down after i DarkCorp'd my wii?
     
  16. Riley

    Member Riley GBAtemp Maniac

    Joined:
    Mar 9, 2009
    Messages:
    1,123
    Location:
    BC Canada
    Country:
    Canada
    Darkcorp DOESN'T install a cIOS61 which is the IOS HBC uses. On the older cioscorps they did have it so it made HBC go upside down. HBC needs the official IOS61 to run on.
     
  17. thesund0g

    Member thesund0g GBAtemp Fan

    Joined:
    Aug 6, 2009
    Messages:
    452
    Location:
    The Boonies
    Country:
    Antarctica
    It depends on which IOS the HackMii installer decided to use. Mine was on 36, then I decided to patch it, so I had to uninstall HBC, patch 36, reinstall and it chose 61 that time as it was left unpatched.

     

Share This Page