Can't install game on USB Loader GX

Discussion in 'Wii - Backup Loaders' started by inadog, Aug 16, 2011.

Aug 16, 2011
  1. inadog
    OP

    Newcomer inadog Newbie

    Joined:
    Aug 13, 2011
    Messages:
    7
    Country:
    United States
    I had a hard drive that I partitioned to some WBFS and the rest NTFS. It worked great for a while. Then I realized some of the benefits of FAT32 so I deleted my WBFS partition and replaced it with a FAT32 one. Now when I use Wii Backup Manager to load my old .wbfs files into the FAT partition's wbfs folder it always makes another folder within it to store just one file. GX doesn't recognize the game when it does this so is there any way to turn this off?

    But my big problem is that when I try to insert one of my games and install it with GX it gives a black code dump screen headed with (DSI) Exception. I used to be able to rip games all the time with my WBFS partition and use Wii Backup Manager without having to worry about the extra folder...can you help me fix these two problems. (The one about installing games and the error is more important as I can manually take the file out of the folder if needed.)

    BTW I tried using CFG Loader to install and it worked but I want to use GX...
     
  2. justjack

    Member justjack GBAtemp Regular

    Joined:
    Feb 10, 2009
    Messages:
    129
    Country:
    Chile
    Go to the settings of Wii Backup Manager and in the fat32/ntfs tab, change the folder layout to make it store all the games on a single folder.

    I don't know about your other problem, haven't used gx in years. Do you have the latest version of the loader and cios?
     
  3. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,400
    Location:
    Engine room, learning
    Country:
    France
    the file being installed in a sub-folder is an option of WiiBackupManager.
    Go the the options of that program, on the FAT32/NTFS tab you should have a way to indicate if you want subfolder or not, and if yes, which name to use.


    About USBloader, do you have the version 2.2 ?
    also, to use FAT32, you need either Hermes cIOS or cIOSx >17 (recommended "rev21 d2x v6 [base 56]"). I suppose it's already the case, so you should be fine.
    Note: You can see which version and IOS you are currently using in the Credit page of USBLoaderGX.

    Edit : Ninja'ed by Spongebob [​IMG]
     
  4. inadog
    OP

    Newcomer inadog Newbie

    Joined:
    Aug 13, 2011
    Messages:
    7
    Country:
    United States
    Thanks for the responses...yup I have the Hermes cios and I can play the games and now thanks to your tips, I can load it from Wii Back up Manager.

    That leaves my main problem. Why is there a DSI Exception every time I try to install a game from a disc? And yes I believe I have GX 2.2
     
  5. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,400
    Location:
    Engine room, learning
    Country:
    France
    DSI and code dump are bugs in the program's code.
    It's hard to tell you what's wrong without more specific informations.


    does it code dump when you launch the menu?
    click the "+"
    insert a disc ?
    after some progress?
    All games, or specific ones?
    etc.
    Please give more details.

    You can also try to use a different cIOS (go to the main settings and set IOS249 or 250 instead of 222 or 223, and reboot the Loader).
     
  6. inadog
    OP

    Newcomer inadog Newbie

    Joined:
    Aug 13, 2011
    Messages:
    7
    Country:
    United States
    Thanks for all you input. I tried reinstalling GX and it seems to have worked but one of the games is missing its title and I can't edit it...why?
     
  7. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,400
    Location:
    Engine room, learning
    Country:
    France
    maybe you need the new Wiitdb file format.
    Go to settings > page 3 > update > Wiitdb
    then check that setting > GUI > use Wiitdb is enabled.

    Could also be because it's using unicodes or japanese title and you currently have a theme with an incompatible font?
    Disable themes if it's the case (to try).
     
  8. inadog
    OP

    Newcomer inadog Newbie

    Joined:
    Aug 13, 2011
    Messages:
    7
    Country:
    United States
    Actually I just had to change the name of th folder containing the game lol.
    Thanks thread solved.
     

Share This Page