Can't install CIAs after moving emuNAND to new SD card

Discussion in '3DS - Flashcards & Custom Firmwares' started by Tomato Hentai, Apr 5, 2016.

  1. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Just the other day, I moved my emuNAND to another SD card, one which was slightly larger than the one I was using before. (original was ~13 GB, current is ~14 GB) Ever since I switched, I've been unable to install CIAs with both DevMenu and FBI.
    This was the error FBI gave me:
    Code:
    Install failed!
    Could not finalize installation.
    Raw error: 0xd8a08012
    Module: AM (0x20)
    Level: Permanent (0x1b)
    Summary: Invalid state (0x5)
    Description: Unknown description (0x12)
    
    Press Start to continue.
    I don't know what the issue would be, because my sister is using the exact same SD card as me, and she has no issues, but hers was set up on that SD card and not moved from another to the one she's using now, so I'm guessing it maybe has to do with switching SD cards? If it helps, I'm using a Verbatim class 4 SDHC, and the last one I was using was actually a micro SDHC in a mirco SD to SD adapter. I can't remember the brand right now, but I can check later. I'm also running rxTools.
     
    Last edited by Tomato Hentai, Apr 5, 2016


  2. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,511
    1,975
    Aug 19, 2015
    United Kingdom
    Clydebank
    Are you using the cia of fbi or the 3dsx?
     
  3. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    CIA. I was never able to do anything with the 3DSX, even when I was having no issues with emuNAND.
     
  4. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,511
    1,975
    Aug 19, 2015
    United Kingdom
    Clydebank
    Yep me to that's why I asked sorry I can't help with the problem with the cia
     
    Tomato Hentai likes this.
  5. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,026
    4,963
    Jan 26, 2016
    United States
    That Nightly Siteā„¢
    It would really help us if you gave us the error message.
     
    Tomato Hentai likes this.
  6. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Was gonna do that as soon as I got home. (And I actually just got home, so I'll go and try to install again and post the error FBI spits out)
     
    astronautlevel likes this.
  7. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    I've added the error to the OP.
     
  8. Cat Prince

    Cat Prince Member

    Newcomer
    14
    0
    Apr 5, 2015
    United States
    How did you copy over your emunand? Did you inject the file or did you clone an SD card?

    Also is this New3DS or Old3DS?
    And is the other working SD on a New or Old as well?

    It's a bit of a stretch but it might have to do with incompatibilities between your old emuNAND and maybe the new one you have may be a RedNAND. That's all I can think of for now
     
    Last edited by Cat Prince, Apr 5, 2016
  9. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    I injected the NAND.bin backup from the old SD card and before that I formatted emuNAND using the Gateway launcher, which is also what I did when I set up my emuNAND the first time. I'm using an O3DS, and the other SD is also working on an O3DS.
     
  10. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,031
    371
    Aug 15, 2015
    United States
    I recommend making sure that your dbs folder at Nintendo 3DS/<id0>/<id1>/dbs/ has a title.db and a import.db, if they dont, create empty ones and the go to System Settings -> Data Management -> Nintendo 3DS -> Software on your 3DS and let it repair the database files.

    If these files do exist, Delete them and make new ones anyways. (Right click > new > .txt > rename it title.db and then do the same for import.db
     
    Last edited by Biff627, Apr 6, 2016
    Quantumcat likes this.
  11. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    They exist. That was one of the things I checked the day I started having the issue.
     
  12. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,031
    371
    Aug 15, 2015
    United States
    Repair them then. I added onto my post above.
     
    Tomato Hentai likes this.
  13. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    It still gives me the error.
     
  14. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,031
    371
    Aug 15, 2015
    United States
    Hmm, I have a few ideas on how this might be fixed. You could try injecting FBI.cia into the health and safety app and see if you can install cias from that. If not I would try this > You said that you used gateway to format your emunand again? Did you by any chance use emunand9 to restore your nand.bin? I recommend trying to restore this same nand with decrypt9 and see it that resolves the problem.

    I hope this helps! I had this problem after moving sd cards and the db files helped after going into the system settings and having it repair the db files. Im not sure why that didnt help but I hope that injecting it and installing the fbi.cia works/fixes the problem.
    I wish I could continue to help but I need to sleep..
     
    Tomato Hentai likes this.
  15. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    I already have injected FBI, and I both extracted and injected my NAND.bin with emuNAND tool, so I'll go and try what you suggested in a little while in a little while, as well as injecting with emunand9.
     
  16. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,031
    371
    Aug 15, 2015
    United States
    also before i go, i would suggest testing out aureinand to see if it is just rxtools acting weird on you. I know a few people do have problems with rxtools in certain occasions so that might help your case
     
    astronautlevel and Tomato Hentai like this.
  17. pustal

    pustal Koalafied member.

    Member
    346
    141
    Jul 19, 2011
    Portugal
    The Matrix
    I had something similar happening to me recently, after formatting EmuNAND twice.

    Try this: on you SD card, rename "Nintendo 3DS" folder to "_Nintendo 3DS" or something different. Your 3DS wont recognize some applications stored in there but try to install a CIA like that and see if it still gives you error. If it installs, you can try to copy again the "Nintendo 3DS" folder from your old SD card and if that doesn't work, install back everything that was stored in there.

    Also check if your SD card safe right lock is slided down instead of up on the side of your SD card.
     
    Last edited by pustal, Apr 6, 2016
  18. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Already tried it.
    If my SD card was write-protected, sysNAND would notify me when I boot into it, and I likely would've noticed by now if it didn't.
     
  19. pustal

    pustal Koalafied member.

    Member
    346
    141
    Jul 19, 2011
    Portugal
    The Matrix
    Ok. Tell me, if you enter eShop or Data Management in System Settings, does it display any error message?
     
  20. Tomato Hentai
    OP

    Tomato Hentai baja boner blast

    Member
    3,725
    6,009
    Oct 30, 2014
    Canada
    actually north korea. please send help
    I can't enter the eShop at all because of my NNID. As for the System Settings, IIRC I only got an error when I went to regenerate the DBs.