Can't Go Online in emuNAND 10.5.0-30U

Discussion in '3DS - Flashcards & Custom Firmwares' started by JohnTravolski, Mar 25, 2016.

  1. JohnTravolski
    OP

    JohnTravolski GBAtemp Regular

    Member
    124
    7
    Jul 9, 2015
    United States
    Whenever I try to go online now in emuNAND, it says that "an update is required to use this service." So here are the specs:

    • I'm on the Old 3DS XL
    • sysNAND version 4.2.0-9U
    • emuNAND version 10.5.0-30U
    • I use RXtools version 2.6 and the DS Profile exploit to get into emuNAND
    • I regularly use FBI Installer and SaveDataFiler inside emuNAND

    The last time this happened to me, I was able to go to the system settings and safely update emuNAND to the latest version at the time (10.5.0-30U) with no issues; then I could go online and everything inside emuNAND still worked. Now that the latest version has been released and I can't go online in 10.5 anymore, is there any risk of updating only my emuNAND through the system settings to the latest version?
     
  2. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    10.7.0-32U updated the friends system-module again so this might be the cause. yes, you can safely update emunand through System Settings.
     
    raystriker likes this.
  3. spinal_cord

    spinal_cord Knows his stuff

    Member
    2,978
    570
    Jul 21, 2007
    somewhere
    I update my emunand all of the time.
     
  4. JohnTravolski
    OP

    JohnTravolski GBAtemp Regular

    Member
    124
    7
    Jul 9, 2015
    United States
    Okay, this is good to hear. I mean, if I just regularly update my emuNAND through system settings all of the time, since I'm on the Old 3DS, what's the worst that Nintendo could do to my system?
     
  5. ultimatetemper

    ultimatetemper GBAtemp Fan

    Member
    302
    52
    Dec 30, 2010
    I can go online on Bravely Second perfectly with 10.6.
    Maybe is a 10.5 issue?
     
  6. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    nothing. don't worry about it. if they could do something they probably would have done it ages ago.
     
  7. Margen67

    Margen67 Dirty entited pirate

    Banned
    1,100
    4,582
    Nov 3, 2014
    United States
    Absolutely nothing.
    Although, menuhax is garbage so you should install A9LH :)
    At the very least update to a new version of Rxtools
     
  8. JohnTravolski
    OP

    JohnTravolski GBAtemp Regular

    Member
    124
    7
    Jul 9, 2015
    United States
    Sorry, I'm still using the method to get into emuNAND that I used back in June 2015, but I'm so bad at doing this stuff that I think that I'll stick with it because it works. Thanks for all of the advice, guys!
     
  9. astronautlevel

    astronautlevel But he's a guy

    Member
    3,909
    4,577
    Jan 26, 2016
    United States
    That Nightly Site™
    They could change the firmware keys again, like they did with the n3ds that caused us to be stuck on 9.6 EmuNAND with the n3ds.
     
  10. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    I think they would need a new hardware revision to do that. as far as I know, the keys to decrypt the 9.6+ firmware were always included with the New3DS, but were not used until 9.6.
     
    astronautlevel likes this.
  11. astronautlevel

    astronautlevel But he's a guy

    Member
    3,909
    4,577
    Jan 26, 2016
    United States
    That Nightly Site™
    That makes more sense then. I was wondering how they had managed to switch the encryption keys.

    Learn something new every day.