Can't get Hollow Knight running well

Discussion in 'Computer Games and General Discussion' started by invaderyoyo, Aug 5, 2017.

  1. invaderyoyo
    OP

    invaderyoyo invader

    Member
    786
    401
    Mar 17, 2014
    United States
    Southern California
    I bought Hollow Knight on Steam a few days ago and I can't get get it to run well. I've been reading stuff online and tweaking the settings, but no dice. It's playable, but it stutters at the worst moments. It's super annoying. These are my specs:

    [​IMG]

    I know they're bad specs, but this game uses freaking sprites, it should work. I tried turning down the particles and resolution. I also tried turning off v-sync and using a frame limiter, nothing.

    Any advice would be appreciated.
     
  2. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,632
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    if this didn't help at all probably is a cpu bottleneck...
    you are using the GPU right? laptops can have the problem of the GPU not kicking in...
    the game kinda looks it's using flash? like the first binding of isaac, theese usually even with plenty of power they make the pc struggle..
    run the game in window and check in the task manager if the CPU percentage in that process is stuck at 25% or 50%, if the game properly uses multi threads, you will see 100% cpu usage..

    i also recommend to check Vram usage... (i think you can use msi afterburner for this?)
     
    invaderyoyo likes this.
  3. Felek666

    Felek666 Demonically Uncontrollable

    Member
    3,514
    3,933
    Jan 3, 2017
    Poland
    reddit.com/r/satania/
    Hollow Knight doesn't use flash.
     
    migles likes this.
  4. invaderyoyo
    OP

    invaderyoyo invader

    Member
    786
    401
    Mar 17, 2014
    United States
    Southern California
    Thanks for the advice. Yeah, I'm using the GPU, otherwise it turns into a slideshow. You might be right about the cpu usage. Looks like it's not using much. Any way to fix that?
    Warning: Spoilers inside!
     
  5. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,632
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    i mean, if the cpu is stuck at a percentage (since you have 4 threads, it can be 25, 50, or 100) it means the cpu was bottlenecking..
    if the cpu is not doing that, it can be your graphics card, in which you should check with msi afterburner if your gpu usage is at 100% or Vram full...

    btw, double check if your laptop is in power saving mode, change it into performance...
     
  6. invaderyoyo
    OP

    invaderyoyo invader

    Member
    786
    401
    Mar 17, 2014
    United States
    Southern California
    It's definitely in performance mode. I'm not sure what I'm looking for in msi afterburner. I'll read up on it.
    Warning: Spoilers inside!
     
  7. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,632
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    go to settings, change the skin into default msi afterburner V3 skin.
    that way you can see the graphs easier..
    check if GPU usage is at 100% or Vram is full
    in monitoring tab in settings you can also enable on screen display so thisn info is displayed above the game
    if your GPU usage or Vram is full, this means the graphic card can't keep up with that game..
    but it's weird the game requires so low specs.. it should run fine
     
  8. invaderyoyo
    OP

    invaderyoyo invader

    Member
    786
    401
    Mar 17, 2014
    United States
    Southern California
    Couldn't figure out how to display VRAM, but this is what I got while fighting a big enemy. The CPU usage does go pretty high.
    Warning: Spoilers inside!
     
  9. jDSX

    jDSX LUEicide

    Member
    983
    1,572
    Jun 15, 2015
    United States
    Happy furry land with Lucar
    It may be something else, did you recently update drivers on your laptop old ones they can hold you back considerably also check on your HDD make sure it's not failing because that sounds bad

    I have a laptop (dell 5440) with the 4210u and just intel hd graphics with windows 10 and I booted up hollow knight just to see if I got the same issue as you are having, and it runs fine.
     
  10. invaderyoyo
    OP

    invaderyoyo invader

    Member
    786
    401
    Mar 17, 2014
    United States
    Southern California
    Hmm, I recently reset my computer. It might be the drivers. I was having trouble installing the newest one for the GPU.