can't get 2 out of 22 games to run via USB on 3.2E wii

Discussion in 'Wii - Backup Loaders' started by Smiff, Nov 3, 2009.

  1. Smiff
    OP

    Newcomer Smiff Advanced Member

    Joined:
    Mar 22, 2004
    Messages:
    79
    Country:
    I wonder if someone can help please because i'm quite stuck.

    My wii is an old model running 3.2E.
    I have Bootmii installed as boot2, preloader 0.29, HBC 1.0.6 and lots of USB loaders.
    CIOS38 rev14 as 249 and Hermes rev4 IOS as 222 (38 merge 37, I think)

    All my games (around 22) are original PAL bought in the UK.

    I have 2 (only 2) games which won't load through any USB loader (have GX, Wiiflow and NeoGamma)
    These 2 games are Wario Land Shake Dimension and Wii Sports Resort (yes, i know there's load of threads and yes i've read loads of threads. from this reading i have confirmed that it is possible to get WSR to run on 3.2E system. I have watched the intro video once by loading from disc in NeoGamma and saved so alt-dol isn't the issue either).

    I have tried installing IOS 38, 53 and 55 manually by extracting them from WSR and installing with WAD Manager. They are not the latest versions according to Pimp My Wii. This seemed to make no difference to any of my games (at least nothing else is broken!).

    Interestingly, those 2 games (that i can't get to load via USB) DO both work when booted from the original disc through NeoGamma so I *think* this means I have the right system IOS installed for them? (does it mean that?)
    But when I try to start those 2 games through a USB loader (GX is my main loader), they always hang at a black screen and have to force power off. They don't seem to be getting far into booting at all. NeoGamma R7, with default options, says "launching game" and gets stuck there, then eventually drops back to its first menu). My other 20 games which includes titles like No More Heroes, Overkill, Bash Party, SSBB - a mix of old and new titles but mostly old) are totally fine. I don't know what else might not work because i don't pirate games.

    Usb loader settings don't see to help. No 002 errors. Does not appear to be a region error (both games and wii are PAL anyway).

    My next step was going to be to make another backup of NAND and try using the "safe updater" to update my system to version 4.2E in the hope that something, I don't know what, might fix the 2 games.
    I thought i'd ask first because i don't really want to update my wii since everything else works well and i'm not interested in the new Nintendo features (or possibly bricking my wii now that it has a strange mix of IOS installed).

    Now that I have 2 games that don't work (just bought WSR) I hoped somebody might seen the connection between them and black screen hangs.

    many thanks in advance, I don't often ask for help and have helped others here so would much appreciate any suggestions!
     
  2. usptactical

    Member usptactical GBAtemp Fan

    Joined:
    Apr 7, 2009
    Messages:
    317
    Country:
    United States
    fwiw, I got WSR working on my friend's 3.4u Wii by doing the following (using 249 rev14):
    1. Install original game disk on hdd ( I used cfg loader with wbfs partition )
    2. In cfg loader, select alt-dol (player.dol) and watch the video. When the video is over, the System Menu comes up.
    3. In cfg loader, do not select alt-dol and just run the game

    There are the same directions that everyone else has posted. I have a 3.2u Wii, but my WSR is still boxed until Christmas.
     
  3. Smiff
    OP

    Newcomer Smiff Advanced Member

    Joined:
    Mar 22, 2004
    Messages:
    79
    Country:
    Is it possible GX is messing up the rips? (all my games were ripped with loader gX)
    I will try reripping with cfg loader now thanks.

    edit: holy h*ll i love you, WSR worked from USB after deleting it, using CFG Loader to rip and run it! amazing. now to check if it works with other loaders with the new rip.
    edit2: yep, now works when run from GX aswell. just trying the same with Wario.
    ok Wario was the same problem, that also works from any loader after reripping with cfg loader.

    so there appears to be something wrong with USB loader GX's ripping, (perhaps on games with update partitions?) which i never thought of and have never once seen suggested either!
    probably should report over there then.. thanks. I guess so many people pirated this game it wasn't found.
     

Share This Page